diff mbox series

[meta-oe,v2] volatile-binds: Calculate the name of the /var/lib service

Message ID 20230828175255.18811-2-sveyret@gmail.com
State Accepted, archived
Commit 66f0c2a1678cb69cf8d50372b0592c55e2dc3e3c
Headers show
Series [meta-oe,v2] volatile-binds: Calculate the name of the /var/lib service | expand

Commit Message

Stéphane Veyret Aug. 28, 2023, 5:52 p.m. UTC
By default, /var/lib is bind mounted on /var/volatile/lib. If this is
the case, the recipe adds conditions on systemd-random-seed in the
service file mounting it. But as the VOLATILE_BINDS may be modified,
/var/lib may be mounted elsewhere, for example in /persistent/var/lib.
In this case, the conditions are not set because the service file name
does not match expected one.
This patch automatically records the name of the service mounting
/var/lib, if any, in order to set the condition in the appropriate file.

Signed-off-by: Stéphane Veyret <sveyret@gmail.com>
---
 .../volatile-binds/volatile-binds.bb           | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

Comments

Stéphane Veyret Oct. 28, 2023, 8:17 a.m. UTC | #1
Hello,

This patch and the previous one (https://lists.openembedded.org/g/openembedded-core/message/186778) have not been integrated yet. Have they been forgotten, should I do some modifications, or have they been definitly rejected ?

Thanks.
Randy MacLeod Oct. 31, 2023, 12:02 a.m. UTC | #2
On 2023-10-28 4:17 a.m., Stéphane Veyret via lists.openembedded.org wrote:
> Hello,
>
> This patch and the previous one 
> (https://lists.openembedded.org/g/openembedded-core/message/186778) 
> have not been integrated yet. Have they been forgotten, should I do 
> some modifications, or have they been definitly rejected ?

Hi Stephane,

The [meta-oe] prefix may have confused people anyway,
the two commits were merged this morning:

https://git.openembedded.org/openembedded-core/log/

https://git.openembedded.org/openembedded-core/commit/?id=66f0c2a1678cb69cf8d50372b0592c55e2dc3e3c

https://git.openembedded.org/openembedded-core/commit/?id=1ca031b77546056ca1994469b0f2e93ea2018edf

Thanks,

../Randy

>
> Thanks.
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#189760):https://lists.openembedded.org/g/openembedded-core/message/189760
> Mute This Topic:https://lists.openembedded.org/mt/101015300/3616765
> Group Owner:openembedded-core+owner@lists.openembedded.org
> Unsubscribe:https://lists.openembedded.org/g/openembedded-core/unsub  [randy.macleod@windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-core/volatile-binds/volatile-binds.bb b/meta/recipes-core/volatile-binds/volatile-binds.bb
index 3fefa9abde..cca8a65fb4 100644
--- a/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -16,10 +16,10 @@  inherit allarch systemd features_check
 REQUIRED_DISTRO_FEATURES = "systemd"
 
 VOLATILE_BINDS ?= "\
-    /var/volatile/lib /var/lib\n\
-    /var/volatile/cache /var/cache\n\
-    /var/volatile/spool /var/spool\n\
-    /var/volatile/srv /srv\n\
+    ${localstatedir}/volatile/lib ${localstatedir}/lib\n\
+    ${localstatedir}/volatile/cache ${localstatedir}/cache\n\
+    ${localstatedir}/volatile/spool ${localstatedir}/spool\n\
+    ${localstatedir}/volatile/srv /srv\n\
 "
 VOLATILE_BINDS[type] = "list"
 VOLATILE_BINDS[separator] = "\n"
@@ -46,8 +46,8 @@  do_compile () {
             continue
         fi
 
-        servicefile="${spec#/}"
-        servicefile="$(echo "$servicefile" | tr / -).service"
+        servicefile="$(echo "${spec#/}" | tr / -).service"
+        [ "$mountpoint" != ${localstatedir}/lib ] || var_lib_servicefile=$servicefile
         sed -e "s#@what@#$spec#g; s#@where@#$mountpoint#g" \
             -e "s#@whatparent@#${spec%/*}#g; s#@whereparent@#${mountpoint%/*}#g" \
             -e "s#@avoid_overlayfs@#${@d.getVar('AVOID_OVERLAYFS')}#g" \
@@ -56,12 +56,12 @@  do_compile () {
 ${@d.getVar('VOLATILE_BINDS').replace("\\n", "\n")}
 END
 
-    if [ -e var-volatile-lib.service ]; then
+    if [ -e "$var_lib_servicefile" ]; then
         # As the seed is stored under /var/lib, ensure that this service runs
         # after the volatile /var/lib is mounted.
         sed -i -e "/^Before=/s/\$/ systemd-random-seed.service/" \
                -e "/^WantedBy=/s/\$/ systemd-random-seed.service/" \
-               var-volatile-lib.service
+               "$var_lib_servicefile"
     fi
 }
 do_compile[dirs] = "${WORKDIR}"
@@ -78,7 +78,7 @@  do_install () {
 
     # Suppress attempts to process some tmpfiles that are not temporary.
     #
-    install -d ${D}${sysconfdir}/tmpfiles.d ${D}/var/cache
+    install -d ${D}${sysconfdir}/tmpfiles.d ${D}${localstatedir}/cache
     ln -s /dev/null ${D}${sysconfdir}/tmpfiles.d/etc.conf
     ln -s /dev/null ${D}${sysconfdir}/tmpfiles.d/home.conf
 }