diff mbox series

[meta-networking,PATCHv3] spice-guest-vdagent: add recipe

Message ID 20230825161733.3279-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-networking,PATCHv3] spice-guest-vdagent: add recipe | expand

Commit Message

Markus Volk Aug. 25, 2023, 4:17 p.m. UTC
The spice-vdagent needs to be running alongside qemu-guest-agent on
virtualizationguest systems that are using the spice protocol to
get seamless integration.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../spice/spice-guest-vdagent_0.22.1.bb       | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb

Comments

Martin Jansa Aug. 30, 2023, 7:23 a.m. UTC | #1
On Fri, Aug 25, 2023 at 6:17 PM Markus Volk <f_l_k@t-online.de> wrote:

> The spice-vdagent needs to be running alongside qemu-guest-agent on
> virtualizationguest systems that are using the spice protocol to
> get seamless integration.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../spice/spice-guest-vdagent_0.22.1.bb       | 25 +++++++++++++++++++
>  1 file changed, 25 insertions(+)
>  create mode 100644 meta-networking/recipes-support/spice/
> spice-guest-vdagent_0.22.1.bb
>
> diff --git a/meta-networking/recipes-support/spice/
> spice-guest-vdagent_0.22.1.bb b/meta-networking/recipes-support/spice/
> spice-guest-vdagent_0.22.1.bb
> new file mode 100644
> index 0000000000..b51e03899f
> --- /dev/null
> +++ b/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb
> @@ -0,0 +1,25 @@
> +SUMMARY = "Spice agent for Linux"
> +HOMEPAGE = "https://spice-space.org"
> +LICENSE = "GPL-3.0-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
> +
> +SRCREV = "aa08162f036840d3e33502dc0a836b03b9cec97c"
> +
> +SRC_URI = "git://
> gitlab.freedesktop.org/spice/linux/vd_agent.git;protocol=https;branch=master
> "
> +
> +S = "${WORKDIR}/git"
> +
> +ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
> +REQUIRED_DISTRO_FEATURES = "opengl"
>

Looks like it needs x11 as well together with few additional deps, in
builds without x11 enabled it fails with:

| checking for gtk4 >= 3.98... yes
| checking for gio-unix-2.0 >= 2.50... yes
| checking for xfixes xrandr >= 1.3 xinerama x11... no
| configure: error: Package requirements (xfixes xrandr >= 1.3 xinerama
x11) were not met:
|
| No package 'xfixes' found
| No package 'xrandr' found
| No package 'xinerama' found
| No package 'x11' found


> +
> +inherit autotools pkgconfig features_check
> +
> +DEPENDS = "glib-2.0 alsa-lib gtk4 dbus libdrm spice-protocol"
> +
> +EXTRA_OECONF = " \
> +       --with-gtk4 \
> +       --enable-pie \
> +"
> +
> +FILES:${PN} += "${datadir}"
> +
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104610):
> https://lists.openembedded.org/g/openembedded-devel/message/104610
> Mute This Topic: https://lists.openembedded.org/mt/100958762/3617156
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> Martin.Jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb b/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb
new file mode 100644
index 0000000000..b51e03899f
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-guest-vdagent_0.22.1.bb
@@ -0,0 +1,25 @@ 
+SUMMARY = "Spice agent for Linux"
+HOMEPAGE = "https://spice-space.org"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRCREV = "aa08162f036840d3e33502dc0a836b03b9cec97c"
+
+SRC_URI = "git://gitlab.freedesktop.org/spice/linux/vd_agent.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+inherit autotools pkgconfig features_check
+
+DEPENDS = "glib-2.0 alsa-lib gtk4 dbus libdrm spice-protocol"
+
+EXTRA_OECONF = " \
+	--with-gtk4 \
+	--enable-pie \
+"
+
+FILES:${PN} += "${datadir}"
+