diff mbox series

[meta-oe] libvpx: fix VPXTARGET for non-neon armv7a

Message ID 20230822101443.715588-1-bbara93@gmail.com
State New
Headers show
Series [meta-oe] libvpx: fix VPXTARGET for non-neon armv7a | expand

Commit Message

Benjamin Bara Aug. 22, 2023, 10:14 a.m. UTC
From: Benjamin Bara <benjamin.bara@skidata.com>

The compiler might use non-supported instructions, as the build config
requires armv7-linux-gcc targets to have NEON[1] and drops the mtune
value[2], which also might use d32 registers on d16 cpus.

Falling back to the generic-gnu target respects the toolchain-set values
and should therefore be used instead.

[1] https://chromium.googlesource.com/webm/libvpx/+/626ff35955c2c35b806b3e0ecf551a1a8611cdbf/build/make/configure.sh#955
[2] https://chromium.googlesource.com/webm/libvpx/+/626ff35955c2c35b806b3e0ecf551a1a8611cdbf/build/make/configure.sh#973

Signed-off-by: Benjamin Bara <benjamin.bara@skidata.com>
---
 meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
index 79b330c31..558b448ba 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.13.0.bb
@@ -26,7 +26,7 @@  export LD = "${CC}"
 
 VPXTARGET:armv5te = "armv5te-linux-gcc"
 VPXTARGET:armv6 = "armv6-linux-gcc"
-VPXTARGET:armv7a = "armv7-linux-gcc"
+VPXTARGET:armv7a = "${@bb.utils.contains("TUNE_FEATURES","neon","armv7-linux-gcc","generic-gnu",d)}"
 VPXTARGET ?= "generic-gnu"
 
 CONFIGUREOPTS = " \