diff mbox series

arm/linux-yocto: change defconfig patch for 6.4

Message ID 20230820215106.3643758-1-jon.mason@arm.com
State New
Headers show
Series arm/linux-yocto: change defconfig patch for 6.4 | expand

Commit Message

Jon Mason Aug. 20, 2023, 9:51 p.m. UTC
Use the patch that Mikko Rapeli is trying to upstream to work around the
Nuvoton defconfig issue instead of reverting the patch that added the
platform to the kernel.

Signed-off-by: Jon Mason <jon.mason@arm.com>
---
 ...g-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch | 50 +++++++++++++++++++
 ...config-Add-Nuvoton-NPCM-family-suppo.patch | 45 -----------------
 .../linux/linux-yocto%.bbappend               |  5 ++
 .../linux/linux-yocto-rt_6.1%.bbappend        |  1 -
 .../linux/linux-yocto_6.1%.bbappend           |  1 -
 5 files changed, 55 insertions(+), 47 deletions(-)
 create mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
 delete mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch

Comments

Mikko Rapeli Aug. 21, 2023, 12:59 p.m. UTC | #1
Hi,

On Sun, Aug 20, 2023 at 04:51:06PM -0500, Jon Mason wrote:
> Use the patch that Mikko Rapeli is trying to upstream to work around the
> Nuvoton defconfig issue instead of reverting the patch that added the
> platform to the kernel.
> 
> Signed-off-by: Jon Mason <jon.mason@arm.com>
> ---
>  ...g-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch | 50 +++++++++++++++++++
>  ...config-Add-Nuvoton-NPCM-family-suppo.patch | 45 -----------------
>  .../linux/linux-yocto%.bbappend               |  5 ++
>  .../linux/linux-yocto-rt_6.1%.bbappend        |  1 -
>  .../linux/linux-yocto_6.1%.bbappend           |  1 -
>  5 files changed, 55 insertions(+), 47 deletions(-)
>  create mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
>  delete mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch
> 
> diff --git a/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
> new file mode 100644
> index 00000000..d7f01853
> --- /dev/null
> +++ b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
> @@ -0,0 +1,50 @@
> +From 94a5e7ffe5855272708a94190820534c4f51bdd8 Mon Sep 17 00:00:00 2001
> +From: Mikko Rapeli <mikko.rapeli@linaro.org>
> +Date: Tue, 15 Aug 2023 10:36:56 +0300
> +Subject: [PATCH] arm64: defconfig: remove CONFIG_COMMON_CLK_NPCM8XX=y
> +
> +There is no code for this config option and enabling it in defconfig
> +causes warnings from tools which are detecting unused and obsolete
> +kernel config flags since the flag will be completely missing from
> +effective build config after "make olddefconfig".
> +
> +Fixes yocto kernel recipe build time warning:
> +
> +WARNING: [kernel config]: This BSP contains fragments with warnings:
> +...
> +[INFO]: the following symbols were not found in the active
> +configuration:
> +     - CONFIG_COMMON_CLK_NPCM8XX
> +
> +The flag was added with commit 45472f1e5348c7b755b4912f2f529ec81cea044b
> +v5.19-rc4-15-g45472f1e5348 so 6.1 and 6.4 stable kernel trees are
> +affected.
> +
> +Fixes: 45472f1e5348c7b755b4912f2f529ec81cea044b ("arm64: defconfig: Add Nuvoton NPCM family support")
> +Cc: stable@kernel.org
> +Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> +Cc: Jon Mason <jon.mason@arm.com>
> +Cc: Jon Mason <jdmason@kudzu.us>
> +Cc: Ross Burton <ross@burtonini.com>
> +Cc: Arnd Bergmann <arnd@arndb.de>
> +Signed-off-by: Mikko Rapeli <mikko.rapeli@linaro.org>
> +
> +Signed-off-by: Jon Mason <jon.mason@arm.com>
> +Upstream-Status: Inappropriate

Upstream-Status: Submitted [https://lists.infradead.org/pipermail/linux-arm-kernel/2023-August/859760.html]

Cheers,

-Mikko
Jon Mason Aug. 21, 2023, 2:10 p.m. UTC | #2
On Mon, Aug 21, 2023 at 03:59:45PM +0300, Mikko Rapeli wrote:
> Hi,
> 
> On Sun, Aug 20, 2023 at 04:51:06PM -0500, Jon Mason wrote:
> > Use the patch that Mikko Rapeli is trying to upstream to work around the
> > Nuvoton defconfig issue instead of reverting the patch that added the
> > platform to the kernel.
> > 
> > Signed-off-by: Jon Mason <jon.mason@arm.com>
> > ---
> >  ...g-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch | 50 +++++++++++++++++++
> >  ...config-Add-Nuvoton-NPCM-family-suppo.patch | 45 -----------------
> >  .../linux/linux-yocto%.bbappend               |  5 ++
> >  .../linux/linux-yocto-rt_6.1%.bbappend        |  1 -
> >  .../linux/linux-yocto_6.1%.bbappend           |  1 -
> >  5 files changed, 55 insertions(+), 47 deletions(-)
> >  create mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
> >  delete mode 100644 meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch
> > 
> > diff --git a/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
> > new file mode 100644
> > index 00000000..d7f01853
> > --- /dev/null
> > +++ b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
> > @@ -0,0 +1,50 @@
> > +From 94a5e7ffe5855272708a94190820534c4f51bdd8 Mon Sep 17 00:00:00 2001
> > +From: Mikko Rapeli <mikko.rapeli@linaro.org>
> > +Date: Tue, 15 Aug 2023 10:36:56 +0300
> > +Subject: [PATCH] arm64: defconfig: remove CONFIG_COMMON_CLK_NPCM8XX=y
> > +
> > +There is no code for this config option and enabling it in defconfig
> > +causes warnings from tools which are detecting unused and obsolete
> > +kernel config flags since the flag will be completely missing from
> > +effective build config after "make olddefconfig".
> > +
> > +Fixes yocto kernel recipe build time warning:
> > +
> > +WARNING: [kernel config]: This BSP contains fragments with warnings:
> > +...
> > +[INFO]: the following symbols were not found in the active
> > +configuration:
> > +     - CONFIG_COMMON_CLK_NPCM8XX
> > +
> > +The flag was added with commit 45472f1e5348c7b755b4912f2f529ec81cea044b
> > +v5.19-rc4-15-g45472f1e5348 so 6.1 and 6.4 stable kernel trees are
> > +affected.
> > +
> > +Fixes: 45472f1e5348c7b755b4912f2f529ec81cea044b ("arm64: defconfig: Add Nuvoton NPCM family support")
> > +Cc: stable@kernel.org
> > +Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> > +Cc: Jon Mason <jon.mason@arm.com>
> > +Cc: Jon Mason <jdmason@kudzu.us>
> > +Cc: Ross Burton <ross@burtonini.com>
> > +Cc: Arnd Bergmann <arnd@arndb.de>
> > +Signed-off-by: Mikko Rapeli <mikko.rapeli@linaro.org>
> > +
> > +Signed-off-by: Jon Mason <jon.mason@arm.com>
> > +Upstream-Status: Inappropriate
> 
> Upstream-Status: Submitted [https://lists.infradead.org/pipermail/linux-arm-kernel/2023-August/859760.html]

Good catch, patch updated (not resending, as this is a fairly trivial
change).

Thanks,
Jon

> 
> Cheers,
> 
> -Mikko
>
Jon Mason Aug. 21, 2023, 10:04 p.m. UTC | #3
On Sun, 20 Aug 2023 16:51:06 -0500, Jon Mason wrote:
> Use the patch that Mikko Rapeli is trying to upstream to work around the
> Nuvoton defconfig issue instead of reverting the patch that added the
> platform to the kernel.
> 
> 

Applied, thanks!

[1/1] arm/linux-yocto: change defconfig patch for 6.4
      commit: 5b8329a99f5fb6497575612ae677e03decf2e3b2

Best regards,
diff mbox series

Patch

diff --git a/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
new file mode 100644
index 00000000..d7f01853
--- /dev/null
+++ b/meta-arm/recipes-kernel/linux/files/aarch64/0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch
@@ -0,0 +1,50 @@ 
+From 94a5e7ffe5855272708a94190820534c4f51bdd8 Mon Sep 17 00:00:00 2001
+From: Mikko Rapeli <mikko.rapeli@linaro.org>
+Date: Tue, 15 Aug 2023 10:36:56 +0300
+Subject: [PATCH] arm64: defconfig: remove CONFIG_COMMON_CLK_NPCM8XX=y
+
+There is no code for this config option and enabling it in defconfig
+causes warnings from tools which are detecting unused and obsolete
+kernel config flags since the flag will be completely missing from
+effective build config after "make olddefconfig".
+
+Fixes yocto kernel recipe build time warning:
+
+WARNING: [kernel config]: This BSP contains fragments with warnings:
+...
+[INFO]: the following symbols were not found in the active
+configuration:
+     - CONFIG_COMMON_CLK_NPCM8XX
+
+The flag was added with commit 45472f1e5348c7b755b4912f2f529ec81cea044b
+v5.19-rc4-15-g45472f1e5348 so 6.1 and 6.4 stable kernel trees are
+affected.
+
+Fixes: 45472f1e5348c7b755b4912f2f529ec81cea044b ("arm64: defconfig: Add Nuvoton NPCM family support")
+Cc: stable@kernel.org
+Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
+Cc: Jon Mason <jon.mason@arm.com>
+Cc: Jon Mason <jdmason@kudzu.us>
+Cc: Ross Burton <ross@burtonini.com>
+Cc: Arnd Bergmann <arnd@arndb.de>
+Signed-off-by: Mikko Rapeli <mikko.rapeli@linaro.org>
+
+Signed-off-by: Jon Mason <jon.mason@arm.com>
+Upstream-Status: Inappropriate
+
+---
+ arch/arm64/configs/defconfig | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/arch/arm64/configs/defconfig b/arch/arm64/configs/defconfig
+index 0777bcae9104..1cf24537fda2 100644
+--- a/arch/arm64/configs/defconfig
++++ b/arch/arm64/configs/defconfig
+@@ -1146,7 +1146,6 @@ CONFIG_COMMON_CLK_S2MPS11=y
+ CONFIG_COMMON_CLK_PWM=y
+ CONFIG_COMMON_CLK_RS9_PCIE=y
+ CONFIG_COMMON_CLK_VC5=y
+-CONFIG_COMMON_CLK_NPCM8XX=y
+ CONFIG_COMMON_CLK_BD718XX=m
+ CONFIG_CLK_RASPBERRYPI=m
+ CONFIG_CLK_IMX8MM=y
diff --git a/meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch b/meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch
deleted file mode 100644
index d5b5363a..00000000
--- a/meta-arm/recipes-kernel/linux/files/aarch64/0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch
+++ /dev/null
@@ -1,45 +0,0 @@ 
-From 891eeb87cddb0d52bc9eac39afcca5027a660be6 Mon Sep 17 00:00:00 2001
-From: Jon Mason <jdmason@kudzu.us>
-Date: Fri, 3 Feb 2023 05:21:07 -0500
-Subject: [PATCH 2/2] Revert "arm64: defconfig: Add Nuvoton NPCM family
- support"
-
-This reverts commit 45472f1e5348c7b755b4912f2f529ec81cea044b
-
-Signed-off-by: Jon Mason <jon.mason@arm.com>
-Upstream-Status: Inappropriate
----
- arch/arm64/configs/defconfig | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/arch/arm64/configs/defconfig b/arch/arm64/configs/defconfig
-index 70919b241469..4f09b80a1b96 100644
---- a/arch/arm64/configs/defconfig
-+++ b/arch/arm64/configs/defconfig
-@@ -51,7 +51,6 @@ CONFIG_ARCH_MESON=y
- CONFIG_ARCH_MVEBU=y
- CONFIG_ARCH_NXP=y
- CONFIG_ARCH_MXC=y
--CONFIG_ARCH_NPCM=y
- CONFIG_ARCH_QCOM=y
- CONFIG_ARCH_RENESAS=y
- CONFIG_ARCH_ROCKCHIP=y
-@@ -637,7 +636,6 @@ CONFIG_UNIPHIER_WATCHDOG=y
- CONFIG_PM8916_WATCHDOG=m
- CONFIG_BCM2835_WDT=y
- CONFIG_BCM7038_WDT=m
--CONFIG_NPCM7XX_WATCHDOG=y
- CONFIG_MFD_ALTERA_SYSMGR=y
- CONFIG_MFD_BD9571MWV=y
- CONFIG_MFD_AXP20X_I2C=y
-@@ -1049,7 +1047,6 @@ CONFIG_COMMON_CLK_FSL_SAI=y
- CONFIG_COMMON_CLK_S2MPS11=y
- CONFIG_COMMON_CLK_PWM=y
- CONFIG_COMMON_CLK_VC5=y
--CONFIG_COMMON_CLK_NPCM8XX=y
- CONFIG_COMMON_CLK_BD718XX=m
- CONFIG_CLK_RASPBERRYPI=m
- CONFIG_CLK_IMX8MM=y
--- 
-2.30.2
-
diff --git a/meta-arm/recipes-kernel/linux/linux-yocto%.bbappend b/meta-arm/recipes-kernel/linux/linux-yocto%.bbappend
index 0a42ce4a..9d5266ba 100644
--- a/meta-arm/recipes-kernel/linux/linux-yocto%.bbappend
+++ b/meta-arm/recipes-kernel/linux/linux-yocto%.bbappend
@@ -1,5 +1,10 @@ 
 ARMFILESPATHS := "${THISDIR}/files:"
 
+FILESEXTRAPATHS:prepend:aarch64 = "${ARMFILESPATHS}"
+SRC_URI:append:aarch64 = " \
+     file://0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch \
+    "
+
 COMPATIBLE_MACHINE:generic-arm64 = "generic-arm64"
 FILESEXTRAPATHS:prepend:generic-arm64 = "${ARMFILESPATHS}"
 SRC_URI:append:generic-arm64 = " \
diff --git a/meta-arm/recipes-kernel/linux/linux-yocto-rt_6.1%.bbappend b/meta-arm/recipes-kernel/linux/linux-yocto-rt_6.1%.bbappend
index d0a0ff0e..4d3beb1d 100644
--- a/meta-arm/recipes-kernel/linux/linux-yocto-rt_6.1%.bbappend
+++ b/meta-arm/recipes-kernel/linux/linux-yocto-rt_6.1%.bbappend
@@ -2,6 +2,5 @@ 
 FILESEXTRAPATHS:prepend:aarch64 = "${ARMFILESPATHS}"
 SRC_URI:append:aarch64 = " \
     file://0001-Revert-arm64-defconfig-Enable-Tegra-MGBE-driver.patch \
-    file://0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch \
     file://0001-gcc-plugins-Reorganize-gimple-includes-for-GCC-13.patch \
     "
diff --git a/meta-arm/recipes-kernel/linux/linux-yocto_6.1%.bbappend b/meta-arm/recipes-kernel/linux/linux-yocto_6.1%.bbappend
index d0a0ff0e..4d3beb1d 100644
--- a/meta-arm/recipes-kernel/linux/linux-yocto_6.1%.bbappend
+++ b/meta-arm/recipes-kernel/linux/linux-yocto_6.1%.bbappend
@@ -2,6 +2,5 @@ 
 FILESEXTRAPATHS:prepend:aarch64 = "${ARMFILESPATHS}"
 SRC_URI:append:aarch64 = " \
     file://0001-Revert-arm64-defconfig-Enable-Tegra-MGBE-driver.patch \
-    file://0002-Revert-arm64-defconfig-Add-Nuvoton-NPCM-family-suppo.patch \
     file://0001-gcc-plugins-Reorganize-gimple-includes-for-GCC-13.patch \
     "