diff mbox series

[meta-oe,v2] libfaketime: add recipe

Message ID 20230818091617.24061-1-tymoteusz.burak@3mdeb.com
State New
Headers show
Series [meta-oe,v2] libfaketime: add recipe | expand

Commit Message

Tymoteusz Burak Aug. 18, 2023, 9:16 a.m. UTC
This commit adds the libfaketime library recipe, which provides time
manipulation capabilities for testing and debugging purposes. libfaketime allows
developers to modify the system time reported to applications, aiding in scenarios
where accurate time emulation is required.

GitHub Repository: https://github.com/wolfcw/libfaketime

Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
---
 .../libfaketime/libfaketime_0.9.10.bb         | 35 +++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
new file mode 100644
index 000000000000..b49491bccbd8
--- /dev/null
+++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
@@ -0,0 +1,35 @@ 
+DESCRIPTION = "A library for faking the system time in user-space programs"
+SECTION = "libs"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+TAG = "v${PV}"
+
+SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
+SRC_URI = "\
+    git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
+    "
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += "\
+    EXTRA_FLAGS='-Wno-error=nonnull-compare' \
+    "
+
+do_configure[noexec] = "1"
+do_compile () {
+    oe_runmake
+}
+do_install () {
+    install -d ${D}${libdir}/faketime
+    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
+    install -d ${D}${bindir}
+    install -m 0755 src/faketime ${D}${bindir}
+}
+
+PACKAGES =+ "lib${PN}"
+
+FILES:${PN} = "${bindir}/faketime"
+FILES:lib${PN} = "${libdir}/faketime/*"
+
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:lib${PN} += "dev-so"