diff mbox series

[meta-python,v2] python3-can: Update runtime dependencies

Message ID 20230817092034.26410-1-frieder@fris.de
State New
Headers show
Series [meta-python,v2] python3-can: Update runtime dependencies | expand

Commit Message

Frieder Schrempf Aug. 17, 2023, 9:20 a.m. UTC
From: Frieder Schrempf <frieder.schrempf@kontron.de>

According to the setup.py of v4.2.2 [1] the following runtime
dependencies are currently missing. Add them.

* packaging
* setuptools

Also the aenum dependency was droppen in v4.0.0 [2], so let's
remove it.

[1] https://github.com/hardbyte/python-can/blob/4.2.2/setup.py
[2] https://github.com/hardbyte/python-can/commit/13625ea2cc18e3283b8111bec7e139ed9b6c7f48

Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
---
Changes in v2:
* Drop unused aenum dependency
* Update subject and commit message
---
 meta-python/recipes-devtools/python/python3-can_4.2.2.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Frieder Schrempf Aug. 22, 2023, 7:12 a.m. UTC | #1
Hi Khem,

On 17.08.23 11:20, Frieder Schrempf wrote:
> From: Frieder Schrempf <frieder.schrempf@kontron.de>
> 
> According to the setup.py of v4.2.2 [1] the following runtime
> dependencies are currently missing. Add them.
> 
> * packaging
> * setuptools
> 
> Also the aenum dependency was droppen in v4.0.0 [2], so let's
> remove it.
> 
> [1] https://github.com/hardbyte/python-can/blob/4.2.2/setup.py
> [2] https://github.com/hardbyte/python-can/commit/13625ea2cc18e3283b8111bec7e139ed9b6c7f48
> 
> Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
> ---
> Changes in v2:
> * Drop unused aenum dependency
> * Update subject and commit message
> ---

I've sent this v2 a few minutes after the v1, but I see v1 was applied
on master-next. It's not a big deal but I still want to ask if there is
anything I can improve to avoid this in the future?

Thanks
Frieder
Khem Raj Aug. 22, 2023, 8:01 p.m. UTC | #2
On Tue, Aug 22, 2023 at 12:12 AM Frieder Schrempf
<frieder.schrempf@kontron.de> wrote:
>
> Hi Khem,
>
> On 17.08.23 11:20, Frieder Schrempf wrote:
> > From: Frieder Schrempf <frieder.schrempf@kontron.de>
> >
> > According to the setup.py of v4.2.2 [1] the following runtime
> > dependencies are currently missing. Add them.
> >
> > * packaging
> > * setuptools
> >
> > Also the aenum dependency was droppen in v4.0.0 [2], so let's
> > remove it.
> >
> > [1] https://github.com/hardbyte/python-can/blob/4.2.2/setup.py
> > [2] https://github.com/hardbyte/python-can/commit/13625ea2cc18e3283b8111bec7e139ed9b6c7f48
> >
> > Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
> > ---
> > Changes in v2:
> > * Drop unused aenum dependency
> > * Update subject and commit message
> > ---
>
> I've sent this v2 a few minutes after the v1, but I see v1 was applied
> on master-next. It's not a big deal but I still want to ask if there is
> anything I can improve to avoid this in the future?
>

Usually, I look out for v2 intently if v1 has some issues if I have
picked it and it might be timing that I missed it.
please send the incremental changes as a separate patch so we can
address issues that are still remaining.

> Thanks
> Frieder
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-can_4.2.2.bb b/meta-python/recipes-devtools/python/python3-can_4.2.2.bb
index 7ecbf1207..32b5ad101 100644
--- a/meta-python/recipes-devtools/python/python3-can_4.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-can_4.2.2.bb
@@ -10,7 +10,6 @@  PYPI_PACKAGE="python-can"
 inherit pypi setuptools3
 
 RDEPENDS:${PN} += " \
-    python3-aenum \
     python3-asyncio \
     python3-codecs \
     python3-compression \
@@ -20,7 +19,9 @@  RDEPENDS:${PN} += " \
     python3-logging \
     python3-misc \
     python3-netserver \
+    python3-packaging \
     python3-pkg-resources \
+    python3-setuptools \
     python3-sqlite3 \
     python3-typing-extensions \
     python3-wrapt \