diff mbox series

[meta-python] recipes-devtools/python3-piccata: piccata - a simple CoAP toolkit added

Message ID 6a8f811d-0ce3-f95b-303c-a65830b0adb5@3mdeb.com
State New
Headers show
Series [meta-python] recipes-devtools/python3-piccata: piccata - a simple CoAP toolkit added | expand

Commit Message

Daniil Klimuk Aug. 16, 2023, 8:30 a.m. UTC
Author: Daniil Klimuk <daniil.klimuk@3mdeb.com>
Date:   Wed Aug 16 08:47:58 2023 +0200

     recipes-devtools/python3-piccata: piccata - a simple CoAP toolkit added

     piccata is a simple CoAP (RFC7252) toolkit compatible with Python 2.7.

     The toolkit provides basic building blocks for using CoAP in an
     application. piccata handles messaging between endpoints
     (retransmission, deduplication) and request/response matching.

     Handling and matching resources, blockwise transfers, etc. is left to
     the application but functions to faciliate this are provided.

     piccata uses a transport abstraction to faciliate using the toolkit for
     communication over different link types. Transport for a UDP socket is
     provided.

     Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>

+
+RDEPENDS:${PN} += "python3-core python3-datetime python3-io 
python3-logging python3-math"

Comments

Khem Raj Aug. 16, 2023, 4:46 p.m. UTC | #1
On 8/16/23 1:30 AM, Danik wrote:
> Author: Daniil Klimuk <daniil.klimuk@3mdeb.com>
> Date:   Wed Aug 16 08:47:58 2023 +0200
> 
>      recipes-devtools/python3-piccata: piccata - a simple CoAP toolkit 
> added
> 
>      piccata is a simple CoAP (RFC7252) toolkit compatible with Python 2.7.
> 
>      The toolkit provides basic building blocks for using CoAP in an
>      application. piccata handles messaging between endpoints
>      (retransmission, deduplication) and request/response matching.
> 
>      Handling and matching resources, blockwise transfers, etc. is left to
>      the application but functions to faciliate this are provided.
> 
>      piccata uses a transport abstraction to faciliate using the toolkit 
> for
>      communication over different link types. Transport for a UDP socket is
>      provided.
> 
>      Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>
> 

follow 
https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded

subject line can be made better.

> diff --git 
> a/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb 
> b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
> new file mode 100644
> index 000000000000..898069b600f6
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "Python CoAP Toolkit"
> +HOMEPAGE = "https://github.com/NordicSemiconductor/piccata"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=e664eb75e2791c2e505e6e1c274e6d4f"
> +
> +SRC_URI = 
> "https://github.com/NordicSemiconductor/piccata/archive/refs/heads/master.zip"

Using github archives is not recommended since they are not immutable as 
they can be re-generated and change the checksums. Please use git 
fetcher instead

> +SRC_URI[md5sum] = "6d198c7a09c69ffa080e419477235bea"
> +SRC_URI[sha256sum] = 
> "017a4836cbac1e16980add49c87e35bfd4874ed25e7aa90a5bdc280ec8263bfe"
> +
> +S = "${WORKDIR}/piccata-master"
> +
> +inherit setuptools3
> +
> +RDEPENDS:${PN} += "python3-core python3-datetime python3-io 
> python3-logging python3-math"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104418): https://lists.openembedded.org/g/openembedded-devel/message/104418
> Mute This Topic: https://lists.openembedded.org/mt/100775623/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git 
a/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb 
b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
new file mode 100644
index 000000000000..898069b600f6
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-piccata/python3-piccata_2.0.3.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Python CoAP Toolkit"
+HOMEPAGE = "https://github.com/NordicSemiconductor/piccata"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e664eb75e2791c2e505e6e1c274e6d4f"
+
+SRC_URI = 
"https://github.com/NordicSemiconductor/piccata/archive/refs/heads/master.zip"
+SRC_URI[md5sum] = "6d198c7a09c69ffa080e419477235bea"
+SRC_URI[sha256sum] = 
"017a4836cbac1e16980add49c87e35bfd4874ed25e7aa90a5bdc280ec8263bfe"
+
+S = "${WORKDIR}/piccata-master"
+
+inherit setuptools3