diff mbox series

[meta-python] python3-rich: upgrade 13.4.2 -> 13.5.2

Message ID 1692150436-5875-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-rich: upgrade 13.4.2 -> 13.5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 16, 2023, 1:47 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
Fixed
--------
Fixed Text.expand_tab assertion error
Fix tilde character (~) not included in link regex when printing to console #3057
Fixed Text.expand_tabs not expanding spans.
Fixed TimeElapsedColumn from showing negative.
Fix for escaping strings with a trailing backslash #2987
Fixed exception in Markdown with partial table #3053
Fixed the HTML export template so that the <html> tag comes before the <head> tag #3021
Fixed issue with custom classes overwriting __eq__ #2875
Fix rich.pretty.install breakage in iPython #3013

Added
--------
Added Text.extend_style method.
Added Span.extend method.

Changed
----------
Text.tab_size now defaults to None to indicate that Console.tab_size should be used.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-rich_13.4.2.bb => python3-rich_13.5.2.bb}          | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-extended/python-rich/{python3-rich_13.4.2.bb => python3-rich_13.5.2.bb} (85%)
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/python-rich/python3-rich_13.4.2.bb b/meta-python/recipes-extended/python-rich/python3-rich_13.5.2.bb
similarity index 85%
rename from meta-python/recipes-extended/python-rich/python3-rich_13.4.2.bb
rename to meta-python/recipes-extended/python-rich/python3-rich_13.5.2.bb
index e7ddf70983..2c31a33751 100644
--- a/meta-python/recipes-extended/python-rich/python3-rich_13.4.2.bb
+++ b/meta-python/recipes-extended/python-rich/python3-rich_13.5.2.bb
@@ -8,7 +8,7 @@  LICENSE = "MIT"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303"
 
-SRC_URI[sha256sum] = "d653d6bccede5844304c605d5aac802c7cf9621efd700b46c7ec2b51ea914898"
+SRC_URI[sha256sum] = "fb9d6c0a0f643c99eed3875b5377a184132ba9be4d61516a55273d3554d75a39"
 
 inherit pypi python_poetry_core