diff mbox series

[meta-python,1/1] python3-kivy: Remove X11 from REQUIRED_DISTRO_FEATURES

Message ID 20230814144304.2395362-2-m.vovard@phytec.de
State Under Review
Headers show
Series Remove X11 from REQUIRED_DISTRO_FEATURES from Kivy | expand

Commit Message

Marine Vovard Aug. 14, 2023, 2:43 p.m. UTC
We can use pure Wayland and therefore X11 is not required all the time.

Signed-off-by: Marine Vovard <m.vovard@phytec.de>
---
 meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Aug. 14, 2023, 3:17 p.m. UTC | #1
On Mon, Aug 14, 2023 at 7:43 AM Marine Vovard <M.Vovard@phytec.de> wrote:
>
> We can use pure Wayland and therefore X11 is not required all the time.
>

Would it also build when x11 or wayland neither are in DISTRO_FEATURES ?
If not then I guess a check should be made to check such that atleast
one of these distro
features are present.

> Signed-off-by: Marine Vovard <m.vovard@phytec.de>
> ---
>  meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> index ca1fc5f96..93894c860 100644
> --- a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> +++ b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> @@ -43,7 +43,7 @@ export KIVY_GRAPHICS
>  KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
>  export KIVY_CROSS_SYSROOT
>
> -REQUIRED_DISTRO_FEATURES += "x11 opengl gobject-introspection-data"
> +REQUIRED_DISTRO_FEATURES += "opengl gobject-introspection-data"
>
>  DEPENDS += " \
>      gstreamer1.0 \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104350): https://lists.openembedded.org/g/openembedded-devel/message/104350
> Mute This Topic: https://lists.openembedded.org/mt/100737871/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Marine Vovard Aug. 16, 2023, 8:29 a.m. UTC | #2
On Mon, 2023-08-14 at 08:17 -0700, Khem Raj wrote:
> On Mon, Aug 14, 2023 at 7:43 AM Marine Vovard <M.Vovard@phytec.de>
> wrote:
> > 
> > We can use pure Wayland and therefore X11 is not required all the
> > time.
> > 
> 
> Would it also build when x11 or wayland neither are in
> DISTRO_FEATURES ?
> If not then I guess a check should be made to check such that atleast
> one of these distro
> features are present.
> 

Indeed, from what I understood you need wayland or x11 (or both) 
to make it work. I'm thinking about adding the following line:

ANY_OF_DISTRO_FEATURES = "x11 wayland"

I will send a new patch with this modification if it seems ok.
 
> > Signed-off-by: Marine Vovard <m.vovard@phytec.de>
> > ---
> >  meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/meta-python/recipes-devtools/python/python3-
> > kivy_2.1.0..bb b/meta-python/recipes-devtools/python/python3-
> > kivy_2.1.0..bb
> > index ca1fc5f96..93894c860 100644
> > --- a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> > +++ b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> > @@ -43,7 +43,7 @@ export KIVY_GRAPHICS
> >  KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
> >  export KIVY_CROSS_SYSROOT
> > 
> > -REQUIRED_DISTRO_FEATURES += "x11 opengl gobject-introspection-
> > data"
> > +REQUIRED_DISTRO_FEATURES += "opengl gobject-introspection-data"
> > 
> >  DEPENDS += " \
> >      gstreamer1.0 \
> > --
> > 2.25.1
> > 
> > 
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#104350):
> > https://lists.openembedded.org/g/openembedded-devel/message/104350
> > Mute This Topic:
> > https://lists.openembedded.org/mt/100737871/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe:
> > https://lists.openembedded.org/g/openembedded-devel/unsub [
> > raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj Aug. 16, 2023, 2:19 p.m. UTC | #3
On Wed, Aug 16, 2023 at 1:29 AM Marine Vovard <M.Vovard@phytec.de> wrote:

> On Mon, 2023-08-14 at 08:17 -0700, Khem Raj wrote:
> > On Mon, Aug 14, 2023 at 7:43 AM Marine Vovard <M.Vovard@phytec.de>
> > wrote:
> > >
> > > We can use pure Wayland and therefore X11 is not required all the
> > > time.
> > >
> >
> > Would it also build when x11 or wayland neither are in
> > DISTRO_FEATURES ?
> > If not then I guess a check should be made to check such that atleast
> > one of these distro
> > features are present.
> >
>
> Indeed, from what I understood you need wayland or x11 (or both)
> to make it work. I'm thinking about adding the following line:
>
> ANY_OF_DISTRO_FEATURES = "x11 wayland"
>
> I will send a new patch with this modification if it seems ok.


Sounds good


>
> > > Signed-off-by: Marine Vovard <m.vovard@phytec.de>
> > > ---
> > >  meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/meta-python/recipes-devtools/python/python3-
> > > kivy_2.1.0..bb b/meta-python/recipes-devtools/python/python3-
> > > kivy_2.1.0..bb
> > > index ca1fc5f96..93894c860 100644
> > > --- a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> > > +++ b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
> > > @@ -43,7 +43,7 @@ export KIVY_GRAPHICS
> > >  KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
> > >  export KIVY_CROSS_SYSROOT
> > >
> > > -REQUIRED_DISTRO_FEATURES += "x11 opengl gobject-introspection-
> > > data"
> > > +REQUIRED_DISTRO_FEATURES += "opengl gobject-introspection-data"
> > >
> > >  DEPENDS += " \
> > >      gstreamer1.0 \
> > > --
> > > 2.25.1
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#104350):
> > > https://lists.openembedded.org/g/openembedded-devel/message/104350
> > > Mute This Topic:
> > > https://lists.openembedded.org/mt/100737871/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe:
> > > https://lists.openembedded.org/g/openembedded-devel/unsub [
> > > raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
>
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
index ca1fc5f96..93894c860 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.1.0..bb
@@ -43,7 +43,7 @@  export KIVY_GRAPHICS
 KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}"
 export KIVY_CROSS_SYSROOT
 
-REQUIRED_DISTRO_FEATURES += "x11 opengl gobject-introspection-data"
+REQUIRED_DISTRO_FEATURES += "opengl gobject-introspection-data"
 
 DEPENDS += " \
     gstreamer1.0 \