diff mbox series

[meta-oe] openh264: fix installed-vs-shared QA issue with multilib

Message ID 20230813152645.8947-1-Martin.Jansa@gmail.com
State Under Review
Headers show
Series [meta-oe] openh264: fix installed-vs-shared QA issue with multilib | expand

Commit Message

Martin Jansa Aug. 13, 2023, 3:26 p.m. UTC
* in some cases libdir is /usr/lib64 and then libraries installed in /usr/lib aren't packaged:
ERROR: QA Issue: openh264: Files/directories were installed but not shipped in any package:
  /usr/lib/libopenh264.a
  /usr/lib/libopenh264.so.2.1.1
  /usr/lib/libopenh264.so
  /usr/lib/libopenh264.so.6
  /usr/lib/pkgconfig
  /usr/lib/pkgconfig/openh264.pc
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
openh264: 6 installed and not shipped files. [installed-vs-shipped]

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta-multimedia/recipes-multimedia/openh264/openh264_2.3.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/openh264/openh264_2.3.1.bb b/meta-multimedia/recipes-multimedia/openh264/openh264_2.3.1.bb
index 3fa87d05f5..89b1ea58c5 100644
--- a/meta-multimedia/recipes-multimedia/openh264/openh264_2.3.1.bb
+++ b/meta-multimedia/recipes-multimedia/openh264/openh264_2.3.1.bb
@@ -45,7 +45,7 @@  do_compile() {
 }
 
 do_install() {
-    oe_runmake install DESTDIR=${D} PREFIX=${prefix}
+    oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIBDIR_NAME=${baselib} SHAREDLIB_DIR=${libdir}
 }
 
 CLEANBROKEN = "1"