[2/2] core-image-sato-sdk: allocate more memory when in qemu

Message ID 20220124181156.3921311-2-ross.burton@arm.com
State Accepted, archived
Commit 50ff1f018a670c963e1979dee76ebd696153b4c1
Headers show
Series [1/2] Revert "oeqa/runtime/stap: increase buffer size" | expand

Commit Message

Ross Burton Jan. 24, 2022, 6:11 p.m. UTC
Compiling code is memory-intensive, especially kernel modules like the
SystemTap probes, so give the VM 1GB of RAM.

Hopefully this solves the intermittent failures caused by OOMs during
the SystemTap test.

[ YOCTO #14673 ]

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-sato/images/core-image-sato-sdk.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Alexander Kanavin Jan. 25, 2022, 3:10 p.m. UTC | #1
Seems to not work on arm(32):

Central error: [    5.282955] vmap allocation for size 1052672 failed:
use vmalloc=<size> to increase size

https://autobuilder.yoctoproject.org/typhoon/#/builders/110/builds/3528/steps/13/logs/stdio

Alex


On Mon, 24 Jan 2022 at 19:12, Ross Burton <ross@burtonini.com> wrote:

> Compiling code is memory-intensive, especially kernel modules like the
> SystemTap probes, so give the VM 1GB of RAM.
>
> Hopefully this solves the intermittent failures caused by OOMs during
> the SystemTap test.
>
> [ YOCTO #14673 ]
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-sato/images/core-image-sato-sdk.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb
> b/meta/recipes-sato/images/core-image-sato-sdk.bb
> index b52de0def02..7df8d00971c 100644
> --- a/meta/recipes-sato/images/core-image-sato-sdk.bb
> +++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
> @@ -10,3 +10,6 @@ IMAGE_FEATURES += "dev-pkgs tools-sdk \
>
>  IMAGE_INSTALL += "kernel-devsrc"
>
> +# Compiling stuff, specifically SystemTap probes, can require lots of
> memory
> +# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
> +QB_MEM = '-m 1024'
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#160890):
> https://lists.openembedded.org/g/openembedded-core/message/160890
> Mute This Topic: https://lists.openembedded.org/mt/88653349/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Alexander Kanavin Jan. 25, 2022, 3:11 p.m. UTC | #2
qemuarm shows something different:
https://autobuilder.yoctoproject.org/typhoon/#/builders/53/builds/4653/steps/13/logs/stdio

Alex

On Tue, 25 Jan 2022 at 16:10, Alexander Kanavin <alex.kanavin@gmail.com>
wrote:

> Seems to not work on arm(32):
>
> Central error: [    5.282955] vmap allocation for size 1052672 failed: use vmalloc=<size> to increase size
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/110/builds/3528/steps/13/logs/stdio
>
> Alex
>
>
> On Mon, 24 Jan 2022 at 19:12, Ross Burton <ross@burtonini.com> wrote:
>
>> Compiling code is memory-intensive, especially kernel modules like the
>> SystemTap probes, so give the VM 1GB of RAM.
>>
>> Hopefully this solves the intermittent failures caused by OOMs during
>> the SystemTap test.
>>
>> [ YOCTO #14673 ]
>>
>> Signed-off-by: Ross Burton <ross.burton@arm.com>
>> ---
>>  meta/recipes-sato/images/core-image-sato-sdk.bb | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb
>> b/meta/recipes-sato/images/core-image-sato-sdk.bb
>> index b52de0def02..7df8d00971c 100644
>> --- a/meta/recipes-sato/images/core-image-sato-sdk.bb
>> +++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
>> @@ -10,3 +10,6 @@ IMAGE_FEATURES += "dev-pkgs tools-sdk \
>>
>>  IMAGE_INSTALL += "kernel-devsrc"
>>
>> +# Compiling stuff, specifically SystemTap probes, can require lots of
>> memory
>> +# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
>> +QB_MEM = '-m 1024'
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#160890):
>> https://lists.openembedded.org/g/openembedded-core/message/160890
>> Mute This Topic: https://lists.openembedded.org/mt/88653349/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
>> alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>>

Patch

diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def02..7df8d00971c 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@  IMAGE_FEATURES += "dev-pkgs tools-sdk \
 
 IMAGE_INSTALL += "kernel-devsrc"
 
+# Compiling stuff, specifically SystemTap probes, can require lots of memory
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
+QB_MEM = '-m 1024'