diff mbox series

[meta-python] python3-m2crypto: Remove __pycache__ files

Message ID 20230807181625.2761204-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python] python3-m2crypto: Remove __pycache__ files | expand

Commit Message

Khem Raj Aug. 7, 2023, 6:16 p.m. UTC
They may not be appropriate for target due to cross compiling

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-devtools/python/python3-m2crypto_0.39.0.bb       | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.39.0.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.39.0.bb
index 3a4a700bf7..ac62773064 100644
--- a/meta-python/recipes-devtools/python/python3-m2crypto_0.39.0.bb
+++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.39.0.bb
@@ -44,4 +44,9 @@  export SWIG_FEATURES
 
 export STAGING_DIR
 
+do_install:append() {
+    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/M2Crypto/SSL/__pycache__/*.cpython-*.pyc
+    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/M2Crypto/__pycache__/*.cpython-*.pyc
+}
+
 BBCLASSEXTEND = "native"