diff mbox series

[1/2] webkitgtk: upgrade 2.40.2 -> 2.40.5

Message ID 20230802150801.2607-1-f_l_k@t-online.de
State Accepted, archived
Commit c2f10d54341d84dcb21aaabe0828bff774de4f6e
Headers show
Series [1/2] webkitgtk: upgrade 2.40.2 -> 2.40.5 | expand

Commit Message

Markus Volk Aug. 2, 2023, 3:08 p.m. UTC
- Remove unneeded patches

    What’s new in the WebKitGTK 2.40.5 release?
    - Fix several crashes and rendering issues.

    What’s new in the WebKitGTK 2.40.4 release?
    - Fix a bug in JavaScript reading variable arguments in a call.

    What’s new in the WebKitGTK 2.40.3 release?
    - Make memory pressure monitor honor memory.memsw.usage_in_bytes if exists.
    - Include key modifiers in wheel events.
    - Apply cookie blocking policy to WebSocket handshakes.
    - Remove accidental dependency on GLib 2.70.
    - Fix the build with BUBBLEWRAP_SANDBOX disabled.
    - Fix several crashes and rendering issues.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...tCore-CMakeLists.txt-ensure-reproduc.patch | 28 -------------
 ...290ab4ab35258a6da9b13795c9b0f7894bf4.patch | 41 -------------------
 ...ebkitgtk_2.40.2.bb => webkitgtk_2.40.5.bb} |  5 +--
 3 files changed, 1 insertion(+), 73 deletions(-)
 delete mode 100644 meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
 delete mode 100644 meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
 rename meta/recipes-sato/webkit/{webkitgtk_2.40.2.bb => webkitgtk_2.40.5.bb} (96%)

Comments

Alexander Kanavin Aug. 2, 2023, 5:42 p.m. UTC | #1
'Unneeded patches' is not a good phrase to use: it's better to say
explicitly that the patches have been merged into the new release (or
if there is some other reason they are not needed anymore). I had to
go to upstream repo and check that, but I shouldn't have to.

Alex

On Wed, 2 Aug 2023 at 17:08, Markus Volk <f_l_k@t-online.de> wrote:
>
> - Remove unneeded patches
>
>     What’s new in the WebKitGTK 2.40.5 release?
>     - Fix several crashes and rendering issues.
>
>     What’s new in the WebKitGTK 2.40.4 release?
>     - Fix a bug in JavaScript reading variable arguments in a call.
>
>     What’s new in the WebKitGTK 2.40.3 release?
>     - Make memory pressure monitor honor memory.memsw.usage_in_bytes if exists.
>     - Include key modifiers in wheel events.
>     - Apply cookie blocking policy to WebSocket handshakes.
>     - Remove accidental dependency on GLib 2.70.
>     - Fix the build with BUBBLEWRAP_SANDBOX disabled.
>     - Fix several crashes and rendering issues.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  ...tCore-CMakeLists.txt-ensure-reproduc.patch | 28 -------------
>  ...290ab4ab35258a6da9b13795c9b0f7894bf4.patch | 41 -------------------
>  ...ebkitgtk_2.40.2.bb => webkitgtk_2.40.5.bb} |  5 +--
>  3 files changed, 1 insertion(+), 73 deletions(-)
>  delete mode 100644 meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
>  delete mode 100644 meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
>  rename meta/recipes-sato/webkit/{webkitgtk_2.40.2.bb => webkitgtk_2.40.5.bb} (96%)
>
> diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
> deleted file mode 100644
> index bbe265059d..0000000000
> --- a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
> +++ /dev/null
> @@ -1,28 +0,0 @@
> -From cd65e3d9256a4f6eb7906a9f10678c29a4ffef2f Mon Sep 17 00:00:00 2001
> -From: Alexander Kanavin <alex@linutronix.de>
> -Date: Mon, 26 Jun 2023 14:30:02 +0200
> -Subject: [PATCH] Source/JavaScriptCore/CMakeLists.txt: ensure reproducibility
> - of __TIMESTAMP__
> -
> -__TIMESTAMP__ refers to mtime of the file that contains it, which is unstable
> -and breaks binary reproducibility when the file is generated at build time. To ensure
> -this does not happen, mtime should be set from the original file.
> -
> -Upstream-Status: Submitted [https://github.com/WebKit/WebKit/pull/15293]
> -Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ----
> - Source/JavaScriptCore/CMakeLists.txt | 1 +
> - 1 file changed, 1 insertion(+)
> -
> -diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
> -index 43dc22ff..c2e3b1cd 100644
> ---- a/Source/JavaScriptCore/CMakeLists.txt
> -+++ b/Source/JavaScriptCore/CMakeLists.txt
> -@@ -159,6 +159,7 @@ add_custom_command(
> -     OUTPUT ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
> -     MAIN_DEPENDENCY ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in
> -     COMMAND ${PERL_EXECUTABLE} -pe s/CACHED_TYPES_CKSUM/__TIMESTAMP__/ ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in > ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
> -+    COMMAND touch -r ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
> -             VERBATIM
> - )
> -
> diff --git a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch b/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
> deleted file mode 100644
> index 79da855ff4..0000000000
> --- a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
> +++ /dev/null
> @@ -1,41 +0,0 @@
> -From 4977290ab4ab35258a6da9b13795c9b0f7894bf4 Mon Sep 17 00:00:00 2001
> -From: Diego Pino Garcia <dpino@igalia.com>
> -Date: Mon, 22 May 2023 19:58:50 -0700
> -Subject: [PATCH] [GLIB] Fix build error after 264196@main
> - https://bugs.webkit.org/show_bug.cgi?id=256917
> -
> -Reviewed by Michael Catanzaro.
> -
> -Variable BWRAP_EXECUTABLE is only defined when BUBBLEWRAP_SANDBOX is
> -enabled.
> -
> -* Source/WTF/wtf/glib/Sandbox.cpp:
> -(WTF::isInsideUnsupportedContainer):
> -
> -Canonical link: https://commits.webkit.org/264395@main
> -Upstream-Status: Backport [https://github.com/WebKit/WebKit/commit/4977290ab4ab35258a6da9b13795c9b0f7894bf4]
> -Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ----
> - Source/WTF/wtf/glib/Sandbox.cpp | 2 ++
> - 1 file changed, 2 insertions(+)
> -
> -diff --git a/Source/WTF/wtf/glib/Sandbox.cpp b/Source/WTF/wtf/glib/Sandbox.cpp
> -index 7d84e830ab33e..9b07bb8cb5a9b 100644
> ---- a/Source/WTF/wtf/glib/Sandbox.cpp
> -+++ b/Source/WTF/wtf/glib/Sandbox.cpp
> -@@ -36,6 +36,7 @@ bool isInsideFlatpak()
> -     return returnValue;
> - }
> -
> -+#if ENABLE(BUBBLEWRAP_SANDBOX)
> - bool isInsideUnsupportedContainer()
> - {
> -     static bool inContainer = g_file_test("/run/.containerenv", G_FILE_TEST_EXISTS);
> -@@ -64,6 +65,7 @@ bool isInsideUnsupportedContainer()
> -
> -     return inContainer && !supportedContainer;
> - }
> -+#endif
> -
> - bool isInsideSnap()
> - {
> diff --git a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
> similarity index 96%
> rename from meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
> rename to meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
> index a9391bfc99..7bf32e8610 100644
> --- a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
> +++ b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
> @@ -13,11 +13,9 @@ SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
>             file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
>             file://reproducibility.patch \
>             file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
> -           file://4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch \
> -           file://0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch \
>             file://check-GST_GL_HAVE_PLATFORM_GLX.patch \
>             "
> -SRC_URI[sha256sum] = "96898870d994da406ee7a632816dcde9a3bb395ee5f344fcb3f3b8cc8a77e000"
> +SRC_URI[sha256sum] = "7de051a263668621d91a61a5eb1c3771d1a7cec900043d4afef06c326c16037f"
>
>  inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
>
> @@ -162,6 +160,5 @@ src_package_preprocess () {
>              ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
>              ${B}/WebCore/DerivedSources/*.cpp \
>              ${B}/WebKitGTK/DerivedSources/webkit/*.cpp
> -
>  }
>
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#185413): https://lists.openembedded.org/g/openembedded-core/message/185413
> Mute This Topic: https://lists.openembedded.org/mt/100507379/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Aug. 2, 2023, 10:29 p.m. UTC | #2
Yes, I checked that as well. I'm sorry I didn't comment in more detail.

On Wed, Aug 2 2023 at 07:42:53 PM +02:00:00, Alexander Kanavin 
<alex.kanavin@gmail.com> wrote:
> 'Unneeded patches' is not a good phrase to use: it's better to say
> explicitly that the patches have been merged into the new release (or
> if there is some other reason they are not needed anymore). I had to
> go to upstream repo and check that, but I shouldn't have to.
> 
> Alex
> 
> On Wed, 2 Aug 2023 at 17:08, Markus Volk <f_l_k@t-online.de 
> <mailto:f_l_k@t-online.de>> wrote:
>> 
>>  - Remove unneeded patches
>> 
>>      What’s new in the WebKitGTK 2.40.5 release?
>>      - Fix several crashes and rendering issues.
>> 
>>      What’s new in the WebKitGTK 2.40.4 release?
>>      - Fix a bug in JavaScript reading variable arguments in a call.
>> 
>>      What’s new in the WebKitGTK 2.40.3 release?
>>      - Make memory pressure monitor honor 
>> memory.memsw.usage_in_bytes if exists.
>>      - Include key modifiers in wheel events.
>>      - Apply cookie blocking policy to WebSocket handshakes.
>>      - Remove accidental dependency on GLib 2.70.
>>      - Fix the build with BUBBLEWRAP_SANDBOX disabled.
>>      - Fix several crashes and rendering issues.
>> 
>>  Signed-off-by: Markus Volk <f_l_k@t-online.de 
>> <mailto:f_l_k@t-online.de>>
>>  ---
>>   ...tCore-CMakeLists.txt-ensure-reproduc.patch | 28 -------------
>>   ...290ab4ab35258a6da9b13795c9b0f7894bf4.patch | 41 
>> -------------------
>>   ...ebkitgtk_2.40.2.bb => webkitgtk_2.40.5.bb} |  5 +--
>>   3 files changed, 1 insertion(+), 73 deletions(-)
>>   delete mode 100644 
>> meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
>>   delete mode 100644 
>> meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
>>   rename meta/recipes-sato/webkit/{webkitgtk_2.40.2.bb => 
>> webkitgtk_2.40.5.bb} (96%)
>> 
>>  diff --git 
>> a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch 
>> b/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
>>  deleted file mode 100644
>>  index bbe265059d..0000000000
>>  --- 
>> a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
>>  +++ /dev/null
>>  @@ -1,28 +0,0 @@
>>  -From cd65e3d9256a4f6eb7906a9f10678c29a4ffef2f Mon Sep 17 00:00:00 
>> 2001
>>  -From: Alexander Kanavin <alex@linutronix.de 
>> <mailto:alex@linutronix.de>>
>>  -Date: Mon, 26 Jun 2023 14:30:02 +0200
>>  -Subject: [PATCH] Source/JavaScriptCore/CMakeLists.txt: ensure 
>> reproducibility
>>  - of __TIMESTAMP__
>>  -
>>  -__TIMESTAMP__ refers to mtime of the file that contains it, which 
>> is unstable
>>  -and breaks binary reproducibility when the file is generated at 
>> build time. To ensure
>>  -this does not happen, mtime should be set from the original file.
>>  -
>>  -Upstream-Status: Submitted 
>> [<https://github.com/WebKit/WebKit/pull/15293>]
>>  -Signed-off-by: Alexander Kanavin <alex@linutronix.de 
>> <mailto:alex@linutronix.de>>
>>  ----
>>  - Source/JavaScriptCore/CMakeLists.txt | 1 +
>>  - 1 file changed, 1 insertion(+)
>>  -
>>  -diff --git a/Source/JavaScriptCore/CMakeLists.txt 
>> b/Source/JavaScriptCore/CMakeLists.txt
>>  -index 43dc22ff..c2e3b1cd 100644
>>  ---- a/Source/JavaScriptCore/CMakeLists.txt
>>  -+++ b/Source/JavaScriptCore/CMakeLists.txt
>>  -@@ -159,6 +159,7 @@ add_custom_command(
>>  -     OUTPUT 
>> ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
>>  -     MAIN_DEPENDENCY 
>> ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in
>>  -     COMMAND ${PERL_EXECUTABLE} -pe 
>> s/CACHED_TYPES_CKSUM/__TIMESTAMP__/ 
>> ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in > 
>> ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
>>  -+    COMMAND touch -r 
>> ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in 
>> ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
>>  -             VERBATIM
>>  - )
>>  -
>>  diff --git 
>> a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch 
>> b/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
>>  deleted file mode 100644
>>  index 79da855ff4..0000000000
>>  --- 
>> a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
>>  +++ /dev/null
>>  @@ -1,41 +0,0 @@
>>  -From 4977290ab4ab35258a6da9b13795c9b0f7894bf4 Mon Sep 17 00:00:00 
>> 2001
>>  -From: Diego Pino Garcia <dpino@igalia.com 
>> <mailto:dpino@igalia.com>>
>>  -Date: Mon, 22 May 2023 19:58:50 -0700
>>  -Subject: [PATCH] [GLIB] Fix build error after 264196@main
>>  - <https://bugs.webkit.org/show_bug.cgi?id=256917>
>>  -
>>  -Reviewed by Michael Catanzaro.
>>  -
>>  -Variable BWRAP_EXECUTABLE is only defined when BUBBLEWRAP_SANDBOX 
>> is
>>  -enabled.
>>  -
>>  -* Source/WTF/wtf/glib/Sandbox.cpp:
>>  -(WTF::isInsideUnsupportedContainer):
>>  -
>>  -Canonical link: <https://commits.webkit.org/264395@main>
>>  -Upstream-Status: Backport 
>> [<https://github.com/WebKit/WebKit/commit/4977290ab4ab35258a6da9b13795c9b0f7894bf4>]
>>  -Signed-off-by: Alexander Kanavin <alex@linutronix.de 
>> <mailto:alex@linutronix.de>>
>>  ----
>>  - Source/WTF/wtf/glib/Sandbox.cpp | 2 ++
>>  - 1 file changed, 2 insertions(+)
>>  -
>>  -diff --git a/Source/WTF/wtf/glib/Sandbox.cpp 
>> b/Source/WTF/wtf/glib/Sandbox.cpp
>>  -index 7d84e830ab33e..9b07bb8cb5a9b 100644
>>  ---- a/Source/WTF/wtf/glib/Sandbox.cpp
>>  -+++ b/Source/WTF/wtf/glib/Sandbox.cpp
>>  -@@ -36,6 +36,7 @@ bool isInsideFlatpak()
>>  -     return returnValue;
>>  - }
>>  -
>>  -+#if ENABLE(BUBBLEWRAP_SANDBOX)
>>  - bool isInsideUnsupportedContainer()
>>  - {
>>  -     static bool inContainer = g_file_test("/run/.containerenv", 
>> G_FILE_TEST_EXISTS);
>>  -@@ -64,6 +65,7 @@ bool isInsideUnsupportedContainer()
>>  -
>>  -     return inContainer && !supportedContainer;
>>  - }
>>  -+#endif
>>  -
>>  - bool isInsideSnap()
>>  - {
>>  diff --git a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb 
>> b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
>>  similarity index 96%
>>  rename from meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
>>  rename to meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
>>  index a9391bfc99..7bf32e8610 100644
>>  --- a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
>>  +++ b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
>>  @@ -13,11 +13,9 @@ SRC_URI = 
>> "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
>>              
>> file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch 
>> <file://0001-findgobjectintrospection.cmake-prefix-variables-obta.patch/> 
>> \
>>              file://reproducibility.patch 
>> <file://reproducibility.patch/> \
>>              file://0d3344e17d258106617b0e6d783d073b188a2548.patch 
>> <file://0d3344e17d258106617b0e6d783d073b188a2548.patch/> \
>>  -           file://4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch 
>> <file://4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch/> \
>>  -           
>> file://0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch 
>> <file://0001-source-javascriptcore-cmakelists.txt-ensure-reproduc.patch/> 
>> \
>>              file://check-GST_GL_HAVE_PLATFORM_GLX.patch 
>> <file://check-gst_gl_have_platform_glx.patch/> \
>>              "
>>  -SRC_URI[sha256sum] = 
>> "96898870d994da406ee7a632816dcde9a3bb395ee5f344fcb3f3b8cc8a77e000"
>>  +SRC_URI[sha256sum] = 
>> "7de051a263668621d91a61a5eb1c3771d1a7cec900043d4afef06c326c16037f"
>> 
>>   inherit cmake pkgconfig gobject-introspection perlnative 
>> features_check upstream-version-is-even gi-docgen
>> 
>>  @@ -162,6 +160,5 @@ src_package_preprocess () {
>>               ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
>>               ${B}/WebCore/DerivedSources/*.cpp \
>>               ${B}/WebKitGTK/DerivedSources/webkit/*.cpp
>>  -
>>   }
>> 
>>  --
>>  2.41.0
>> 
>> 
>> 
>> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#185422): 
> <https://lists.openembedded.org/g/openembedded-core/message/185422>
> Mute This Topic: <https://lists.openembedded.org/mt/100507379/3618223>
> Group Owner: openembedded-core+owner@lists.openembedded.org 
> <mailto:openembedded-core+owner@lists.openembedded.org>
> Unsubscribe: 
> <https://lists.openembedded.org/g/openembedded-core/unsub> 
> [f_l_k@t-online.de <mailto:f_l_k@t-online.de>]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
deleted file mode 100644
index bbe265059d..0000000000
--- a/meta/recipes-sato/webkit/webkitgtk/0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-From cd65e3d9256a4f6eb7906a9f10678c29a4ffef2f Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex@linutronix.de>
-Date: Mon, 26 Jun 2023 14:30:02 +0200
-Subject: [PATCH] Source/JavaScriptCore/CMakeLists.txt: ensure reproducibility
- of __TIMESTAMP__
-
-__TIMESTAMP__ refers to mtime of the file that contains it, which is unstable
-and breaks binary reproducibility when the file is generated at build time. To ensure
-this does not happen, mtime should be set from the original file.
-
-Upstream-Status: Submitted [https://github.com/WebKit/WebKit/pull/15293]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- Source/JavaScriptCore/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
-index 43dc22ff..c2e3b1cd 100644
---- a/Source/JavaScriptCore/CMakeLists.txt
-+++ b/Source/JavaScriptCore/CMakeLists.txt
-@@ -159,6 +159,7 @@ add_custom_command(
-     OUTPUT ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
-     MAIN_DEPENDENCY ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in
-     COMMAND ${PERL_EXECUTABLE} -pe s/CACHED_TYPES_CKSUM/__TIMESTAMP__/ ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in > ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
-+    COMMAND touch -r ${JAVASCRIPTCORE_DIR}/runtime/JSCBytecodeCacheVersion.cpp.in ${JavaScriptCore_DERIVED_SOURCES_DIR}/JSCBytecodeCacheVersion.cpp
-             VERBATIM
- )
- 
diff --git a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch b/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
deleted file mode 100644
index 79da855ff4..0000000000
--- a/meta/recipes-sato/webkit/webkitgtk/4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From 4977290ab4ab35258a6da9b13795c9b0f7894bf4 Mon Sep 17 00:00:00 2001
-From: Diego Pino Garcia <dpino@igalia.com>
-Date: Mon, 22 May 2023 19:58:50 -0700
-Subject: [PATCH] [GLIB] Fix build error after 264196@main
- https://bugs.webkit.org/show_bug.cgi?id=256917
-
-Reviewed by Michael Catanzaro.
-
-Variable BWRAP_EXECUTABLE is only defined when BUBBLEWRAP_SANDBOX is
-enabled.
-
-* Source/WTF/wtf/glib/Sandbox.cpp:
-(WTF::isInsideUnsupportedContainer):
-
-Canonical link: https://commits.webkit.org/264395@main
-Upstream-Status: Backport [https://github.com/WebKit/WebKit/commit/4977290ab4ab35258a6da9b13795c9b0f7894bf4]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- Source/WTF/wtf/glib/Sandbox.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/Source/WTF/wtf/glib/Sandbox.cpp b/Source/WTF/wtf/glib/Sandbox.cpp
-index 7d84e830ab33e..9b07bb8cb5a9b 100644
---- a/Source/WTF/wtf/glib/Sandbox.cpp
-+++ b/Source/WTF/wtf/glib/Sandbox.cpp
-@@ -36,6 +36,7 @@ bool isInsideFlatpak()
-     return returnValue;
- }
- 
-+#if ENABLE(BUBBLEWRAP_SANDBOX)
- bool isInsideUnsupportedContainer()
- {
-     static bool inContainer = g_file_test("/run/.containerenv", G_FILE_TEST_EXISTS);
-@@ -64,6 +65,7 @@ bool isInsideUnsupportedContainer()
- 
-     return inContainer && !supportedContainer;
- }
-+#endif
- 
- bool isInsideSnap()
- {
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
similarity index 96%
rename from meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
rename to meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
index a9391bfc99..7bf32e8610 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.40.2.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.40.5.bb
@@ -13,11 +13,9 @@  SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
            file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
            file://reproducibility.patch \
            file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
-           file://4977290ab4ab35258a6da9b13795c9b0f7894bf4.patch \
-           file://0001-Source-JavaScriptCore-CMakeLists.txt-ensure-reproduc.patch \
            file://check-GST_GL_HAVE_PLATFORM_GLX.patch \
            "
-SRC_URI[sha256sum] = "96898870d994da406ee7a632816dcde9a3bb395ee5f344fcb3f3b8cc8a77e000"
+SRC_URI[sha256sum] = "7de051a263668621d91a61a5eb1c3771d1a7cec900043d4afef06c326c16037f"
 
 inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
 
@@ -162,6 +160,5 @@  src_package_preprocess () {
             ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
             ${B}/WebCore/DerivedSources/*.cpp \
             ${B}/WebKitGTK/DerivedSources/webkit/*.cpp
-
 }