diff mbox series

re2c: upgrade 3.0 -> 3.1

Message ID 1690875687-21573-15-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 43e646a99f8be07fd410fd4af19a31fc98508a76
Headers show
Series re2c: upgrade 3.0 -> 3.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 1, 2023, 7:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- Added capturing groups with leftmost greedy semantics:
- Added non-capturing groups:
- Regenerated Unicode include header to support a newer standard
- Published TDFA paper: https://arxiv.org/abs/2206.01398, co-authored with
  Angelo Borsotti
- Removed experimental algorithms that are superseded by TDFA(1) and
  generally less efficient:
- Fixed parsing of raw UTF-8 characters in Flex compatibility mode
- Added header file to the dependencies generated with "--depfile" option
- Fixed stack overflow on large regular expressions by rewriting recursive
    functions in iterative form and limited stack to 256K on GithubActions CI
- Added minimal http://bazel.build integration
- Added configure option "--enable-parsers" that regenerates bison parsers
- Added CMake option "RE2C_REBUILD_PARSERS"
- Moved the entire codebase to C++11.
- Added uniform error handling (return codes are now properly checked and
 returned to the caller).
- Reorganized codegen subsystem in four well-defined phases (analyze,
 generate, fixup, render) and separated codegen from parsing phase.
- Improved memory allocation by using slab allocators instead of global free
 lists.
- Moved to pure API for bison parsers.
- Unified code style.
- Added "--verbose" flag to run_tests.py and suppressed verbose output by
 default.
- Multiple improvements of continuous testing with GithubActions.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-support/re2c/{re2c_3.0.bb => re2c_3.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-support/re2c/{re2c_3.0.bb => re2c_3.1.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-support/re2c/re2c_3.0.bb b/meta/recipes-support/re2c/re2c_3.1.bb
similarity index 91%
rename from meta/recipes-support/re2c/re2c_3.0.bb
rename to meta/recipes-support/re2c/re2c_3.1.bb
index f8f85125a3..25ec47519a 100644
--- a/meta/recipes-support/re2c/re2c_3.0.bb
+++ b/meta/recipes-support/re2c/re2c_3.1.bb
@@ -8,7 +8,7 @@  LICENSE = "PD"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=64eca4d8a3b67f9dc7656094731a2c8d"
 
 SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
-SRC_URI[sha256sum] = "b3babbbb1461e13fe22c630a40c43885efcfbbbb585830c6f4c0d791cf82ba0b"
+SRC_URI[sha256sum] = "0ac299ad359e3f512b06a99397d025cfff81d3be34464ded0656f8a96676c029"
 GITHUB_BASE_URI = "https://github.com/skvadrik/re2c/releases"
 
 BBCLASSEXTEND = "native nativesdk"