diff mbox series

[meta-python] python3-typeguard: upgrade 4.0.0 -> 4.1.0

Message ID 1690875717-21608-33-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-typeguard: upgrade 4.0.0 -> 4.1.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 1, 2023, 7:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- Added support for passing a tuple as expected_type to check_type(), making it
  more of a drop-in replacement for isinstance()
- Fixed regression where Literal inside a Union had quotes stripped from its
  contents, thus typically causing NameError to be raised when run
- Fixed handling of typing_extensions.Literal on Python 3.8 and 3.9 when
  typing_extensions>=4.6.0 is installed
- Fixed NameError when generated type checking code references an imported
  name from a method
- Fixed docstrings disappearing from instrumented functions
- Fixed @typechecked failing to instrument functions when there are more than
  one function within the same scope
- Fixed frozenset not being checked

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-typeguard_4.0.0.bb => python3-typeguard_4.1.0.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-typeguard_4.0.0.bb => python3-typeguard_4.1.0.bb} (89%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb
rename to meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb
index ca17e2b135..f64c70a72d 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://pypi.org/project/typeguard/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
 
-SRC_URI[sha256sum] = "194fb3dbcb06ea9caf7088f3befee014de57961689f9c859ac5239b1ef61d987"
+SRC_URI[sha256sum] = "b05a54bb0276eefd28880df42e004a71e699c8081fcb9d0536b2ceb01019f60c"
 
 inherit pypi python_setuptools_build_meta ptest