diff mbox series

[meta-python,v2] python3-mypy, python3-mypy-extensions: remove

Message ID 20230724165848.3294-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,v2] python3-mypy, python3-mypy-extensions: remove | expand

Commit Message

Trevor Gamblin July 24, 2023, 4:58 p.m. UTC
While attempting to upgrade mypy and mypy-extensions, it was discovered
that it depends on new modules, some of which have no maintenance plan
in place, e.g.: https://pypi.org/project/types-typed-ast/

Since this is something we want to avoid adding to the ecosystem and
mypy isn't a dependency for anything else in meta-python, remove the
recipes.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
v2 removes the recipes from the packagegroup as well.

 .../packagegroups/packagegroup-meta-python.bb |  2 --
 .../python/python3-mypy-extensions_0.4.3.bb   | 12 ----------
 .../python/python3-mypy_0.971.bb              | 23 -------------------
 3 files changed, 37 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
 delete mode 100644 meta-python/recipes-devtools/python/python3-mypy_0.971.bb

Comments

Justin Bronder July 24, 2023, 7:18 p.m. UTC | #1
On 24/07/23 12:58 -0400, Trevor Gamblin wrote:
> While attempting to upgrade mypy and mypy-extensions, it was discovered
> that it depends on new modules, some of which have no maintenance plan
> in place, e.g.: https://pypi.org/project/types-typed-ast/

That dependency has been dropped upstream as part of removing support for python
3.7 [1].  If there's other other problematic recipes, I think it'd be beneficial
to have a type checker for python available.

1. https://github.com/python/mypy/commit/2edaf35ec1f91c139dfe1930b1b0d1e1cac59599


> 
> Since this is something we want to avoid adding to the ecosystem and
> mypy isn't a dependency for anything else in meta-python, remove the
> recipes.
> 
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
> v2 removes the recipes from the packagegroup as well.
> 
>  .../packagegroups/packagegroup-meta-python.bb |  2 --
>  .../python/python3-mypy-extensions_0.4.3.bb   | 12 ----------
>  .../python/python3-mypy_0.971.bb              | 23 -------------------
>  3 files changed, 37 deletions(-)
>  delete mode 100644 meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
>  delete mode 100644 meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> 
> diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> index b23d24c6d4..c12d475047 100644
> --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> @@ -245,8 +245,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
>      python3-msk \
>      python3-msm \
>      python3-multidict \
> -    python3-mypy \
> -    python3-mypy-extensions \
>      python3-natsort \
>      python3-netaddr \
>      python3-netifaces \
> diff --git a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb b/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
> deleted file mode 100644
> index 83ac5362d6..0000000000
> --- a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
> +++ /dev/null
> @@ -1,12 +0,0 @@
> -SUMMARY = "Experimental type system extensions for programs checked with the mypy typechecker"
> -HOMEPAGE = "https://github.com/python/mypy_extensions"
> -LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=0fe3219e2470a78c0d1837019b8b426e"
> -
> -PYPI_PACKAGE = "mypy_extensions"
> -
> -inherit pypi setuptools3
> -
> -SRC_URI[sha256sum] = "2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"
> -
> -BBCLASSEXTEND = "native"
> diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> deleted file mode 100644
> index 31fcb06c9e..0000000000
> --- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> +++ /dev/null
> @@ -1,23 +0,0 @@
> -SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
> -HOMEPAGE = "https://github.com/python/mypy"
> -LICENSE = "MIT & Python-2.0"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
> -
> -PYPI_PACKAGE = "mypy"
> -
> -inherit pypi python_setuptools_build_meta
> -
> -SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
> -
> -BBCLASSEXTEND = "native"
> -
> -RDEPENDS:${PN} += " \
> -    ${PYTHON_PN}-mypy-extensions \
> -    ${PYTHON_PN}-typed-ast \
> -    ${PYTHON_PN}-typing-extensions \
> -    ${PYTHON_PN}-json \
> -    ${PYTHON_PN}-compression \
> -    ${PYTHON_PN}-pprint \
> -    ${PYTHON_PN}-difflib \
> -    ${PYTHON_PN}-toml \
> -"
> -- 
> 2.41.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#103996): https://lists.openembedded.org/g/openembedded-devel/message/103996
> Mute This Topic: https://lists.openembedded.org/mt/100333071/4454694
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [jsbronder@cold-front.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Justin Bronder July 24, 2023, 7:30 p.m. UTC | #2
On 24/07/23 15:18 -0400, Justin Bronder wrote:
> On 24/07/23 12:58 -0400, Trevor Gamblin wrote:
> > While attempting to upgrade mypy and mypy-extensions, it was discovered
> > that it depends on new modules, some of which have no maintenance plan
> > in place, e.g.: https://pypi.org/project/types-typed-ast/
> 
> That dependency has been dropped upstream as part of removing support for python
> 3.7 [1].  If there's other other problematic recipes, I think it'd be beneficial
> to have a type checker for python available.
> 
> 1. https://github.com/python/mypy/commit/2edaf35ec1f91c139dfe1930b1b0d1e1cac59599

1.5 looks like it'll be released soon.  If there's interested in keeping mypy
around, I'll volunteer to try to package it then.

https://github.com/python/mypy/issues/15588

> 
> 
> > 
> > Since this is something we want to avoid adding to the ecosystem and
> > mypy isn't a dependency for anything else in meta-python, remove the
> > recipes.
> > 
> > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > ---
> > v2 removes the recipes from the packagegroup as well.
> > 
> >  .../packagegroups/packagegroup-meta-python.bb |  2 --
> >  .../python/python3-mypy-extensions_0.4.3.bb   | 12 ----------
> >  .../python/python3-mypy_0.971.bb              | 23 -------------------
> >  3 files changed, 37 deletions(-)
> >  delete mode 100644 meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
> >  delete mode 100644 meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> > 
> > diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> > index b23d24c6d4..c12d475047 100644
> > --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> > +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
> > @@ -245,8 +245,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
> >      python3-msk \
> >      python3-msm \
> >      python3-multidict \
> > -    python3-mypy \
> > -    python3-mypy-extensions \
> >      python3-natsort \
> >      python3-netaddr \
> >      python3-netifaces \
> > diff --git a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb b/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
> > deleted file mode 100644
> > index 83ac5362d6..0000000000
> > --- a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
> > +++ /dev/null
> > @@ -1,12 +0,0 @@
> > -SUMMARY = "Experimental type system extensions for programs checked with the mypy typechecker"
> > -HOMEPAGE = "https://github.com/python/mypy_extensions"
> > -LICENSE = "MIT"
> > -LIC_FILES_CHKSUM = "file://LICENSE;md5=0fe3219e2470a78c0d1837019b8b426e"
> > -
> > -PYPI_PACKAGE = "mypy_extensions"
> > -
> > -inherit pypi setuptools3
> > -
> > -SRC_URI[sha256sum] = "2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"
> > -
> > -BBCLASSEXTEND = "native"
> > diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> > deleted file mode 100644
> > index 31fcb06c9e..0000000000
> > --- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> > +++ /dev/null
> > @@ -1,23 +0,0 @@
> > -SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
> > -HOMEPAGE = "https://github.com/python/mypy"
> > -LICENSE = "MIT & Python-2.0"
> > -LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
> > -
> > -PYPI_PACKAGE = "mypy"
> > -
> > -inherit pypi python_setuptools_build_meta
> > -
> > -SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
> > -
> > -BBCLASSEXTEND = "native"
> > -
> > -RDEPENDS:${PN} += " \
> > -    ${PYTHON_PN}-mypy-extensions \
> > -    ${PYTHON_PN}-typed-ast \
> > -    ${PYTHON_PN}-typing-extensions \
> > -    ${PYTHON_PN}-json \
> > -    ${PYTHON_PN}-compression \
> > -    ${PYTHON_PN}-pprint \
> > -    ${PYTHON_PN}-difflib \
> > -    ${PYTHON_PN}-toml \
> > -"
> > -- 
> > 2.41.0
> > 
> 
> > 
> > 
> > 
> 
> 
> -- 
> Justin Bronder

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104000): https://lists.openembedded.org/g/openembedded-devel/message/104000
> Mute This Topic: https://lists.openembedded.org/mt/100336187/4454694
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [jsbronder@cold-front.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tim Orling July 24, 2023, 7:47 p.m. UTC | #3
On Mon, Jul 24, 2023 at 12:30 PM Justin Bronder <jsbronder@cold-front.org>
wrote:

> On 24/07/23 15:18 -0400, Justin Bronder wrote:
> > On 24/07/23 12:58 -0400, Trevor Gamblin wrote:
> > > While attempting to upgrade mypy and mypy-extensions, it was discovered
> > > that it depends on new modules, some of which have no maintenance plan
> > > in place, e.g.: https://pypi.org/project/types-typed-ast/
> >
> > That dependency has been dropped upstream as part of removing support
> for python
> > 3.7 [1].  If there's other other problematic recipes, I think it'd be
> beneficial
> > to have a type checker for python available.
> >
> > 1.
> https://github.com/python/mypy/commit/2edaf35ec1f91c139dfe1930b1b0d1e1cac59599
>
> 1.5 looks like it'll be released soon.  If there's interested in keeping
> mypy
> around, I'll volunteer to try to package it then.
>
> https://github.com/python/mypy/issues/15588
>

That’s much appreciated. We can hold off on the deletion then. Plenty of
whack-a-mole to go yet.


> >
> >
> > >
> > > Since this is something we want to avoid adding to the ecosystem and
> > > mypy isn't a dependency for anything else in meta-python, remove the
> > > recipes.
> > >
> > > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > > ---
> > > v2 removes the recipes from the packagegroup as well.
> > >
> > >  .../packagegroups/packagegroup-meta-python.bb |  2 --
> > >  .../python/python3-mypy-extensions_0.4.3.bb   | 12 ----------
> > >  .../python/python3-mypy_0.971.bb              | 23
> -------------------
> > >  3 files changed, 37 deletions(-)
> > >  delete mode 100644 meta-python/recipes-devtools/python/
> python3-mypy-extensions_0.4.3.bb
> > >  delete mode 100644 meta-python/recipes-devtools/python/
> python3-mypy_0.971.bb
> > >
> > > diff --git a/meta-python/recipes-core/packagegroups/
> packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/
> packagegroup-meta-python.bb
> > > index b23d24c6d4..c12d475047 100644
> > > --- a/meta-python/recipes-core/packagegroups/
> packagegroup-meta-python.bb
> > > +++ b/meta-python/recipes-core/packagegroups/
> packagegroup-meta-python.bb
> > > @@ -245,8 +245,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
> > >      python3-msk \
> > >      python3-msm \
> > >      python3-multidict \
> > > -    python3-mypy \
> > > -    python3-mypy-extensions \
> > >      python3-natsort \
> > >      python3-netaddr \
> > >      python3-netifaces \
> > > diff --git a/meta-python/recipes-devtools/python/
> python3-mypy-extensions_0.4.3.bb b/meta-python/recipes-devtools/python/
> python3-mypy-extensions_0.4.3.bb
> > > deleted file mode 100644
> > > index 83ac5362d6..0000000000
> > > --- a/meta-python/recipes-devtools/python/
> python3-mypy-extensions_0.4.3.bb
> > > +++ /dev/null
> > > @@ -1,12 +0,0 @@
> > > -SUMMARY = "Experimental type system extensions for programs checked
> with the mypy typechecker"
> > > -HOMEPAGE = "https://github.com/python/mypy_extensions"
> > > -LICENSE = "MIT"
> > > -LIC_FILES_CHKSUM =
> "file://LICENSE;md5=0fe3219e2470a78c0d1837019b8b426e"
> > > -
> > > -PYPI_PACKAGE = "mypy_extensions"
> > > -
> > > -inherit pypi setuptools3
> > > -
> > > -SRC_URI[sha256sum] =
> "2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"
> > > -
> > > -BBCLASSEXTEND = "native"
> > > diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> > > deleted file mode 100644
> > > index 31fcb06c9e..0000000000
> > > --- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
> > > +++ /dev/null
> > > @@ -1,23 +0,0 @@
> > > -SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
> > > -HOMEPAGE = "https://github.com/python/mypy"
> > > -LICENSE = "MIT & Python-2.0"
> > > -LIC_FILES_CHKSUM =
> "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
> > > -
> > > -PYPI_PACKAGE = "mypy"
> > > -
> > > -inherit pypi python_setuptools_build_meta
> > > -
> > > -SRC_URI[sha256sum] =
> "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
> > > -
> > > -BBCLASSEXTEND = "native"
> > > -
> > > -RDEPENDS:${PN} += " \
> > > -    ${PYTHON_PN}-mypy-extensions \
> > > -    ${PYTHON_PN}-typed-ast \
> > > -    ${PYTHON_PN}-typing-extensions \
> > > -    ${PYTHON_PN}-json \
> > > -    ${PYTHON_PN}-compression \
> > > -    ${PYTHON_PN}-pprint \
> > > -    ${PYTHON_PN}-difflib \
> > > -    ${PYTHON_PN}-toml \
> > > -"
> > > --
> > > 2.41.0
> > >
> >
> > >
> > >
> > >
> >
> >
> > --
> > Justin Bronder
>
> >
> >
> >
>
>
> --
> Justin Bronder
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104001):
> https://lists.openembedded.org/g/openembedded-devel/message/104001
> Mute This Topic: https://lists.openembedded.org/mt/100336398/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index b23d24c6d4..c12d475047 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -245,8 +245,6 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-msk \
     python3-msm \
     python3-multidict \
-    python3-mypy \
-    python3-mypy-extensions \
     python3-natsort \
     python3-netaddr \
     python3-netifaces \
diff --git a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb b/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
deleted file mode 100644
index 83ac5362d6..0000000000
--- a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
+++ /dev/null
@@ -1,12 +0,0 @@ 
-SUMMARY = "Experimental type system extensions for programs checked with the mypy typechecker"
-HOMEPAGE = "https://github.com/python/mypy_extensions"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0fe3219e2470a78c0d1837019b8b426e"
-
-PYPI_PACKAGE = "mypy_extensions"
-
-inherit pypi setuptools3
-
-SRC_URI[sha256sum] = "2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
deleted file mode 100644
index 31fcb06c9e..0000000000
--- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
+++ /dev/null
@@ -1,23 +0,0 @@ 
-SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
-HOMEPAGE = "https://github.com/python/mypy"
-LICENSE = "MIT & Python-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
-
-PYPI_PACKAGE = "mypy"
-
-inherit pypi python_setuptools_build_meta
-
-SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
-
-BBCLASSEXTEND = "native"
-
-RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-mypy-extensions \
-    ${PYTHON_PN}-typed-ast \
-    ${PYTHON_PN}-typing-extensions \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-compression \
-    ${PYTHON_PN}-pprint \
-    ${PYTHON_PN}-difflib \
-    ${PYTHON_PN}-toml \
-"