diff mbox series

python_setuptools3_rust: inherit ...build_meta

Message ID 20230723165215.4034727-1-tim.orling@konsulko.com
State Accepted, archived
Commit 52d33576a17574025e40526816c5f0ba72a57eea
Headers show
Series python_setuptools3_rust: inherit ...build_meta | expand

Commit Message

Tim Orling July 23, 2023, 4:52 p.m. UTC
Rather than inheriting the aging `setuptools3` bbclass, inherit
`python_setuptools_build_meta` which is one of the PEP 517 build
backends (for proper wheels using pyproject.toml).

Since python_setuptools_build_meta does not have a do_configure,
call the parent python_pep517_do_configure().

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
* All python3-cryptography ptests pass on core-image-base qemux86_64
* All python3-bcrypt ptests pass on core-image-base qemux86_64
* Basic python3-pyruvate Hello World example works
  (needs python3-logging) on core-image-base qemux86_64

 meta/classes-recipe/python_setuptools3_rust.bbclass | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/classes-recipe/python_setuptools3_rust.bbclass b/meta/classes-recipe/python_setuptools3_rust.bbclass
index d6ce2edb963..d3d7590cbeb 100644
--- a/meta/classes-recipe/python_setuptools3_rust.bbclass
+++ b/meta/classes-recipe/python_setuptools3_rust.bbclass
@@ -4,14 +4,14 @@ 
 # SPDX-License-Identifier: MIT
 #
 
-inherit python_pyo3 setuptools3
+inherit python_pyo3 python_setuptools_build_meta
 
 DEPENDS += "python3-setuptools-rust-native"
 
 python_setuptools3_rust_do_configure() {
     python_pyo3_do_configure
     cargo_common_do_configure
-    setuptools3_do_configure
+    python_pep517_do_configure
 }
 
 EXPORT_FUNCTIONS do_configure