diff mbox series

[meta-python,8/9] python3-flask: upgrade 2.2.3 -> 2.3.2

Message ID 20230721192530.2515633-8-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0 | expand

Commit Message

Trevor Gamblin July 21, 2023, 7:25 p.m. UTC
flask has migrated to using pyproject.toml, so we need
python_setuptools_build_meta instead of setuptools3.

Changelog: https://flask.palletsprojects.com/en/2.3.x/changes/#version-2-3-0

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/{python3-flask_2.2.3.bb => python3-flask_2.3.2.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-flask_2.2.3.bb => python3-flask_2.3.2.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask_2.2.3.bb b/meta-python/recipes-devtools/python/python3-flask_2.3.2.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-flask_2.2.3.bb
rename to meta-python/recipes-devtools/python/python3-flask_2.3.2.bb
index 90c56c75a4..ec9c62a170 100644
--- a/meta-python/recipes-devtools/python/python3-flask_2.2.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_2.3.2.bb
@@ -6,11 +6,11 @@  HOMEPAGE = "https://github.com/mitsuhiko/flask/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
 
-SRC_URI[sha256sum] = "7eb373984bf1c770023fce9db164ed0c3353cd0b53f130f4693da0ca756a2e6d"
+SRC_URI[sha256sum] = "8c2f9abd47a9e8df7f0c3f091ce9497d011dc3b31effcf4c85a6e2b50f4114ef"
 
 PYPI_PACKAGE = "Flask"
 
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
 
 CLEANBROKEN = "1"