diff mbox series

[meta-arago,master/kirkstone] clocl: Lock the llvm-config down to the native version

Message ID 20230721152404.9888-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone] clocl: Lock the llvm-config down to the native version | expand

Commit Message

Ryan Eatmon July 21, 2023, 3:24 p.m. UTC
We are seeing some random build failures related to how bitbake chooses
which llvm-config to run during do_compile.  This locks the path to
llvm-config to the native version of the tool.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Suggested-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-arago-extras/recipes-ti/ocl/clocl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-ti/ocl/clocl_git.bb b/meta-arago-extras/recipes-ti/ocl/clocl_git.bb
index 9b2a3aa9..52deaab8 100644
--- a/meta-arago-extras/recipes-ti/ocl/clocl_git.bb
+++ b/meta-arago-extras/recipes-ti/ocl/clocl_git.bb
@@ -19,7 +19,7 @@  TARGET:class-nativesdk = "x86"
 EXTRA_OEMAKE = " -C ${S}/clocl \
                  _PRODUCT_VERSION=${PV} \
                  TARGET=${TARGET} \
-                 LLVM_CONFIG_EXE=llvm-config \
+                 LLVM_CONFIG_EXE=${STAGING_BINDIR_NATIVE}/llvm-config \
 "
 
 do_compile() {