diff mbox series

[master/kirkstone] packagegroup-arago-sysvinit-boot: fix tiny image unable to login issue

Message ID 20230720000324.3094300-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master/kirkstone] packagegroup-arago-sysvinit-boot: fix tiny image unable to login issue | expand

Commit Message

Denys Dmytriyenko July 20, 2023, 12:03 a.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

Commit 292b4549c14c73c7b9d50051ef7a999377ab8f40 changed how login_manager
gets set conditionally for systemd vs. sysvinit builds. But tiny image is
rather special as it uses sysvinit even during systemd build. That's why
all other conditional VIRTUAL_RUNTIME variables were being forced in the
packagegroup-arago-sysvinit-boot - need to do the same for login_manager.
Otherwise it pulls shadow-base into a tiny image w/o additional required
dependencies for securetty and few pam plugins, preventing root user from
being able to login.

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../packagegroups/packagegroup-arago-sysvinit-boot.bb            | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
index 9f937343..df7ff960 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-sysvinit-boot.bb
@@ -12,3 +12,4 @@  VIRTUAL-RUNTIME_dev_manager = ""
 VIRTUAL-RUNTIME_init_manager = "sysvinit"
 VIRTUAL-RUNTIME_initscripts = "initscripts"
 VIRTUAL-RUNTIME_initramfs = "sysvinit-initramfs"
+VIRTUAL-RUNTIME_login_manager = "busybox"