diff mbox series

[meta-python] python3-gevent: upgrade 22.10.2 -> 23.7.0

Message ID 1689654348-30702-29-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-gevent: upgrade 22.10.2 -> 23.7.0 | expand

Commit Message

Mingyu Wang (Fujitsu) July 18, 2023, 4:25 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
Features
----------
-Add preliminary support for Python 3.12, using greenlet 3.0a1.
-Update the bundled c-ares version to 1.19.1.

Bugfixes
------------
-Fix an edge case connecting a non-blocking SSLSocket that could result in an AttributeError.
-Make gevent's FileObjectThread (mostly used on Windows) implement readinto cooperatively.
-Work around an AttributeError during cyclic garbage collection when Python finalizers (__del__ and the like) attempt to use gevent APIs.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-gevent_22.10.2.bb => python3-gevent_23.7.0.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-gevent_22.10.2.bb => python3-gevent_23.7.0.bb} (93%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gevent_22.10.2.bb b/meta-python/recipes-devtools/python/python3-gevent_23.7.0.bb
similarity index 93%
rename from meta-python/recipes-devtools/python/python3-gevent_22.10.2.bb
rename to meta-python/recipes-devtools/python/python3-gevent_23.7.0.bb
index b9bf9130db..a82abcc096 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_22.10.2.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_23.7.0.bb
@@ -13,7 +13,7 @@  RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
 
 SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch"
 
-SRC_URI[sha256sum] = "1ca01da176ee37b3527a2702f7d40dbc9ffb8cfc7be5a03bfa4f9eec45e55c46"
+SRC_URI[sha256sum] = "d0d3630674c1b344b256a298ab1ff43220f840b12af768131b5d74e485924237"
 
 inherit pypi setuptools3