diff mbox series

wic: Add dependencies for erofs-utils

Message ID 20230717044449.11556-1-heiko.thole@entwicklung.eq-3.de
State Accepted, archived
Commit 68e364340c439a1341d37c3f7a2b0e6aad8e1e56
Headers show
Series wic: Add dependencies for erofs-utils | expand

Commit Message

Heiko Thole July 17, 2023, 4:44 a.m. UTC
In order to build erofs filesystems, wic must have the erofs-utils package installed into its sysroot.

Signed-off-by: Heiko Thole <heiko.thole@entwicklung.eq-3.de>
---
 meta/classes/image_types_wic.bbclass | 2 +-
 meta/recipes-core/meta/wic-tools.bb  | 2 +-
 scripts/lib/wic/misc.py              | 1 +
 3 files changed, 3 insertions(+), 2 deletions(-)

--
2.41.0

eQ-3 Entwicklung GmbH, Maiburger Str. 36, 26789 Leer
Geschäftsführer: Prof. Heinz-G. Redeker
Registergericht: Amtsgericht Aurich, HRB 110388
eQ-3 AG, Maiburger Str. 29, 26789 Leer
Vorstand: Prof. Heinz-G. Redeker (Vorsitzender), Helga Redeker
Vorsitzende des Aufsichtsrats: Irmgard Keplin
Registergericht: Amtsgericht Aurich, HRB 200335

Comments

Alexandre Belloni July 17, 2023, 1:49 p.m. UTC | #1
Hello,

Commit 68e364340c43 ("wic: Add dependencies for erofs-utils") has
already done so for a while, maybe you want a backport instead?

On 17/07/2023 06:44:49+0200, Heiko wrote:
> In order to build erofs filesystems, wic must have the erofs-utils package installed into its sysroot.
> 
> Signed-off-by: Heiko Thole <heiko.thole@entwicklung.eq-3.de>
> ---
>  meta/classes/image_types_wic.bbclass | 2 +-
>  meta/recipes-core/meta/wic-tools.bb  | 2 +-
>  scripts/lib/wic/misc.py              | 1 +
>  3 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/classes/image_types_wic.bbclass b/meta/classes/image_types_wic.bbclass
> index 6453dd1b74..8497916d48 100644
> --- a/meta/classes/image_types_wic.bbclass
> +++ b/meta/classes/image_types_wic.bbclass
> @@ -83,7 +83,7 @@ do_image_wic[recrdeptask] += "do_deploy"
>  do_image_wic[deptask] += "do_image_complete"
> 
>  WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
> -WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native"
> +WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native erofs-utils-native"
>  # Unified kernel images need objcopy
>  WKS_FILE_DEPENDS_DEFAULT += "virtual/${MLPREFIX}${TARGET_PREFIX}binutils"
>  WKS_FILE_DEPENDS_BOOTLOADERS = ""
> diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
> index daaf3ea576..9282d36a4d 100644
> --- a/meta/recipes-core/meta/wic-tools.bb
> +++ b/meta/recipes-core/meta/wic-tools.bb
> @@ -6,7 +6,7 @@ DEPENDS = "\
>             parted-native gptfdisk-native dosfstools-native \
>             mtools-native bmap-tools-native grub-native cdrtools-native \
>             btrfs-tools-native squashfs-tools-native pseudo-native \
> -           e2fsprogs-native util-linux-native tar-native \
> +           e2fsprogs-native util-linux-native tar-native erofs-utils-native \
>             virtual/${TARGET_PREFIX}binutils \
>             "
>  DEPENDS:append:x86 = " syslinux-native syslinux grub-efi systemd-boot"
> diff --git a/scripts/lib/wic/misc.py b/scripts/lib/wic/misc.py
> index a8aab6c524..2b90821b30 100644
> --- a/scripts/lib/wic/misc.py
> +++ b/scripts/lib/wic/misc.py
> @@ -36,6 +36,7 @@ NATIVE_RECIPES = {"bmaptool": "bmap-tools",
>                    "mkdosfs": "dosfstools",
>                    "mkisofs": "cdrtools",
>                    "mkfs.btrfs": "btrfs-tools",
> +                  "mkfs.erofs": "erofs-utils",
>                    "mkfs.ext2": "e2fsprogs",
>                    "mkfs.ext3": "e2fsprogs",
>                    "mkfs.ext4": "e2fsprogs",
> --
> 2.41.0
> 
> eQ-3 Entwicklung GmbH, Maiburger Str. 36, 26789 Leer
> Gesch?ftsf?hrer: Prof. Heinz-G. Redeker
> Registergericht: Amtsgericht Aurich, HRB 110388
> eQ-3 AG, Maiburger Str. 29, 26789 Leer
> Vorstand: Prof. Heinz-G. Redeker (Vorsitzender), Helga Redeker
> Vorsitzende des Aufsichtsrats: Irmgard Keplin
> Registergericht: Amtsgericht Aurich, HRB 200335

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184427): https://lists.openembedded.org/g/openembedded-core/message/184427
> Mute This Topic: https://lists.openembedded.org/mt/100189195/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Heiko Thole July 17, 2023, 1:55 p.m. UTC | #2
Hello Alexandre,

I know. The patch is based on it.

I asked to cherrypick it. But Steve told me ( https://lists.openembedded.org/g/openembedded-core/message/184140 ) , that I should create a new patch.

Bye,
Heiko
Alexandre Belloni July 17, 2023, 2:20 p.m. UTC | #3
On 17/07/2023 06:55:42-0700, Heiko wrote:
> Hello Alexandre,
> 
> I know. The patch is based on it.
> 
> I asked to cherrypick it. But Steve told me ( https://lists.openembedded.org/g/openembedded-core/message/184140 ) , that I should create a new patch.
> 

Please mark it for kirkstone then

> Bye,
> Heiko

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#184468): https://lists.openembedded.org/g/openembedded-core/message/184468
> Mute This Topic: https://lists.openembedded.org/mt/100189195/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Steve Sakoman July 17, 2023, 2:25 p.m. UTC | #4
On Mon, Jul 17, 2023 at 4:20 AM Alexandre Belloni via
lists.openembedded.org
<alexandre.belloni=bootlin.com@lists.openembedded.org> wrote:
>
> On 17/07/2023 06:55:42-0700, Heiko wrote:
> > Hello Alexandre,
> >
> > I know. The patch is based on it.
> >
> > I asked to cherrypick it. But Steve told me ( https://lists.openembedded.org/g/openembedded-core/message/184140 ) , that I should create a new patch.
> >
>
> Please mark it for kirkstone then

Yes, the patch subject should be something like: [oe-core] [kirkstone]
[PATCH] wic: Add dependencies for erofs-utils

No need to re-submit this time though, I've taken the patch into my test queue.

Steve
diff mbox series

Patch

diff --git a/meta/classes/image_types_wic.bbclass b/meta/classes/image_types_wic.bbclass
index 6453dd1b74..8497916d48 100644
--- a/meta/classes/image_types_wic.bbclass
+++ b/meta/classes/image_types_wic.bbclass
@@ -83,7 +83,7 @@  do_image_wic[recrdeptask] += "do_deploy"
 do_image_wic[deptask] += "do_image_complete"

 WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
-WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native"
+WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native erofs-utils-native"
 # Unified kernel images need objcopy
 WKS_FILE_DEPENDS_DEFAULT += "virtual/${MLPREFIX}${TARGET_PREFIX}binutils"
 WKS_FILE_DEPENDS_BOOTLOADERS = ""
diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index daaf3ea576..9282d36a4d 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -6,7 +6,7 @@  DEPENDS = "\
            parted-native gptfdisk-native dosfstools-native \
            mtools-native bmap-tools-native grub-native cdrtools-native \
            btrfs-tools-native squashfs-tools-native pseudo-native \
-           e2fsprogs-native util-linux-native tar-native \
+           e2fsprogs-native util-linux-native tar-native erofs-utils-native \
            virtual/${TARGET_PREFIX}binutils \
            "
 DEPENDS:append:x86 = " syslinux-native syslinux grub-efi systemd-boot"
diff --git a/scripts/lib/wic/misc.py b/scripts/lib/wic/misc.py
index a8aab6c524..2b90821b30 100644
--- a/scripts/lib/wic/misc.py
+++ b/scripts/lib/wic/misc.py
@@ -36,6 +36,7 @@  NATIVE_RECIPES = {"bmaptool": "bmap-tools",
                   "mkdosfs": "dosfstools",
                   "mkisofs": "cdrtools",
                   "mkfs.btrfs": "btrfs-tools",
+                  "mkfs.erofs": "erofs-utils",
                   "mkfs.ext2": "e2fsprogs",
                   "mkfs.ext3": "e2fsprogs",
                   "mkfs.ext4": "e2fsprogs",