diff mbox series

[meta-oe] lastlog2: add new recipe

Message ID 1689296444-28141-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] lastlog2: add new recipe | expand

Commit Message

Mingyu Wang (Fujitsu) July 14, 2023, 1 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../lastlog2/lastlog2_1.1.0.bb                | 30 +++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb

Comments

Khem Raj July 14, 2023, 10:02 p.m. UTC | #1
fails to build with ptests on

tests/tst-y2038-64bit-time_t.p/tst-y2038-64bit-time_t.c.o: file not
recognized: file format not recognized

see - https://errors.yoctoproject.org/Errors/Details/716657/

On Thu, Jul 13, 2023 at 6:01 PM wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../lastlog2/lastlog2_1.1.0.bb                | 30 +++++++++++++++++++
>  1 file changed, 30 insertions(+)
>  create mode 100644 meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb
>
> diff --git a/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb b/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb
> new file mode 100644
> index 0000000000..cc60a46899
> --- /dev/null
> +++ b/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb
> @@ -0,0 +1,30 @@
> +SUMMARY = "Y2038 safe version of lastlog"
> +HOMEPAGE = "https://github.com/thkukuk/lastlog2"
> +DESCRIPTION = "lastlog reports the last login of a given user or of all users who did ever login on a system."
> +LICENSE = "BSD-2-Clause"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c"
> +SECTION = "libs"
> +
> +SRCREV = "585153a577788c590370d20e40263b61238dfab3"
> +
> +SRC_URI = "git://github.com/thkukuk/lastlog2.git;branch=main;protocol=https"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit meson pkgconfig systemd
> +
> +DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} sqlite3 "
> +
> +SYSTEMD_SERVICE:${PN} = "lastlog2-import.service"
> +
> +EXTRA_OEMESON = " -Dpamlibdir=${libdir}"
> +
> +do_install:append () {
> +      # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
> +      # without usrmerge distro feature enabled
> +      install -d `dirname ${D}${systemd_unitdir}`
> +      mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
> +}
> +
> +FILES:${PN} += " ${systemd_system_unitdir} "
> +FILES:${PN} += " ${libdir} "
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#103858): https://lists.openembedded.org/g/openembedded-devel/message/103858
> Mute This Topic: https://lists.openembedded.org/mt/100132957/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb b/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb
new file mode 100644
index 0000000000..cc60a46899
--- /dev/null
+++ b/meta-oe/recipes-extended/lastlog2/lastlog2_1.1.0.bb
@@ -0,0 +1,30 @@ 
+SUMMARY = "Y2038 safe version of lastlog"
+HOMEPAGE = "https://github.com/thkukuk/lastlog2"
+DESCRIPTION = "lastlog reports the last login of a given user or of all users who did ever login on a system."
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c"
+SECTION = "libs"
+
+SRCREV = "585153a577788c590370d20e40263b61238dfab3"
+
+SRC_URI = "git://github.com/thkukuk/lastlog2.git;branch=main;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
+
+DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} sqlite3 "
+
+SYSTEMD_SERVICE:${PN} = "lastlog2-import.service"
+
+EXTRA_OEMESON = " -Dpamlibdir=${libdir}"
+
+do_install:append () {
+      # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
+      # without usrmerge distro feature enabled
+      install -d `dirname ${D}${systemd_unitdir}`
+      mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
+}
+
+FILES:${PN} += " ${systemd_system_unitdir} "
+FILES:${PN} += " ${libdir} "