[v2] icu: fix make_icudata dependencies

Message ID 20220120165455.42075-1-kory.maincent@bootlin.com
State Accepted, archived
Commit c134f62062a6359d2d5831ba4cb9694035e4f25a
Headers show
Series [v2] icu: fix make_icudata dependencies | expand

Commit Message

Köry Maincent Jan. 20, 2022, 4:54 p.m. UTC
The make_icudata task is set before the configure task then the
dependencies for this task are not populate yet.

Fixed it by setting the deptask flag to do_populate_sysroot. With this, the
do_populate_sysroot task of each item in DEPENDS must complete before
do_make_icudata can execute.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---

Change in v2:
Use deptask flag instead of setting manually the task dependencies with
depends flag.

 meta/recipes-support/icu/icu_70.1.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Alexander Kanavin Jan. 20, 2022, 7:05 p.m. UTC | #1
This isn't correct, as recipe's own sysroot is populated by
prepare_recipe_sysroot() of the recipe.

I think the real correct fix is

addtask do_make_icudata before do_configure after do_patch
do_prepare_recipe_sysroot

You need to tweak the line at the end of the recipe.

Alex

On Thu, 20 Jan 2022 at 17:54, Kory Maincent <kory.maincent@bootlin.com>
wrote:

> The make_icudata task is set before the configure task then the
> dependencies for this task are not populate yet.
>
> Fixed it by setting the deptask flag to do_populate_sysroot. With this, the
> do_populate_sysroot task of each item in DEPENDS must complete before
> do_make_icudata can execute.
>
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
> ---
>
> Change in v2:
> Use deptask flag instead of setting manually the task dependencies with
> depends flag.
>
>  meta/recipes-support/icu/icu_70.1.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-support/icu/icu_70.1.bb
> b/meta/recipes-support/icu/icu_70.1.bb
> index 0988ae8b8e..ff5e249e9d 100644
> --- a/meta/recipes-support/icu/icu_70.1.bb
> +++ b/meta/recipes-support/icu/icu_70.1.bb
> @@ -123,6 +123,9 @@ EXTRA_OECONF:append:libc-musl = "
> ac_cv_func_strtod_l=no"
>  PACKAGECONFIG ?= ""
>  PACKAGECONFIG[make-icudata] = ",,,"
>
> +# Add dependencies to make_icudata
> +do_make_icudata[deptask] += "do_populate_sysroot"
> +
>  do_make_icudata:class-target () {
>      ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0',
> d)}
>      cd ${S}
> --
> 2.25.1
>
>

Patch

diff --git a/meta/recipes-support/icu/icu_70.1.bb b/meta/recipes-support/icu/icu_70.1.bb
index 0988ae8b8e..ff5e249e9d 100644
--- a/meta/recipes-support/icu/icu_70.1.bb
+++ b/meta/recipes-support/icu/icu_70.1.bb
@@ -123,6 +123,9 @@  EXTRA_OECONF:append:libc-musl = " ac_cv_func_strtod_l=no"
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[make-icudata] = ",,,"
 
+# Add dependencies to make_icudata
+do_make_icudata[deptask] += "do_populate_sysroot"
+
 do_make_icudata:class-target () {
     ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
     cd ${S}