[2/2] meta-arm-bsp: use old python3-crytography on platforms using TF-M

Message ID 20220120163206.1950366-2-ross.burton@arm.com
State New
Headers show
Series [1/2] meta-arm: add old version of python3-cryptography | expand

Commit Message

Ross Burton Jan. 20, 2022, 4:32 p.m. UTC
As the latest python3-crytography breaks TF-M builds, downgrade those
machines using TF-M (musca and corstone) to python3-crytography-native
3.3.2 temporarily.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-arm-bsp/conf/layer.conf                       | 6 +++++-
 meta-arm-bsp/conf/machine/include/corstone1000.inc | 5 +++++
 meta-arm-bsp/conf/machine/musca-b1.conf            | 5 +++++
 meta-arm-bsp/conf/machine/musca-s1.conf            | 5 +++++
 4 files changed, 20 insertions(+), 1 deletion(-)

Patch

diff --git a/meta-arm-bsp/conf/layer.conf b/meta-arm-bsp/conf/layer.conf
index 45767866..82230470 100644
--- a/meta-arm-bsp/conf/layer.conf
+++ b/meta-arm-bsp/conf/layer.conf
@@ -21,4 +21,8 @@  LAYERDEPENDS_meta-arm-bsp:append:musca-s1 = " meta-python"
 LICENSE_PATH += "${LAYERDIR}/custom-licenses"
 
 # Delete this when our downgrade of python3-cryptography is removed
-BBMASK += "meta-arm-bsp/recipes-devtools/python/python3-cryptography_3.3.2.bb"
+META_ARM_PYCRYPTO = "meta-arm-bsp/recipes-devtools/python/python3-cryptography_3.3.2.bb"
+META_ARM_PYCRYPTO:corstone1000 = ""
+META_ARM_PYCRYPTO:musca-b1 = ""
+META_ARM_PYCRYPTO:musca-s1 = ""
+BBMASK += "${META_ARM_PYCRYPTO}"
diff --git a/meta-arm-bsp/conf/machine/include/corstone1000.inc b/meta-arm-bsp/conf/machine/include/corstone1000.inc
index f9d301e4..019293b0 100644
--- a/meta-arm-bsp/conf/machine/include/corstone1000.inc
+++ b/meta-arm-bsp/conf/machine/include/corstone1000.inc
@@ -63,3 +63,8 @@  SERIAL_CONSOLES ?= "115200;ttyAMA0"
 WKS_FILE_DEPENDS:append = " ${EXTRA_IMAGEDEPENDS}"
 
 WKS_FILE ?= "corstone1000-image.corstone1000.wks"
+
+# The latest python3-cryptography-native doesn't work
+# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
+# version before Rust was involved for now.
+PREFERRED_VERSION_python3-cryptography-native = "3.3.2"
diff --git a/meta-arm-bsp/conf/machine/musca-b1.conf b/meta-arm-bsp/conf/machine/musca-b1.conf
index 073c466e..ec5ff4ee 100644
--- a/meta-arm-bsp/conf/machine/musca-b1.conf
+++ b/meta-arm-bsp/conf/machine/musca-b1.conf
@@ -26,3 +26,8 @@  ZEPHYR_INHERIT_CLASSES += "zephyr-qemuboot"
 ARCH:musca-b1 = "arm"
 
 TFM_PLATFORM = "arm/musca_b1/sse_200"
+
+# The latest python3-cryptography-native doesn't work
+# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
+# version before Rust was involved for now.
+PREFERRED_VERSION_python3-cryptography-native = "3.3.2"
diff --git a/meta-arm-bsp/conf/machine/musca-s1.conf b/meta-arm-bsp/conf/machine/musca-s1.conf
index d18c06c2..e5f63f76 100644
--- a/meta-arm-bsp/conf/machine/musca-s1.conf
+++ b/meta-arm-bsp/conf/machine/musca-s1.conf
@@ -25,3 +25,8 @@  ZEPHYR_INHERIT_CLASSES += "zephyr-qemuboot"
 ARCH:musca-s1 = "arm"
 
 TFM_PLATFORM = "arm/musca_s1"
+
+# The latest python3-cryptography-native doesn't work
+# (cryptography.exceptions.InternalError: Unknown OpenSSL error) so use the
+# version before Rust was involved for now.
+PREFERRED_VERSION_python3-cryptography-native = "3.3.2"