diff mbox series

python3-setuptools: upgrade 67.6.1 -> 68.0.0

Message ID 20230710191231.170744-1-tgamblin@baylibre.com
State Accepted, archived
Commit a248b94dff49b0331bd1e37e594f983fc50b3f0d
Headers show
Series python3-setuptools: upgrade 67.6.1 -> 68.0.0 | expand

Commit Message

Trevor Gamblin July 10, 2023, 7:12 p.m. UTC
AUH upgrade failed because the LICENSE checksum no longer matched. This
is because the attribution in the file was removed upstream in v67.8.0.
Patch fuzz also needed to be upgraded for
0001-conditionally-do-not-fetch-code-by-easy_install.patch.

Changelog: https://setuptools.pypa.io/en/stable/history.html

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...itionally-do-not-fetch-code-by-easy_install.patch | 12 +++++++-----
 ...ptools_67.6.1.bb => python3-setuptools_68.0.0.bb} |  4 ++--
 2 files changed, 9 insertions(+), 7 deletions(-)
 rename meta/recipes-devtools/python/{python3-setuptools_67.6.1.bb => python3-setuptools_68.0.0.bb} (90%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
index 4d56dc89ba..1e5ab498a4 100644
--- a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
+++ b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
@@ -1,4 +1,4 @@ 
-From 2b06ca797d3ccc5b195aaa04a085c44bf61d4de3 Mon Sep 17 00:00:00 2001
+From 5e603da9c01ccb828a03ea3e82d15599971f794f Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Tue, 17 Jul 2018 10:13:38 +0800
 Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -9,17 +9,16 @@  internet by easy_install.
 Upstream-Status: Inappropriate [oe specific]
 
 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-
 ---
  setuptools/command/easy_install.py | 5 +++++
  1 file changed, 5 insertions(+)
 
 diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 444d3b3..61e445a 100644
+index 0b8d1159..93308060 100644
 --- a/setuptools/command/easy_install.py
 +++ b/setuptools/command/easy_install.py
-@@ -648,6 +648,11 @@ class easy_install(Command):
-             os.path.exists(tmpdir) and rmtree(tmpdir)
+@@ -644,6 +644,11 @@ class easy_install(Command):
+             os.path.exists(tmpdir) and _rmtree(tmpdir)
  
      def easy_install(self, spec, deps=False):
 +        if os.environ.get('NO_FETCH_BUILD', None):
@@ -30,3 +29,6 @@  index 444d3b3..61e445a 100644
          with self._tmpdir() as tmpdir:
              if not isinstance(spec, Requirement):
                  if URL_SCHEME(spec):
+-- 
+2.41.0
+
diff --git a/meta/recipes-devtools/python/python3-setuptools_67.6.1.bb b/meta/recipes-devtools/python/python3-setuptools_68.0.0.bb
similarity index 90%
rename from meta/recipes-devtools/python/python3-setuptools_67.6.1.bb
rename to meta/recipes-devtools/python/python3-setuptools_68.0.0.bb
index ad0d7cc527..4ac789d18c 100644
--- a/meta/recipes-devtools/python/python3-setuptools_67.6.1.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_68.0.0.bb
@@ -2,7 +2,7 @@  SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
 HOMEPAGE = "https://pypi.org/project/setuptools"
 SECTION = "devel/python"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f"
 
 inherit pypi python_setuptools_build_meta
 
@@ -11,7 +11,7 @@  SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-e
 SRC_URI += " \
             file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch"
 
-SRC_URI[sha256sum] = "257de92a9d50a60b8e22abfcbb771571fde0dbf3ec234463212027a4eeecbe9a"
+SRC_URI[sha256sum] = "baf1fdb41c6da4cd2eae722e135500da913332ab3f2f5c7d33af9b492acb5235"
 
 DEPENDS += "${PYTHON_PN}"