[meta-gnome,1/2] geary: initial add recipe

Message ID 20220120151824.61601-1-f_l_k@t-online.de
State New
Headers show
Series [meta-gnome,1/2] geary: initial add recipe | expand

Commit Message

Markus Volk Jan. 20, 2022, 3:18 p.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../recipes-connectivity/geary/geary_40.0.bb  | 54 +++++++++++++++++++
 1 file changed, 54 insertions(+)
 create mode 100644 meta-gnome/recipes-connectivity/geary/geary_40.0.bb

Comments

Khem Raj Jan. 20, 2022, 6:22 p.m. UTC | #1
thanks for the patches, they should be sent to oe-devel mailing list.

On 1/20/22 7:18 AM, Markus Volk wrote:
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>   .../recipes-connectivity/geary/geary_40.0.bb  | 54 +++++++++++++++++++
>   1 file changed, 54 insertions(+)
>   create mode 100644 meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> 
> diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> new file mode 100644
> index 000000000..e4d07ad29
> --- /dev/null
> +++ b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
> @@ -0,0 +1,54 @@
> +SUMMARY = "Geary is an email application built around conversations, for the GNOME 3 desktop."
> +SECTION = "network"
> +LICENSE = "LGPL-2.1"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=2a2244d5a13871ad950c55877546a6a2"
> +
> +DEPENDS = " \
> +	appstream-glib \
> +	cairo \
> +	enchant2 \
> +	evolution-data-server \
> +	folks \
> +	gcr \
> +	gmime \
> +	gnome-online-accounts \
> +	gsound \
> +	gspell \
> +	gtk+3 \
> +	icu \
> +	iso-codes \
> +	json-glib \
> +	libhandy \
> +	libical \
> +	libpeas \
> +	libsecret \
> +	libstemmer \
> +	libxml2 \
> +	sqlite3 \
> +	webkitgtk \
> +"
> +
> +RDEPENDS:${PN} = "gnome-keyring"
> +
> +inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala
> +
> +SRC_URI = " \
> +	git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
> +"
> +
> +S = "${WORKDIR}/git"
> +SRCREV = "gnome-${PV}"
> +
> +REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
> +
> +GIR_MESON_OPTION = ""
> +EXTRA_OEMESON = "-Dprofile=release"
> +
> +PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
> +PACKAGECONFIG[tnef] = "-Dtnef=enabled,-Dtnef=disabled,libytnef"
> +PACKAGECONFIG[valadoc] = "-Dvaladoc=enabled,-Dvaladoc=disabled"
> +
> +PACKAGECONFIG ??= ""
> +
> +FILES:${PN} += "${datadir}"
> +
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#160767): https://lists.openembedded.org/g/openembedded-core/message/160767
> Mute This Topic: https://lists.openembedded.org/mt/88560747/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-gnome/recipes-connectivity/geary/geary_40.0.bb b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
new file mode 100644
index 000000000..e4d07ad29
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/geary/geary_40.0.bb
@@ -0,0 +1,54 @@ 
+SUMMARY = "Geary is an email application built around conversations, for the GNOME 3 desktop."
+SECTION = "network"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2a2244d5a13871ad950c55877546a6a2"
+
+DEPENDS = " \
+	appstream-glib \
+	cairo \
+	enchant2 \
+	evolution-data-server \
+	folks \
+	gcr \
+	gmime \
+	gnome-online-accounts \
+	gsound \
+	gspell \
+	gtk+3 \
+	icu \
+	iso-codes \
+	json-glib \
+	libhandy \
+	libical \
+	libpeas \
+	libsecret \
+	libstemmer \
+	libxml2 \
+	sqlite3 \
+	webkitgtk \
+"
+
+RDEPENDS:${PN} = "gnome-keyring"
+
+inherit meson pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala
+
+SRC_URI = " \
+	git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
+"
+
+S = "${WORKDIR}/git"
+SRCREV = "gnome-${PV}"
+
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+
+GIR_MESON_OPTION = ""
+EXTRA_OEMESON = "-Dprofile=release"
+
+PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
+PACKAGECONFIG[tnef] = "-Dtnef=enabled,-Dtnef=disabled,libytnef"
+PACKAGECONFIG[valadoc] = "-Dvaladoc=enabled,-Dvaladoc=disabled"
+
+PACKAGECONFIG ??= ""
+
+FILES:${PN} += "${datadir}"
+