diff mbox series

[meta-arago,kirkstone/master] arago-image.inc: remove IMAGE_FEATURES append weston

Message ID 20230705214637.1376739-1-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,kirkstone/master] arago-image.inc: remove IMAGE_FEATURES append weston | expand

Commit Message

Randolph Sapp July 5, 2023, 9:46 p.m. UTC
From: Randolph Sapp <rs@ti.com>

Remove the IMAGE_FEATURES append line I was using to automatically
configure some options from the core image we inherit. Instead
explicitly set the systemd target based on the opengl distro feature and
what image you are building for.

This reverts commit f21a29344aebc86910b73d1adffe356113442506.
---
 meta-arago-distro/recipes-core/images/arago-image.inc        | 5 -----
 meta-arago-distro/recipes-core/images/tisdk-default-image.bb | 5 +++++
 .../recipes-core/images/tisdk-thinlinux-image.bb             | 5 +++++
 3 files changed, 10 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/arago-image.inc b/meta-arago-distro/recipes-core/images/arago-image.inc
index 8e8eb114..d00c1f70 100644
--- a/meta-arago-distro/recipes-core/images/arago-image.inc
+++ b/meta-arago-distro/recipes-core/images/arago-image.inc
@@ -6,11 +6,6 @@  COMPATIBLE_MACHINE = "ti-soc"
 
 IMAGE_FEATURES += "package-management splash"
 
-# this is required to make sure the proper systemd default target gets set
-IMAGE_FEATURES += " \
-	${@bb.utils.contains("DISTRO_FEATURES", "wayland", "weston", "", d)} \
-"
-
 # 4KB per 1 inode should be enough
 EXTRA_IMAGECMD:ext2.gz += "-i 4096"
 
diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index 7769c97c..787fac95 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -7,6 +7,11 @@  require arago-image.inc
 
 ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= ""
 
+# we're assuming some display manager is being installed with opengl
+SYSTEMD_DEFAULT_TARGET = " \
+    ${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)} \
+"
+
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
     packagegroup-arago-console \
diff --git a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
index a61e6881..a840b7a0 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
@@ -8,6 +8,11 @@  require arago-image.inc
 # Allow users to tack on additional packages as interesting.
 ARAGO_THIN_IMAGE_EXTRA_INSTALL ?= ""
 
+# we're assuming some display manager is being installed with opengl
+SYSTEMD_DEFAULT_TARGET = " \
+    ${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)} \
+"
+
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
     packagegroup-arago-console \