diff mbox series

[meta-networking,2/2] libcoap: Build linker symbol file explicitly

Message ID 20230704220315.1958265-2-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/2] ctags: Extend to build native package | expand

Commit Message

Khem Raj July 4, 2023, 10:03 p.m. UTC
Since we autoreconf, it should be better to build the linker map file
too, which requires ctags during build. This is otherwise flagged as
error by lld linker where we specify a linker symbol file on cmdline
but the file is not there.

Fixes
| libtool:   error: symbol file './libcoap-3.sym' does not exist

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
index 0fc342560a..efea3fab74 100644
--- a/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
+++ b/meta-networking/recipes-devtools/libcoap/libcoap_4.3.1.bb
@@ -16,6 +16,8 @@  S = "${WORKDIR}/git"
 
 inherit autotools manpages pkgconfig ptest
 
+DEPENDS += "ctags-native"
+
 PACKAGECONFIG ?= "\
     async openssl tcp \
     ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
@@ -42,6 +44,10 @@  python () {
 
 export SGML_CATALOG_FILES="file://${STAGING_ETCDIR_NATIVE}/xml/catalog"
 
+do_compile:prepend() {
+    oe_runmake update-map-file
+}
+
 do_install_ptest () {
 	install -d ${D}${PTEST_PATH}
 	install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest