diff mbox series

python3-pygments: upgrade to 2.15.1

Message ID 20230704200907.20403-1-sudipm.mukherjee@gmail.com
State New
Headers show
Series python3-pygments: upgrade to 2.15.1 | expand

Commit Message

Sudip Mukherjee July 4, 2023, 8:09 p.m. UTC
Upstream has removed setup.py and started using pyproject.toml

Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
---
 ...ython3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} (76%)

Comments

Tim Orling July 5, 2023, 7:44 a.m. UTC | #1
On Tue, Jul 4, 2023 at 10:09 PM Sudip Mukherjee <sudipm.mukherjee@gmail.com>
wrote:

> Upstream has removed setup.py and started using pyproject.toml
>
> Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
> ---
>  ...ython3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>  rename meta/recipes-devtools/python/{python3-pygments_2.14.0.bb =>
> python3-pygments_2.15.1.bb} (76%)
>
> diff --git a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> similarity index 76%
> rename from meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> rename to meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> index 16769e9263..7e3b286f41 100644
> --- a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> +++ b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> @@ -5,7 +5,7 @@ LICENSE = "BSD-2-Clause"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592"
>
>  inherit setuptools3


 instead of setuptools3, inherit python_setuptools_build_meta
Look at the build.backend variable in pyproject.toml for hints
https://github.com/pygments/pygments/blob/master/pyproject.toml#L4

>
> -SRC_URI[sha256sum] =
> "b3ed06a9e8ac9a9aae5a6f5dbe78a8a58655d17b43b93c078f094ddc476ae297"
> +SRC_URI[sha256sum] =
> "8ace4d3c1dd481894b2005f560ead0f9f19ee64fe983366be1a21e171d12775c"
>
>  DEPENDS += "\
>              ${PYTHON_PN} \
> @@ -15,5 +15,9 @@ PYPI_PACKAGE = "Pygments"
>
>  inherit pypi
>
> +do_compile () {
> +    python_pep517_do_compile
> +}
> +

inheriting the proper class will do this

>
>  BBCLASSEXTEND = "native nativesdk"
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183871):
> https://lists.openembedded.org/g/openembedded-core/message/183871
> Mute This Topic: https://lists.openembedded.org/mt/99953624/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Sudip Mukherjee July 5, 2023, 9:23 a.m. UTC | #2
On Wed, 5 Jul 2023 at 08:45, Tim Orling <ticotimo@gmail.com> wrote:
>
>
>
> On Tue, Jul 4, 2023 at 10:09 PM Sudip Mukherjee <sudipm.mukherjee@gmail.com> wrote:
>>
>> Upstream has removed setup.py and started using pyproject.toml
>>
>> Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
>> ---
>>  ...ython3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} | 6 +++++-
>>  1 file changed, 5 insertions(+), 1 deletion(-)
>>  rename meta/recipes-devtools/python/{python3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} (76%)
>>
>> diff --git a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
>> similarity index 76%
>> rename from meta/recipes-devtools/python/python3-pygments_2.14.0.bb
>> rename to meta/recipes-devtools/python/python3-pygments_2.15.1.bb
>> index 16769e9263..7e3b286f41 100644
>> --- a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
>> +++ b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
>> @@ -5,7 +5,7 @@ LICENSE = "BSD-2-Clause"
>>  LIC_FILES_CHKSUM = "file://LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592"
>>
>>  inherit setuptools3
>
>
>  instead of setuptools3, inherit python_setuptools_build_meta
> Look at the build.backend variable in pyproject.toml for hints
> https://github.com/pygments/pygments/blob/master/pyproject.toml#L4

Thanks Tim. I was going through all the python*.bbclass to find a
suitable one but obviously I missed it.
Will update, test and send a v2.
Sudip Mukherjee July 5, 2023, 9:44 a.m. UTC | #3
On Wed, 5 Jul 2023 at 10:23, Sudip Mukherjee via
lists.openembedded.org
<sudipm.mukherjee=gmail.com@lists.openembedded.org> wrote:
>
> On Wed, 5 Jul 2023 at 08:45, Tim Orling <ticotimo@gmail.com> wrote:
> >
> >
> >
> > On Tue, Jul 4, 2023 at 10:09 PM Sudip Mukherjee <sudipm.mukherjee@gmail.com> wrote:
> >>
> >> Upstream has removed setup.py and started using pyproject.toml
> >>
> >> Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
> >> ---
> >>  ...ython3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} | 6 +++++-
> >>  1 file changed, 5 insertions(+), 1 deletion(-)
> >>  rename meta/recipes-devtools/python/{python3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} (76%)
> >>
> >> diff --git a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> >> similarity index 76%
> >> rename from meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> >> rename to meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> >> index 16769e9263..7e3b286f41 100644
> >> --- a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> >> +++ b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> >> @@ -5,7 +5,7 @@ LICENSE = "BSD-2-Clause"
> >>  LIC_FILES_CHKSUM = "file://LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592"
> >>
> >>  inherit setuptools3
> >
> >
> >  instead of setuptools3, inherit python_setuptools_build_meta
> > Look at the build.backend variable in pyproject.toml for hints
> > https://github.com/pygments/pygments/blob/master/pyproject.toml#L4
>
> Thanks Tim. I was going through all the python*.bbclass to find a
> suitable one but obviously I missed it.
> Will update, test and send a v2.

nm, I can see you have already sent a patch for this.
Tim Orling July 5, 2023, 10 a.m. UTC | #4
On Wed, Jul 5, 2023 at 11:45 AM Sudip Mukherjee <sudipm.mukherjee@gmail.com>
wrote:

> On Wed, 5 Jul 2023 at 10:23, Sudip Mukherjee via
> lists.openembedded.org
> <sudipm.mukherjee=gmail.com@lists.openembedded.org> wrote:
> >
> > On Wed, 5 Jul 2023 at 08:45, Tim Orling <ticotimo@gmail.com> wrote:
> > >
> > >
> > >
> > > On Tue, Jul 4, 2023 at 10:09 PM Sudip Mukherjee <
> sudipm.mukherjee@gmail.com> wrote:
> > >>
> > >> Upstream has removed setup.py and started using pyproject.toml
> > >>
> > >> Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
> > >> ---
> > >>  ...ython3-pygments_2.14.0.bb => python3-pygments_2.15.1.bb} | 6
> +++++-
> > >>  1 file changed, 5 insertions(+), 1 deletion(-)
> > >>  rename meta/recipes-devtools/python/{python3-pygments_2.14.0.bb =>
> python3-pygments_2.15.1.bb} (76%)
> > >>
> > >> diff --git a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> > >> similarity index 76%
> > >> rename from meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> > >> rename to meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> > >> index 16769e9263..7e3b286f41 100644
> > >> --- a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
> > >> +++ b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
> > >> @@ -5,7 +5,7 @@ LICENSE = "BSD-2-Clause"
> > >>  LIC_FILES_CHKSUM =
> "file://LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592"
> > >>
> > >>  inherit setuptools3
> > >
> > >
> > >  instead of setuptools3, inherit python_setuptools_build_meta
> > > Look at the build.backend variable in pyproject.toml for hints
> > > https://github.com/pygments/pygments/blob/master/pyproject.toml#L4
> >
> > Thanks Tim. I was going through all the python*.bbclass to find a
> > suitable one but obviously I missed it.
> > Will update, test and send a v2.
>
> nm, I can see you have already sent a patch for this.
>
> I decided to maintain it. Thank you for your contribution and bringing it
to my attention.


> --
> Regards
> Sudip
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
similarity index 76%
rename from meta/recipes-devtools/python/python3-pygments_2.14.0.bb
rename to meta/recipes-devtools/python/python3-pygments_2.15.1.bb
index 16769e9263..7e3b286f41 100644
--- a/meta/recipes-devtools/python/python3-pygments_2.14.0.bb
+++ b/meta/recipes-devtools/python/python3-pygments_2.15.1.bb
@@ -5,7 +5,7 @@  LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592"
 
 inherit setuptools3
-SRC_URI[sha256sum] = "b3ed06a9e8ac9a9aae5a6f5dbe78a8a58655d17b43b93c078f094ddc476ae297"
+SRC_URI[sha256sum] = "8ace4d3c1dd481894b2005f560ead0f9f19ee64fe983366be1a21e171d12775c"
 
 DEPENDS += "\
             ${PYTHON_PN} \
@@ -15,5 +15,9 @@  PYPI_PACKAGE = "Pygments"
 
 inherit pypi
 
+do_compile () {
+    python_pep517_do_compile
+}
+
 BBCLASSEXTEND = "native nativesdk"