diff mbox series

perf: fix buildpaths QA warning in 6.4+

Message ID 20230704170546.1016441-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit b9f1d1ec162531e0ce59ea829ae570ca907b3448
Headers show
Series perf: fix buildpaths QA warning in 6.4+ | expand

Commit Message

Bruce Ashfield July 4, 2023, 5:05 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

kernel version 6.4 introduces a new file that need to have
absolute paths removed, so we can avoid the buildpaths QA
warning and have relocatable packages.

We add pmu-flex.h to the processing, and the issue is resolved.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/perf/perf.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 2d803381bb..7d90ac3612 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -383,7 +383,7 @@  PACKAGESPLITFUNCS =+ "perf_fix_sources"
 
 perf_fix_sources () {
 	for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
-			util/expr-flex.h util/expr-flex.c; do
+			util/pmu-flex.h util/expr-flex.h util/expr-flex.c; do
 		f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
 		if [ -e $f ]; then
 			sed -i -e 's#${S}/##g' $f