diff mbox series

gn: Disable warning as error but not disable completely

Message ID 20230703043511.123460-1-raj.khem@gmail.com
State New
Headers show
Series gn: Disable warning as error but not disable completely | expand

Commit Message

Khem Raj July 3, 2023, 4:35 a.m. UTC
This will still emit the diagnostic but it wont break the build,
additionally pass it to CXXFLAGS since thats the right subset to
disable it for.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-arm/recipes-devtools/gn/gn_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jon Mason July 3, 2023, 10:23 p.m. UTC | #1
On Sun, 2 Jul 2023 21:35:11 -0700, Khem Raj wrote:
> This will still emit the diagnostic but it wont break the build,
> additionally pass it to CXXFLAGS since thats the right subset to
> disable it for.

Applied, thanks!

[1/1] gn: Disable warning as error but not disable completely
      commit: fa02cad2dae68e07e4c62a2df0ac5e247207e9ca

Best regards,
diff mbox series

Patch

diff --git a/meta-arm/recipes-devtools/gn/gn_git.bb b/meta-arm/recipes-devtools/gn/gn_git.bb
index 3713787a..4b021bbe 100644
--- a/meta-arm/recipes-devtools/gn/gn_git.bb
+++ b/meta-arm/recipes-devtools/gn/gn_git.bb
@@ -16,7 +16,7 @@  B = "${WORKDIR}/build"
 # ../git/src/gn/desc_builder.cc: In member function 'base::Value {anonymous}::BaseDescBuilder::ToBaseValue(const Scope*)':
 # ../git/src/gn/desc_builder.cc:179:21: error: redundant move in return statement [-Werror=redundant-move]
 #   179 |     return std::move(res);
-CFLAGS:append = " -Wno-redundant-move"
+CXXFLAGS += "-Wno-error=redundant-move"
 
 # Map from our _OS strings to the GN's platform values.
 def gn_platform(variable, d):