diff mbox series

[PATCHv2] cpio: respect MLPREFIX for PACKAGE_WRITE_DEPS

Message ID 20230701235605.2623625-1-Martin.Jansa@gmail.com
State Accepted, archived
Commit c74697e194fe07cb4a2fee45142ae626996fd294
Headers show
Series [PATCHv2] cpio: respect MLPREFIX for PACKAGE_WRITE_DEPS | expand

Commit Message

Martin Jansa July 1, 2023, 11:56 p.m. UTC
* unlike DEPENDS/RDEPENDS the PACKAGE_WRITE_DEPS dependency isn't automatically
  extended with MLPREFIX, causing lib32-cpio to depend on 64bit ptest-runner (and
  all its deps)

* append it only for class-target to avoid nativesdk-cpio depending
  on target ptest-runner (before this patch) and depending on non-existent
  nativesdk-ptest-runner with this patch (as nativesdk.bbclass sets MLPREFIX to
  "nativesdk-")

  stdio: WARNING: Nothing PROVIDES 'nativesdk-ptest-runner'. Close matches:
  stdio: WARNING: Nothing RPROVIDES 'nativesdk-cpio' (but virtual:nativesdk:/home/pokybuild/yocto-worker/a-full/build/meta/recipes-extended/cpio/cpio_2.14.bb RDEPENDS on or otherwise requires it)
  stdio: WARNING: Nothing RPROVIDES 'nativesdk-cpio-dev' (but virtual:nativesdk:/home/pokybuild/yocto-worker/a-full/build/meta/recipes-extended/cpio/cpio_2.14.bb RDEPENDS on or otherwise requires it)

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta/recipes-extended/cpio/cpio_2.14.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/cpio/cpio_2.14.bb b/meta/recipes-extended/cpio/cpio_2.14.bb
index e55fb70cb1..45eb9de8e0 100644
--- a/meta/recipes-extended/cpio/cpio_2.14.bb
+++ b/meta/recipes-extended/cpio/cpio_2.14.bb
@@ -66,7 +66,7 @@  do_install_ptest_base:append() {
 
 # The tests need to run as a non-root user, so pull in the ptest user
 DEPENDS:append:class-target = "${@bb.utils.contains('PTEST_ENABLED', '1', ' ptest-runner', '', d)}"
-PACKAGE_WRITE_DEPS += "ptest-runner"
+PACKAGE_WRITE_DEPS:append:class-target = " ${MLPREFIX}ptest-runner"
 
 RDEPENDS:${PN}-ptest += "ptest-runner"