diff mbox series

[meta-security] qemu: move qemu setting to image and out of layer.conf

Message ID 20230628192752.3209428-1-akuster808@gmail.com
State New
Headers show
Series [meta-security] qemu: move qemu setting to image and out of layer.conf | expand

Commit Message

akuster808 June 28, 2023, 7:27 p.m. UTC
I suspect its better form to have these in the image definition.

Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 conf/layer.conf                             | 2 --
 recipes-core/images/security-build-image.bb | 5 +++++
 2 files changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/conf/layer.conf b/conf/layer.conf
index 334a945..05f678a 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -26,6 +26,4 @@  BBFILES_DYNAMIC += " \
 # Setting SKIP_META_SECURITY_SANITY_CHECK to "1" would skip the bbappend files check.
 INHERIT += "sanity-meta-security"
 
-QB_KERNEL_CMDLINE_APPEND = " ${@bb.utils.contains('DISTRO_FEATURES', 'apparmor', 'apparmor=1 security=apparmor', '', d)}"
-
 addpylib ${LAYERDIR}/lib oeqa
diff --git a/recipes-core/images/security-build-image.bb b/recipes-core/images/security-build-image.bb
index 411cd20..9c82049 100644
--- a/recipes-core/images/security-build-image.bb
+++ b/recipes-core/images/security-build-image.bb
@@ -18,3 +18,8 @@  inherit core-image
 export IMAGE_BASENAME = "security-build-image"
 
 IMAGE_ROOTFS_EXTRA_SPACE = "5242880"
+
+QB_KERNEL_CMDLINE_APPEND = " ${@bb.utils.contains('DISTRO_FEATURES', 'apparmor', 'apparmor=1 security=apparmor', '', d)}"
+
+# We need more mem to run many apps in this layer
+QB_MEM = "-m 2048"