diff mbox series

[master/kirkstone,v4,2/8] meta-arago-extras: sysrepo: Add libssh recipe needed for sysrepo

Message ID 20230627144249.30543-3-r-gunasekaran@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Add meta-sysrepo recipes | expand

Commit Message

Ravi Gunasekaran June 27, 2023, 2:42 p.m. UTC
libnetconf2 is needed to build sysrepo. And libnetconf2 depends on
libssh. So add receipe for libssh.

The recipe is taken as-is from the commit 09f73e7 ("update for honister")
from the public repo [1].

[1] - https://github.com/sartura/meta-sysrepo

Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
---

Changes since v3:
----------------
No change

Changes since v2:
---------------
Newly introduced in this series

 .../recipes-sysrepo/libssh/libssh_0.9.5.bb    | 35 +++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb

Comments

Andrew Davis June 27, 2023, 2:56 p.m. UTC | #1
On 6/27/23 9:42 AM, Ravi Gunasekaran wrote:
> libnetconf2 is needed to build sysrepo. And libnetconf2 depends on
> libssh. So add receipe for libssh.
> 

What is wrong with the version of libssh already in meta-oe?

Andrew

> The recipe is taken as-is from the commit 09f73e7 ("update for honister")
> from the public repo [1].
> 
> [1] - https://github.com/sartura/meta-sysrepo
> 
> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> ---
> 
> Changes since v3:
> ----------------
> No change
> 
> Changes since v2:
> ---------------
> Newly introduced in this series
> 
>   .../recipes-sysrepo/libssh/libssh_0.9.5.bb    | 35 +++++++++++++++++++
>   1 file changed, 35 insertions(+)
>   create mode 100644 meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> 
> diff --git a/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> new file mode 100644
> index 00000000..43a6827e
> --- /dev/null
> +++ b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> @@ -0,0 +1,35 @@
> +SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
> +HOMEPAGE = "http://www.libssh.org"
> +SECTION = "libs"
> +LICENSE = "LGPLv2.1"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
> +
> +DEPENDS = "zlib openssl"
> +
> +SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.9"
> +SRCREV = "0cceefd49d4d397eb21bd36e314ac87739da51ff"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit cmake
> +
> +PACKAGECONFIG ??=""
> +PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
> +
> +ARM_INSTRUCTION_SET:armv5 = "arm"
> +
> +EXTRA_OECMAKE = " \
> +    -DWITH_GCRYPT=0 \
> +    -DWITH_PCAP=1 \
> +    -DWITH_SFTP=1 \
> +    -DWITH_ZLIB=1 \
> +    -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
> +    "
> +
> +do_configure:prepend () {
> +    # Disable building of examples
> +    sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
> +        || bbfatal "Failed to disable examples"
> +}
> +
> +TOOLCHAIN = "gcc"
Ravi Gunasekaran June 28, 2023, 4:17 a.m. UTC | #2
On 6/27/23 8:26 PM, Andrew Davis wrote:
> On 6/27/23 9:42 AM, Ravi Gunasekaran wrote:
>> libnetconf2 is needed to build sysrepo. And libnetconf2 depends on
>> libssh. So add receipe for libssh.
>>
> 
> What is wrong with the version of libssh already in meta-oe?

The recommended version of libssh for libnetconf2 is 0.9. [1]
While the version of libssh in meta-oe is 0.8

[1] - https://github.com/CESNET/libnetconf2

> 
> Andrew
> 
>> The recipe is taken as-is from the commit 09f73e7 ("update for honister")
>> from the public repo [1].
>>
>> [1] - https://github.com/sartura/meta-sysrepo
>>
>> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
>> ---
>>
>> Changes since v3:
>> ----------------
>> No change
>>
>> Changes since v2:
>> ---------------
>> Newly introduced in this series
>>
>>   .../recipes-sysrepo/libssh/libssh_0.9.5.bb    | 35 +++++++++++++++++++
>>   1 file changed, 35 insertions(+)
>>   create mode 100644 meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
>>
>> diff --git a/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
>> new file mode 100644
>> index 00000000..43a6827e
>> --- /dev/null
>> +++ b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
>> @@ -0,0 +1,35 @@
>> +SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
>> +HOMEPAGE = "http://www.libssh.org"
>> +SECTION = "libs"
>> +LICENSE = "LGPLv2.1"
>> +LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
>> +
>> +DEPENDS = "zlib openssl"
>> +
>> +SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.9"
>> +SRCREV = "0cceefd49d4d397eb21bd36e314ac87739da51ff"
>> +
>> +S = "${WORKDIR}/git"
>> +
>> +inherit cmake
>> +
>> +PACKAGECONFIG ??=""
>> +PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
>> +
>> +ARM_INSTRUCTION_SET:armv5 = "arm"
>> +
>> +EXTRA_OECMAKE = " \
>> +    -DWITH_GCRYPT=0 \
>> +    -DWITH_PCAP=1 \
>> +    -DWITH_SFTP=1 \
>> +    -DWITH_ZLIB=1 \
>> +    -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
>> +    "
>> +
>> +do_configure:prepend () {
>> +    # Disable building of examples
>> +    sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
>> +        || bbfatal "Failed to disable examples"
>> +}
>> +
>> +TOOLCHAIN = "gcc"
Denys Dmytriyenko June 28, 2023, 5:57 p.m. UTC | #3
On Wed, Jun 28, 2023 at 09:47:36AM +0530, Ravi Gunasekaran wrote:
> 
> 
> On 6/27/23 8:26 PM, Andrew Davis wrote:
> > On 6/27/23 9:42 AM, Ravi Gunasekaran wrote:
> >> libnetconf2 is needed to build sysrepo. And libnetconf2 depends on
> >> libssh. So add receipe for libssh.
> >>
> > 
> > What is wrong with the version of libssh already in meta-oe?
> 
> The recommended version of libssh for libnetconf2 is 0.9. [1]
> While the version of libssh in meta-oe is 0.8
> 
> [1] - https://github.com/CESNET/libnetconf2

Kirkstone or master?



> >> The recipe is taken as-is from the commit 09f73e7 ("update for honister")
> >> from the public repo [1].
> >>
> >> [1] - https://github.com/sartura/meta-sysrepo
> >>
> >> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> >> ---
> >>
> >> Changes since v3:
> >> ----------------
> >> No change
> >>
> >> Changes since v2:
> >> ---------------
> >> Newly introduced in this series
> >>
> >>   .../recipes-sysrepo/libssh/libssh_0.9.5.bb    | 35 +++++++++++++++++++
> >>   1 file changed, 35 insertions(+)
> >>   create mode 100644 meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> >>
> >> diff --git a/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> >> new file mode 100644
> >> index 00000000..43a6827e
> >> --- /dev/null
> >> +++ b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
> >> @@ -0,0 +1,35 @@
> >> +SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
> >> +HOMEPAGE = "http://www.libssh.org"
> >> +SECTION = "libs"
> >> +LICENSE = "LGPLv2.1"
> >> +LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
> >> +
> >> +DEPENDS = "zlib openssl"
> >> +
> >> +SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.9"
> >> +SRCREV = "0cceefd49d4d397eb21bd36e314ac87739da51ff"
> >> +
> >> +S = "${WORKDIR}/git"
> >> +
> >> +inherit cmake
> >> +
> >> +PACKAGECONFIG ??=""
> >> +PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
> >> +
> >> +ARM_INSTRUCTION_SET:armv5 = "arm"
> >> +
> >> +EXTRA_OECMAKE = " \
> >> +    -DWITH_GCRYPT=0 \
> >> +    -DWITH_PCAP=1 \
> >> +    -DWITH_SFTP=1 \
> >> +    -DWITH_ZLIB=1 \
> >> +    -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
> >> +    "
> >> +
> >> +do_configure:prepend () {
> >> +    # Disable building of examples
> >> +    sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
> >> +        || bbfatal "Failed to disable examples"
> >> +}
> >> +
> >> +TOOLCHAIN = "gcc"
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
new file mode 100644
index 00000000..43a6827e
--- /dev/null
+++ b/meta-arago-extras/recipes-sysrepo/libssh/libssh_0.9.5.bb
@@ -0,0 +1,35 @@ 
+SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
+HOMEPAGE = "http://www.libssh.org"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
+
+DEPENDS = "zlib openssl"
+
+SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.9"
+SRCREV = "0cceefd49d4d397eb21bd36e314ac87739da51ff"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??=""
+PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+
+ARM_INSTRUCTION_SET:armv5 = "arm"
+
+EXTRA_OECMAKE = " \
+    -DWITH_GCRYPT=0 \
+    -DWITH_PCAP=1 \
+    -DWITH_SFTP=1 \
+    -DWITH_ZLIB=1 \
+    -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
+    "
+
+do_configure:prepend () {
+    # Disable building of examples
+    sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
+        || bbfatal "Failed to disable examples"
+}
+
+TOOLCHAIN = "gcc"