diff mbox series

[master/kirkstone,v4,1/8] meta-arago-extras: sysrepo: Update checksum for nw-configurator

Message ID 20230627144249.30543-2-r-gunasekaran@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Add meta-sysrepo recipes | expand

Commit Message

Ravi Gunasekaran June 27, 2023, 2:42 p.m. UTC
Instead of using the source file to compute the license checksum,
use the license text only from source file.

Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
---

Changes since v3:
----------------
No change

Changes since v2:
----------------
1) Corrected the license type
2) License checksum calculated based on the license header instead of the 
entire source file

Changes since v1:
---------------
No change

 .../recipes-sysrepo/nw-configurator/nw-configurator.bb       | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Denys Dmytriyenko June 28, 2023, 5:07 p.m. UTC | #1
On Tue, Jun 27, 2023 at 08:12:42PM +0530, Ravi Gunasekaran wrote:
> Instead of using the source file to compute the license checksum,
> use the license text only from source file.
> 
> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> ---
> 
> Changes since v3:
> ----------------
> No change
> 
> Changes since v2:
> ----------------
> 1) Corrected the license type
> 2) License checksum calculated based on the license header instead of the 
> entire source file
> 
> Changes since v1:
> ---------------
> No change
> 
>  .../recipes-sysrepo/nw-configurator/nw-configurator.bb       | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
> index 5a152017..c5d9a86b 100644
> --- a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
> +++ b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
> @@ -1,6 +1,7 @@
> -LICENSE="GPLv2"
>  DESCRIPTION = "Sysrepo based repo to configure EST"
> -LIC_FILES_CHKSUM = "file://nw-configurator.c;md5=a818a6cf4fbeeb21acc8b4e9956c08a4"
> +
> +LICENSE = "BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://nw-configurator.c;beginline=1;endline=33;md5=3538caaf9bfb8372347877ad393660fa"

Thanks, this is a move in the right direction!

However, you also changed the LICENSE identifier w/o explaining the reason in 
the commit message! This is rather critical... I checked the nw-configurator.c 
and indeed GPLv2 was totally wrong, but you have to explain the change anyway. 
Going forward there will be a new requirement for Yocto compliance to properly 
explain license changes like that and there's a new field "License-Update:"
https://www.openembedded.org/wiki/Commit_Patch_Message_Guidelines#Describing_license_changes


>  SRC_URI = "file://nw-configurator.c"
Ravi Gunasekaran June 29, 2023, 4:09 a.m. UTC | #2
On 6/28/23 10:37 PM, Denys Dmytriyenko wrote:
> On Tue, Jun 27, 2023 at 08:12:42PM +0530, Ravi Gunasekaran wrote:
>> Instead of using the source file to compute the license checksum,
>> use the license text only from source file.
>>
>> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
>> ---
>>
>> Changes since v3:
>> ----------------
>> No change
>>
>> Changes since v2:
>> ----------------
>> 1) Corrected the license type
>> 2) License checksum calculated based on the license header instead of the 
>> entire source file
>>
>> Changes since v1:
>> ---------------
>> No change
>>
>>  .../recipes-sysrepo/nw-configurator/nw-configurator.bb       | 5 +++--
>>  1 file changed, 3 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
>> index 5a152017..c5d9a86b 100644
>> --- a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
>> +++ b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
>> @@ -1,6 +1,7 @@
>> -LICENSE="GPLv2"
>>  DESCRIPTION = "Sysrepo based repo to configure EST"
>> -LIC_FILES_CHKSUM = "file://nw-configurator.c;md5=a818a6cf4fbeeb21acc8b4e9956c08a4"
>> +
>> +LICENSE = "BSD-3-Clause"
>> +LIC_FILES_CHKSUM = "file://nw-configurator.c;beginline=1;endline=33;md5=3538caaf9bfb8372347877ad393660fa"
> 
> Thanks, this is a move in the right direction!
> 
> However, you also changed the LICENSE identifier w/o explaining the reason in 
> the commit message! This is rather critical... I checked the nw-configurator.c 
> and indeed GPLv2 was totally wrong, but you have to explain the change anyway. 
> Going forward there will be a new requirement for Yocto compliance to properly 
> explain license changes like that and there's a new field "License-Update:"
> https://www.openembedded.org/wiki/Commit_Patch_Message_Guidelines#Describing_license_changes
> 

Noted. In future, I will add such reasoning in the commit message itself.

> 
>>  SRC_URI = "file://nw-configurator.c"
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
index 5a152017..c5d9a86b 100644
--- a/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
+++ b/meta-arago-extras/recipes-sysrepo/nw-configurator/nw-configurator.bb
@@ -1,6 +1,7 @@ 
-LICENSE="GPLv2"
 DESCRIPTION = "Sysrepo based repo to configure EST"
-LIC_FILES_CHKSUM = "file://nw-configurator.c;md5=a818a6cf4fbeeb21acc8b4e9956c08a4"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://nw-configurator.c;beginline=1;endline=33;md5=3538caaf9bfb8372347877ad393660fa"
 
 SRC_URI = "file://nw-configurator.c"