[v2,7/7] systemd: add nativesdk

Message ID 20211119113429.502652-7-luca.boccassi@gmail.com
State New
Headers show
Series [v2,1/7] systemd: skip chown when building for nativesdk | expand

Commit Message

Luca Boccassi Nov. 19, 2021, 11:34 a.m. UTC
From: Luca Boccassi <luca.boccassi@microsoft.com>

Allows using tools like systemd-analyze at build time and in
CI systems

Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
---
 meta/recipes-core/systemd/systemd-conf_1.0.bb    | 2 ++
 meta/recipes-core/systemd/systemd-serialgetty.bb | 2 ++
 meta/recipes-core/systemd/systemd_249.5.bb       | 2 ++
 3 files changed, 6 insertions(+)

Comments

Alexander Kanavin Nov. 19, 2021, 11:39 a.m. UTC | #1
Once again, I do not want this accepted in oe-core, not until there's
equivalent native functionality.

Alex

On Fri, 19 Nov 2021 at 12:35, Luca Bocassi <luca.boccassi@gmail.com> wrote:

> From: Luca Boccassi <luca.boccassi@microsoft.com>
>
> Allows using tools like systemd-analyze at build time and in
> CI systems
>
> Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
> ---
>  meta/recipes-core/systemd/systemd-conf_1.0.bb    | 2 ++
>  meta/recipes-core/systemd/systemd-serialgetty.bb | 2 ++
>  meta/recipes-core/systemd/systemd_249.5.bb       | 2 ++
>  3 files changed, 6 insertions(+)
>
> diff --git a/meta/recipes-core/systemd/systemd-conf_1.0.bb
> b/meta/recipes-core/systemd/systemd-conf_1.0.bb
> index 61ce7939d3..84de4d17cf 100644
> --- a/meta/recipes-core/systemd/systemd-conf_1.0.bb
> +++ b/meta/recipes-core/systemd/systemd-conf_1.0.bb
> @@ -41,3 +41,5 @@ FILES:${PN} = "\
>      ${systemd_unitdir}/system.conf.d/ \
>      ${systemd_unitdir}/network/ \
>  "
> +
> +BBCLASSEXTEND = "nativesdk"
> diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb
> b/meta/recipes-core/systemd/systemd-serialgetty.bb
> index 7ca951cdbd..f877e6ad18 100644
> --- a/meta/recipes-core/systemd/systemd-serialgetty.bb
> +++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
> @@ -50,3 +50,5 @@ FILES:${PN} = "${systemd_system_unitdir}/*.service
> ${sysconfdir}"
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>
>  ALLOW_EMPTY:${PN} = "1"
> +
> +BBCLASSEXTEND = "nativesdk"
> diff --git a/meta/recipes-core/systemd/systemd_249.5.bb
> b/meta/recipes-core/systemd/systemd_249.5.bb
> index 2928a85c93..445a50b1e3 100644
> --- a/meta/recipes-core/systemd/systemd_249.5.bb
> +++ b/meta/recipes-core/systemd/systemd_249.5.bb
> @@ -773,6 +773,8 @@ ALTERNATIVE_TARGET[runlevel] =
> "${base_bindir}/systemctl"
>  ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
>  ALTERNATIVE_PRIORITY[runlevel] ?= "300"
>
> +BBCLASSEXTEND = "nativesdk"
> +
>  # Nothing picks up /var in the nativesdk case
>  do_install_append_class-nativesdk () {
>         rm -rf ${D}/var
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#158513):
> https://lists.openembedded.org/g/openembedded-core/message/158513
> Mute This Topic: https://lists.openembedded.org/mt/87165499/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Luca Boccassi Nov. 19, 2021, 11:55 a.m. UTC | #2
On Fri, 2021-11-19 at 12:39 +0100, Alexander Kanavin wrote:
> Once again, I do not want this accepted in oe-core, not until there's
> equivalent native functionality.
> 
> Alex

As already mentioned, that's completely unrelated, and I do not have
the time nor the interest to invest weeks of my time working on that.
But arbitrarily rejecting patches is your prerogative of course, so
I'll just keep these changes out-of-tree then.

> On Fri, 19 Nov 2021 at 12:35, Luca Bocassi <luca.boccassi@gmail.com>
> wrote:
> > From: Luca Boccassi <luca.boccassi@microsoft.com>
> > 
> > Allows using tools like systemd-analyze at build time and in
> > CI systems
> > 
> > Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
> > ---
> >  meta/recipes-core/systemd/systemd-conf_1.0.bb    | 2 ++
> >  meta/recipes-core/systemd/systemd-serialgetty.bb | 2 ++
> >  meta/recipes-core/systemd/systemd_249.5.bb       | 2 ++
> >  3 files changed, 6 insertions(+)
> > 
> > diff --git a/meta/recipes-core/systemd/systemd-conf_1.0.bb
> > b/meta/recipes-core/systemd/systemd-conf_1.0.bb
> > index 61ce7939d3..84de4d17cf 100644
> > --- a/meta/recipes-core/systemd/systemd-conf_1.0.bb
> > +++ b/meta/recipes-core/systemd/systemd-conf_1.0.bb
> > @@ -41,3 +41,5 @@ FILES:${PN} = "\
> >      ${systemd_unitdir}/system.conf.d/ \
> >      ${systemd_unitdir}/network/ \
> >  "
> > +
> > +BBCLASSEXTEND = "nativesdk"
> > diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb
> > b/meta/recipes-core/systemd/systemd-serialgetty.bb
> > index 7ca951cdbd..f877e6ad18 100644
> > --- a/meta/recipes-core/systemd/systemd-serialgetty.bb
> > +++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
> > @@ -50,3 +50,5 @@ FILES:${PN} =
> > "${systemd_system_unitdir}/*.service ${sysconfdir}"
> >  PACKAGE_ARCH = "${MACHINE_ARCH}"
> > 
> >  ALLOW_EMPTY:${PN} = "1"
> > +
> > +BBCLASSEXTEND = "nativesdk"
> > diff --git a/meta/recipes-core/systemd/systemd_249.5.bb
> > b/meta/recipes-core/systemd/systemd_249.5.bb
> > index 2928a85c93..445a50b1e3 100644
> > --- a/meta/recipes-core/systemd/systemd_249.5.bb
> > +++ b/meta/recipes-core/systemd/systemd_249.5.bb
> > @@ -773,6 +773,8 @@ ALTERNATIVE_TARGET[runlevel] =
> > "${base_bindir}/systemctl"
> >  ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
> >  ALTERNATIVE_PRIORITY[runlevel] ?= "300"
> > 
> > +BBCLASSEXTEND = "nativesdk"
> > +
> >  # Nothing picks up /var in the nativesdk case
> >  do_install_append_class-nativesdk () {
> >         rm -rf ${D}/var

Patch

diff --git a/meta/recipes-core/systemd/systemd-conf_1.0.bb b/meta/recipes-core/systemd/systemd-conf_1.0.bb
index 61ce7939d3..84de4d17cf 100644
--- a/meta/recipes-core/systemd/systemd-conf_1.0.bb
+++ b/meta/recipes-core/systemd/systemd-conf_1.0.bb
@@ -41,3 +41,5 @@  FILES:${PN} = "\
     ${systemd_unitdir}/system.conf.d/ \
     ${systemd_unitdir}/network/ \
 "
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 7ca951cdbd..f877e6ad18 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -50,3 +50,5 @@  FILES:${PN} = "${systemd_system_unitdir}/*.service ${sysconfdir}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 ALLOW_EMPTY:${PN} = "1"
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/systemd/systemd_249.5.bb b/meta/recipes-core/systemd/systemd_249.5.bb
index 2928a85c93..445a50b1e3 100644
--- a/meta/recipes-core/systemd/systemd_249.5.bb
+++ b/meta/recipes-core/systemd/systemd_249.5.bb
@@ -773,6 +773,8 @@  ALTERNATIVE_TARGET[runlevel] = "${base_bindir}/systemctl"
 ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
 ALTERNATIVE_PRIORITY[runlevel] ?= "300"
 
+BBCLASSEXTEND = "nativesdk"
+
 # Nothing picks up /var in the nativesdk case
 do_install_append_class-nativesdk () {
 	rm -rf ${D}/var