diff mbox series

[meta-ti,kirkstone] linux-ti-staging: add configuration for remoteproc/rpmsg IPC modules

Message ID 20230623075732.4119753-1-u-kumar1@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,kirkstone] linux-ti-staging: add configuration for remoteproc/rpmsg IPC modules | expand

Commit Message

Kumar, Udit June 23, 2023, 7:57 a.m. UTC
* rpmsg_client_sample is a test module and should not be autoloaded
* Both k3_r5 and k3_dsp remoteproc modules depend on virtio_rpmsg_bus

Cc: Denys Dmytriyenko <denys@ti.com>
Cc: Ryan Eatmon <reatmon@ti.com>
Cc: Praneeth Bajjuri <praneeth@ti.com>
Cc: Apurva Nandan <a-nandan@ti.com>
Cc: Hari Nagalla <hnagalla@ti.com>
Signed-off-by: Udit Kumar <u-kumar1@ti.com>
---
 meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index 69f82e8c..37296ffc 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -36,3 +36,9 @@  KERNEL_GIT_PROTOCOL = "https"
 SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
             file://defconfig"
 
+# Special configuration for remoteproc/rpmsg IPC modules
+module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
+module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
+module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
+KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
+