diff mbox series

[master/kirkstone,v2,3/3] tisdk-default-image: Add package group for netopeer/sysrepo

Message ID 20230622103445.31114-4-r-gunasekaran@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series Add meta-sysrepo recipes | expand

Commit Message

Ravi Gunasekaran June 22, 2023, 10:34 a.m. UTC
Add new package group for netopeer2, sysrepo, nw-configurator
and yang models.

Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
---
 .../recipes-core/images/tisdk-default-image.bb  |  1 +
 .../packagegroup-arago-tisdk-sysrepo.bb         | 17 +++++++++++++++++
 2 files changed, 18 insertions(+)
 create mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb

Comments

Denys Dmytriyenko June 22, 2023, 3:58 p.m. UTC | #1
On Thu, Jun 22, 2023 at 04:04:45PM +0530, Ravi Gunasekaran wrote:
> Add new package group for netopeer2, sysrepo, nw-configurator
> and yang models.
> 
> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> ---
>  .../recipes-core/images/tisdk-default-image.bb  |  1 +
>  .../packagegroup-arago-tisdk-sysrepo.bb         | 17 +++++++++++++++++
>  2 files changed, 18 insertions(+)
>  create mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
> 
> diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> index bb825e09..7769c97c 100644
> --- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> +++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> @@ -28,6 +28,7 @@ IMAGE_INSTALL += "\
>      ti-analytics \
>      ti-demos \
>      ${ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL} \
> +    packagegroup-arago-tisdk-sysrepo \
>  "
>  
>  export IMAGE_BASENAME = "tisdk-default-image"
> diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
> new file mode 100644
> index 00000000..14608dfe
> --- /dev/null
> +++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Netopeer2 and Sysrepo packagegroup"
> +LICENSE = "MIT"
> +
> +PACKAGE_ARCH = "${MACHINE_ARCH}"

This packagegroup doesn't seem to be machine-specific, so no need for the 
above line.


> +inherit packagegroup
> +
> +ARAGO_NETOPEER_SYSREPO = "\
> +    sysrepo \
> +    netopeer2-server \
> +    nw-configurator \
> +    tsn-yang-models \
> +"
> +
> +RDEPENDS:${PN} = "\
> +    ${ARAGO_NETOPEER_SYSREPO} \
> +"
> -- 
> 2.17.1
Ravi Gunasekaran June 23, 2023, 4:24 a.m. UTC | #2
On 6/22/23 9:28 PM, Denys Dmytriyenko wrote:
> On Thu, Jun 22, 2023 at 04:04:45PM +0530, Ravi Gunasekaran wrote:
>> Add new package group for netopeer2, sysrepo, nw-configurator
>> and yang models.
>>
>> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
>> ---
>>  .../recipes-core/images/tisdk-default-image.bb  |  1 +
>>  .../packagegroup-arago-tisdk-sysrepo.bb         | 17 +++++++++++++++++
>>  2 files changed, 18 insertions(+)
>>  create mode 100644 meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
>>
>> diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> index bb825e09..7769c97c 100644
>> --- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> +++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> @@ -28,6 +28,7 @@ IMAGE_INSTALL += "\
>>      ti-analytics \
>>      ti-demos \
>>      ${ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL} \
>> +    packagegroup-arago-tisdk-sysrepo \
>>  "
>>  
>>  export IMAGE_BASENAME = "tisdk-default-image"
>> diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
>> new file mode 100644
>> index 00000000..14608dfe
>> --- /dev/null
>> +++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
>> @@ -0,0 +1,17 @@
>> +SUMMARY = "Netopeer2 and Sysrepo packagegroup"
>> +LICENSE = "MIT"
>> +
>> +PACKAGE_ARCH = "${MACHINE_ARCH}"
> 
> This packagegroup doesn't seem to be machine-specific, so no need for the 
> above line.

I will remove this in the next series.

> 
> 
>> +inherit packagegroup
>> +
>> +ARAGO_NETOPEER_SYSREPO = "\
>> +    sysrepo \
>> +    netopeer2-server \
>> +    nw-configurator \
>> +    tsn-yang-models \
>> +"
>> +
>> +RDEPENDS:${PN} = "\
>> +    ${ARAGO_NETOPEER_SYSREPO} \
>> +"
>> -- 
>> 2.17.1
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index bb825e09..7769c97c 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -28,6 +28,7 @@  IMAGE_INSTALL += "\
     ti-analytics \
     ti-demos \
     ${ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL} \
+    packagegroup-arago-tisdk-sysrepo \
 "
 
 export IMAGE_BASENAME = "tisdk-default-image"
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
new file mode 100644
index 00000000..14608dfe
--- /dev/null
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-sysrepo.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Netopeer2 and Sysrepo packagegroup"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+ARAGO_NETOPEER_SYSREPO = "\
+    sysrepo \
+    netopeer2-server \
+    nw-configurator \
+    tsn-yang-models \
+"
+
+RDEPENDS:${PN} = "\
+    ${ARAGO_NETOPEER_SYSREPO} \
+"