diff mbox series

[master/kirkstone,3/3] tisdk-default-image: Add packages to support NETCONF/YANG

Message ID 20230621091801.14944-4-r-gunasekaran@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series Add meta-sysrepo recipes | expand

Commit Message

Ravi Gunasekaran June 21, 2023, 9:18 a.m. UTC
Add sysrepo, netopeer2-server, nw-configurator packages

Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
---
 .../recipes-core/images/tisdk-default-image.bb             | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Ryan Eatmon June 21, 2023, 2:17 p.m. UTC | #1
On 6/21/2023 4:18 AM, Ravi Gunasekaran wrote:
> Add sysrepo, netopeer2-server, nw-configurator packages
> 
> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> ---
>   .../recipes-core/images/tisdk-default-image.bb             | 7 ++++++-
>   1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> index bb825e09..8239e0ce 100644
> --- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> +++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> @@ -5,7 +5,12 @@ DESCRIPTION = "Complete Arago TI SDK filesystem image containing complete\
>   
>   require arago-image.inc
>   
> -ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= ""
> +ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= "\
> +    sysrepo \
> +    netopeer2-server \
> +    nw-configurator \
> +    tsn-yang-models \
> +"

NAK.  This variable is there to allow for the user to add packages from 
the local.conf.  Putting anything in there by default creates the risk 
that the users will lose these packages if they set the variable.

If these packages are needed, then they should be included in a 
packagegroup.  Feel free to create a new package group for sysrepo 
support.  (ie. packagegroup-arago-tisdk-sysrepo)


>   IMAGE_INSTALL += "\
>       packagegroup-arago-base \
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index bb825e09..8239e0ce 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -5,7 +5,12 @@  DESCRIPTION = "Complete Arago TI SDK filesystem image containing complete\
 
 require arago-image.inc
 
-ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= ""
+ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= "\
+    sysrepo \
+    netopeer2-server \
+    nw-configurator \
+    tsn-yang-models \
+"
 
 IMAGE_INSTALL += "\
     packagegroup-arago-base \