[v2,4/7] systemd: remove volatile-binds RDEPENDS for nativesdk

Message ID 20211119113429.502652-4-luca.boccassi@gmail.com
State New
Headers show
Series [v2,1/7] systemd: skip chown when building for nativesdk | expand

Commit Message

Luca Boccassi Nov. 19, 2021, 11:34 a.m. UTC
From: Luca Boccassi <luca.boccassi@microsoft.com>

Not needed for SDK binaries

Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
---
v2: remove dependency instead of adding nativesdk to volatile-binds

 meta/recipes-core/systemd/systemd_249.5.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Richard Purdie Nov. 22, 2021, 11:56 a.m. UTC | #1
On Fri, 2021-11-19 at 11:34 +0000, Luca Bocassi wrote:
> From: Luca Boccassi <luca.boccassi@microsoft.com>
> 
> Not needed for SDK binaries
> 
> Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
> ---
> v2: remove dependency instead of adding nativesdk to volatile-binds
> 
>  meta/recipes-core/systemd/systemd_249.5.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-core/systemd/systemd_249.5.bb b/meta/recipes-core/systemd/systemd_249.5.bb
> index 9993036aac..2928a85c93 100644
> --- a/meta/recipes-core/systemd/systemd_249.5.bb
> +++ b/meta/recipes-core/systemd/systemd_249.5.bb
> @@ -644,6 +644,7 @@ FILES:${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ $
>  RDEPENDS:${PN} += "kmod dbus util-linux-mount util-linux-umount udev (= ${EXTENDPKGV}) systemd-udev-rules util-linux-agetty util-linux-fsck"
>  RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-getty-generator', '', 'systemd-serialgetty', d)}"
>  RDEPENDS:${PN} += "volatile-binds"
> +RDEPENDS_${PN}_remove_class-nativesdk = "volatile-binds"
>  
>  RRECOMMENDS:${PN} += "systemd-extra-utils \
>                        udev-hwdb \

This patch raises a few questions like how this is being tested?

The override syntax changed so the avoid would never have worked with master.

Also, I have a strong preference for not using remove operators in OE-Core, you
can usually rearrange things so that it isn't necessary. The reason for that is
that it is very hard to override these operations. I know we do have some but
minimising them is good.

Cheers,

Richard
Luca Boccassi Nov. 22, 2021, 10:51 p.m. UTC | #2
On Mon, 2021-11-22 at 11:56 +0000, Richard Purdie wrote:
> On Fri, 2021-11-19 at 11:34 +0000, Luca Bocassi wrote:
> > From: Luca Boccassi <luca.boccassi@microsoft.com>
> > 
> > Not needed for SDK binaries
> > 
> > Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
> > ---
> > v2: remove dependency instead of adding nativesdk to volatile-binds
> > 
> >  meta/recipes-core/systemd/systemd_249.5.bb | 1 +
> >  1 file changed, 1 insertion(+)
> > 
> > diff --git a/meta/recipes-core/systemd/systemd_249.5.bb
> > b/meta/recipes-core/systemd/systemd_249.5.bb
> > index 9993036aac..2928a85c93 100644
> > --- a/meta/recipes-core/systemd/systemd_249.5.bb
> > +++ b/meta/recipes-core/systemd/systemd_249.5.bb
> > @@ -644,6 +644,7 @@ FILES:${PN}-dev +=
> > "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ $
> >  RDEPENDS:${PN} += "kmod dbus util-linux-mount util-linux-umount
> > udev (= ${EXTENDPKGV}) systemd-udev-rules util-linux-agetty util-
> > linux-fsck"
> >  RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-
> > getty-generator', '', 'systemd-serialgetty', d)}"
> >  RDEPENDS:${PN} += "volatile-binds"
> > +RDEPENDS_${PN}_remove_class-nativesdk = "volatile-binds"
> >  
> >  RRECOMMENDS:${PN} += "systemd-extra-utils \
> >                        udev-hwdb \
> 
> This patch raises a few questions like how this is being tested?
> 
> The override syntax changed so the avoid would never have worked with
> master.
> 
> Also, I have a strong preference for not using remove operators in
> OE-Core, you
> can usually rearrange things so that it isn't necessary. The reason
> for that is
> that it is very hard to override these operations. I know we do have
> some but
> minimising them is good.
> 
> Cheers,
> 
> Richard

It was tested in a downstream dunfell branch, since that's what our
build system supports. I was not aware there had been a backward
incompatible syntax change, thanks for the hint.

Patch

diff --git a/meta/recipes-core/systemd/systemd_249.5.bb b/meta/recipes-core/systemd/systemd_249.5.bb
index 9993036aac..2928a85c93 100644
--- a/meta/recipes-core/systemd/systemd_249.5.bb
+++ b/meta/recipes-core/systemd/systemd_249.5.bb
@@ -644,6 +644,7 @@  FILES:${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ $
 RDEPENDS:${PN} += "kmod dbus util-linux-mount util-linux-umount udev (= ${EXTENDPKGV}) systemd-udev-rules util-linux-agetty util-linux-fsck"
 RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-getty-generator', '', 'systemd-serialgetty', d)}"
 RDEPENDS:${PN} += "volatile-binds"
+RDEPENDS_${PN}_remove_class-nativesdk = "volatile-binds"
 
 RRECOMMENDS:${PN} += "systemd-extra-utils \
                       udev-hwdb \