diff mbox series

[meta-python,RESEND,38/54] python3-can: fix coding style

Message ID 20230619132214.213417-39-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski June 19, 2023, 1:21 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Stop using PYTHON_PN, order RDEPENDS alphabetically, drop unneeded
class-target override, fix whitespaces.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../python/python3-can_4.2.1.bb               | 26 +++++++++----------
 1 file changed, 13 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-can_4.2.1.bb b/meta-python/recipes-devtools/python/python3-can_4.2.1.bb
index d7b2a9573..f5cc31d6f 100644
--- a/meta-python/recipes-devtools/python/python3-can_4.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-can_4.2.1.bb
@@ -9,19 +9,19 @@  PYPI_PACKAGE="python-can"
 
 inherit pypi setuptools3
 
-RDEPENDS:${PN}:class-target += "\
-    ${PYTHON_PN}-aenum \
-    ${PYTHON_PN}-ctypes \
-    ${PYTHON_PN}-codecs \
-    ${PYTHON_PN}-compression \
-    ${PYTHON_PN}-fcntl \
-    ${PYTHON_PN}-logging \
-    ${PYTHON_PN}-misc \
-    ${PYTHON_PN}-netserver \
-    ${PYTHON_PN}-sqlite3 \
-    ${PYTHON_PN}-wrapt \
-    ${PYTHON_PN}-pkg-resources \
-    ${PYTHON_PN}-typing-extensions \
+RDEPENDS:${PN} += " \
+    python3-aenum \
+    python3-codecs \
+    python3-compression \
+    python3-ctypes \
+    python3-fcntl \
+    python3-logging \
+    python3-misc \
+    python3-netserver \
+    python3-pkg-resources \
+    python3-sqlite3 \
+    python3-typing-extensions \
+    python3-wrapt \
 "
 
 BBCLASSEXTEND = "native nativesdk"