diff mbox series

[meta-python] python3-click-repl: upgrade 0.2.0 -> 0.3.0

Message ID 1687157308-17342-5-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-click-repl: upgrade 0.2.0 -> 0.3.0 | expand

Commit Message

Mingyu Wang (Fujitsu) June 19, 2023, 6:48 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
 Add "Copyright (c) 2016-2026 Asif Saif Uddin & contributors." to
license file.

Changelog:
===========
  Drop Python 2 support, remove six.
  Uses PromptSession() class from prompt_toolkit instead of prompt() function (#63).
  Added filter for hidden commands and options (#86).
  Added click's autocompletion support (#88).
  Added tab-completion for Path and BOOL type arguments (#95).
  Added 'expand environmental variables in path' feature (#96).
  Delegate command dispatching to the actual group command.
  Updated completer class and tests based on new fix#92 (#102).
  Python 3.11 support.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ython3-click-repl_0.2.0.bb => python3-click-repl_0.3.0.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-click-repl_0.2.0.bb => python3-click-repl_0.3.0.bb} (55%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-click-repl_0.2.0.bb b/meta-python/recipes-devtools/python/python3-click-repl_0.3.0.bb
similarity index 55%
rename from meta-python/recipes-devtools/python/python3-click-repl_0.2.0.bb
rename to meta-python/recipes-devtools/python/python3-click-repl_0.3.0.bb
index c8798c5e3..33e42cb3b 100644
--- a/meta-python/recipes-devtools/python/python3-click-repl_0.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-click-repl_0.3.0.bb
@@ -1,9 +1,9 @@ 
 SUMMARY = "REPL plugin for Click"
 HOMEPAGE = "https://github.com/untitaker/click-repl"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=fee2943fdd4d8afbac9ccc1c8ac137d5"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=580facc4832cac548fad94845542da44"
 
-SRC_URI[sha256sum] = "cd12f68d745bf6151210790540b4cb064c7b13e571bc64b6957d98d120dacfd8"
+SRC_URI[sha256sum] = "17849c23dba3d667247dc4defe1757fff98694e90fe37474f3feebb69ced26a9"
 
 inherit pypi setuptools3