diff mbox series

ptest-runner: Pull in sync fix to improve log warnings

Message ID 20230618090946.2478083-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit f051de5d5da7e9a2f4137013e24589b594ff6d35
Headers show
Series ptest-runner: Pull in sync fix to improve log warnings | expand

Commit Message

Richard Purdie June 18, 2023, 9:09 a.m. UTC
Pulls in:

    utils: Ensure buffers are flushed after child exits

    We currently wait for the child to exit but we don't flush the buffers.
    This can mean the output ends up out of sync and the END: line isn't at
    the end of the logs.

    We've recently seen a lot of issues related to this on the autobuilder.
    Add in a flush call for all fds to ensure buffers are in sync. This
    does appear to improve warnings on the autobuilder now we started detecting
    the issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexander Kanavin June 28, 2023, 2:24 p.m. UTC | #1
This appears to have regressed glib-2.0 ptest, particularly:
Failed ptests:
{'glib-2.0': ['glib/codegen.py.test']}
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/5273/steps/12/logs/stdio

I didn't yet got to the root cause, just wanted to register where it
happened. Note that the ptest passes when run directly and fails only
under ptest-runner, and it somehow is specific to qemux86_64 as well.
Bizarre, yes.

Alex

On Sun, 18 Jun 2023 at 11:09, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> Pulls in:
>
>     utils: Ensure buffers are flushed after child exits
>
>     We currently wait for the child to exit but we don't flush the buffers.
>     This can mean the output ends up out of sync and the END: line isn't at
>     the end of the logs.
>
>     We've recently seen a lot of issues related to this on the autobuilder.
>     Add in a flush call for all fds to ensure buffers are in sync. This
>     does appear to improve warnings on the autobuilder now we started detecting
>     the issue.
>
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> index ff5629c6f9b..67dd887c240 100644
> --- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> +++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> @@ -7,7 +7,7 @@ HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
>  LICENSE = "GPL-2.0-or-later"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
>
> -SRCREV = "bcb82804daa8f725b6add259dcef2067e61a75aa"
> +SRCREV = "ea2a9cc159ad5f64ee75781d55101d7c340e0303"
>  PV .= "+git${SRCPV}"
>
>  SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183056): https://lists.openembedded.org/g/openembedded-core/message/183056
> Mute This Topic: https://lists.openembedded.org/mt/99601743/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin June 28, 2023, 2:26 p.m. UTC | #2
There's an open issue for it as well:
https://bugzilla.yoctoproject.org/show_bug.cgi?id=15154

Alex

On Wed, 28 Jun 2023 at 16:24, Alexander Kanavin via
lists.openembedded.org <alex.kanavin=gmail.com@lists.openembedded.org>
wrote:
>
> This appears to have regressed glib-2.0 ptest, particularly:
> Failed ptests:
> {'glib-2.0': ['glib/codegen.py.test']}
> https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/5273/steps/12/logs/stdio
>
> I didn't yet got to the root cause, just wanted to register where it
> happened. Note that the ptest passes when run directly and fails only
> under ptest-runner, and it somehow is specific to qemux86_64 as well.
> Bizarre, yes.
>
> Alex
>
> On Sun, 18 Jun 2023 at 11:09, Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
> >
> > Pulls in:
> >
> >     utils: Ensure buffers are flushed after child exits
> >
> >     We currently wait for the child to exit but we don't flush the buffers.
> >     This can mean the output ends up out of sync and the END: line isn't at
> >     the end of the logs.
> >
> >     We've recently seen a lot of issues related to this on the autobuilder.
> >     Add in a flush call for all fds to ensure buffers are in sync. This
> >     does appear to improve warnings on the autobuilder now we started detecting
> >     the issue.
> >
> > Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> > ---
> >  meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> > index ff5629c6f9b..67dd887c240 100644
> > --- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> > +++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
> > @@ -7,7 +7,7 @@ HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
> >  LICENSE = "GPL-2.0-or-later"
> >  LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
> >
> > -SRCREV = "bcb82804daa8f725b6add259dcef2067e61a75aa"
> > +SRCREV = "ea2a9cc159ad5f64ee75781d55101d7c340e0303"
> >  PV .= "+git${SRCPV}"
> >
> >  SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \
> > --
> > 2.39.2
> >
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183585): https://lists.openembedded.org/g/openembedded-core/message/183585
> Mute This Topic: https://lists.openembedded.org/mt/99601743/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie June 28, 2023, 9:10 p.m. UTC | #3
On Wed, 2023-06-28 at 16:24 +0200, Alexander Kanavin wrote:
> This appears to have regressed glib-2.0 ptest, particularly:
> Failed ptests:
> {'glib-2.0': ['glib/codegen.py.test']}
> https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/5273/steps/12/logs/stdio
> 
> I didn't yet got to the root cause, just wanted to register where it
> happened. Note that the ptest passes when run directly and fails only
> under ptest-runner, and it somehow is specific to qemux86_64 as well.
> Bizarre, yes.

It happens on qemuarm64 too:

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/5091/steps/12/logs/stdio

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
index ff5629c6f9b..67dd887c240 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
@@ -7,7 +7,7 @@  HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
 LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
 
-SRCREV = "bcb82804daa8f725b6add259dcef2067e61a75aa"
+SRCREV = "ea2a9cc159ad5f64ee75781d55101d7c340e0303"
 PV .= "+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \