diff mbox series

[meta-ti,kirkstone,v2,1/2] u-boot-ti-staging_2023.04: Copy bitmap file to boot partition for AM62x

Message ID 20230614143306.1502763-2-devarsht@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Early splash screen on | expand

Commit Message

Devarsh Thakkar June 14, 2023, 2:33 p.m. UTC
Early splash screen support for AM62x has been enabled in u-boot
and it requires bitmap tarball to be present in boot partition
as per the default environment settings done in u-boot [1].

Copy the ti logo bitmap tarball to boot partition of wic image in order
to enable out of box early display on AM62x.

[1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env

Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
---
V2: Rename ti logo tarball as per suggested changes (same is being
    done in ti-u-boot too)
---
 .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Denys Dmytriyenko June 14, 2023, 2:54 p.m. UTC | #1
On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar via lists.yoctoproject.org wrote:
> Early splash screen support for AM62x has been enabled in u-boot
> and it requires bitmap tarball to be present in boot partition
> as per the default environment settings done in u-boot [1].
> 
> Copy the ti logo bitmap tarball to boot partition of wic image in order
> to enable out of box early display on AM62x.
> 
> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
> 
> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
> ---
> V2: Rename ti logo tarball as per suggested changes (same is being
>     done in ti-u-boot too)
> ---
>  .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>  1 file changed, 9 insertions(+)
> 
> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> index e6da84cb..c948e1ed 100644
> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>  
>  SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>  
> +do_install:append:am62xx() {
> +	install -d ${D}/boot
> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
> +}
> +
> +do_deploy:append:am62xx() {
> +	install -d ${DEPLOYDIR}
> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}

Any specific reason you also need to deploy this loose file?
Devarsh Thakkar June 14, 2023, 3:23 p.m. UTC | #2
Hi Denys,

Thanks for the review,

On 14/06/23 20:24, Denys Dmytriyenko wrote:
> On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar via lists.yoctoproject.org wrote:
>> Early splash screen support for AM62x has been enabled in u-boot
>> and it requires bitmap tarball to be present in boot partition
>> as per the default environment settings done in u-boot [1].
>>
>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>> to enable out of box early display on AM62x.
>>
>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>
>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>> ---
>> V2: Rename ti logo tarball as per suggested changes (same is being
>>     done in ti-u-boot too)
>> ---
>>  .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>  1 file changed, 9 insertions(+)
>>
>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> index e6da84cb..c948e1ed 100644
>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>  
>>  SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>  
>> +do_install:append:am62xx() {
>> +	install -d ${D}/boot
>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>> +}
>> +
>> +do_deploy:append:am62xx() {
>> +	install -d ${DEPLOYDIR}
>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
> 
> Any specific reason you also need to deploy this loose file?
> 

I think the boot partition script which is ran as part of do_image_wic expects
IMAGE_BOOTFILES to be present in deploy directory, I remember getting below
error without doing so :

| ERROR: _exec_cmd: install -m 0644 -D
/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz
/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/tmp-wic/hdd/boot/ti.gz
returned '1' instead of 0
| output: install: cannot stat
'/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz':
No such file or directory
| WARNING:
/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/temp/run.do_image_wic.1581619:162
exit 1 from 'BUILDDIR="/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build"
PSEUDO_UNLOAD=1 wic create "$wks" --vars
"/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/sysroots/am62xx-evm/imgdata/"
-e "tisdk-default-image" -o "$build_wic/" -w "$tmp_wic"'


One more reason to do so was to allow user ease of use, to copy the logo too
from deploy folder along with other boot files (if not flashing from wic
image) since the same is set in am62x.env and if logo is not present in boot
partition then it throws some error message although the device still boots.

Regards
Devarsh
Denys Dmytriyenko June 14, 2023, 3:51 p.m. UTC | #3
On Wed, Jun 14, 2023 at 08:53:07PM +0530, Devarsh Thakkar wrote:
> Hi Denys,
> 
> Thanks for the review,
> 
> On 14/06/23 20:24, Denys Dmytriyenko wrote:
> > On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar via lists.yoctoproject.org wrote:
> >> Early splash screen support for AM62x has been enabled in u-boot
> >> and it requires bitmap tarball to be present in boot partition
> >> as per the default environment settings done in u-boot [1].
> >>
> >> Copy the ti logo bitmap tarball to boot partition of wic image in order
> >> to enable out of box early display on AM62x.
> >>
> >> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
> >>
> >> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
> >> ---
> >> V2: Rename ti logo tarball as per suggested changes (same is being
> >>     done in ti-u-boot too)
> >> ---
> >>  .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
> >>  1 file changed, 9 insertions(+)
> >>
> >> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >> index e6da84cb..c948e1ed 100644
> >> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
> >>  
> >>  SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
> >>  
> >> +do_install:append:am62xx() {
> >> +	install -d ${D}/boot
> >> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
> >> +}
> >> +
> >> +do_deploy:append:am62xx() {
> >> +	install -d ${DEPLOYDIR}
> >> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
> > 
> > Any specific reason you also need to deploy this loose file?
> > 
> 
> I think the boot partition script which is ran as part of do_image_wic expects
> IMAGE_BOOTFILES to be present in deploy directory, I remember getting below
> error without doing so :
> 
> | ERROR: _exec_cmd: install -m 0644 -D
> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz
> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/tmp-wic/hdd/boot/ti.gz
> returned '1' instead of 0
> | output: install: cannot stat
> '/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz':
> No such file or directory
> | WARNING:
> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/temp/run.do_image_wic.1581619:162
> exit 1 from 'BUILDDIR="/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build"
> PSEUDO_UNLOAD=1 wic create "$wks" --vars
> "/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/sysroots/am62xx-evm/imgdata/"
> -e "tisdk-default-image" -o "$build_wic/" -w "$tmp_wic"'

So, is this logo expected by U-boot to reside in the boot partition of SD 
card, or in the /boot directory of the rootfs?
The first is handled by do_deploy and IMAGE_BOOTFILES, while the second is 
handled by do_install. I wonder if doing both is going to be confusing...


> One more reason to do so was to allow user ease of use, to copy the logo too
> from deploy folder along with other boot files (if not flashing from wic
> image) since the same is set in am62x.env and if logo is not present in boot
> partition then it throws some error message although the device still boots.
Devarsh Thakkar June 14, 2023, 4:57 p.m. UTC | #4
On 14/06/23 21:21, Denys Dmytriyenko wrote:
> On Wed, Jun 14, 2023 at 08:53:07PM +0530, Devarsh Thakkar wrote:
>> Hi Denys,
>>
>> Thanks for the review,
>>
>> On 14/06/23 20:24, Denys Dmytriyenko wrote:
>>> On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar via lists.yoctoproject.org wrote:
>>>> Early splash screen support for AM62x has been enabled in u-boot
>>>> and it requires bitmap tarball to be present in boot partition
>>>> as per the default environment settings done in u-boot [1].
>>>>
>>>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>>>> to enable out of box early display on AM62x.
>>>>
>>>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>>>
>>>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>>>> ---
>>>> V2: Rename ti logo tarball as per suggested changes (same is being
>>>>      done in ti-u-boot too)
>>>> ---
>>>>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>>>   1 file changed, 9 insertions(+)
>>>>
>>>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> index e6da84cb..c948e1ed 100644
>>>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>>>   
>>>>   SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>>>   
>>>> +do_install:append:am62xx() {
>>>> +	install -d ${D}/boot
>>>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>>>> +}
>>>> +
>>>> +do_deploy:append:am62xx() {
>>>> +	install -d ${DEPLOYDIR}
>>>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
>>>
>>> Any specific reason you also need to deploy this loose file?
>>>
>>
>> I think the boot partition script which is ran as part of do_image_wic expects
>> IMAGE_BOOTFILES to be present in deploy directory, I remember getting below
>> error without doing so :
>>
>> | ERROR: _exec_cmd: install -m 0644 -D
>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz
>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/tmp-wic/hdd/boot/ti.gz
>> returned '1' instead of 0
>> | output: install: cannot stat
>> '/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz':
>> No such file or directory
>> | WARNING:
>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/temp/run.do_image_wic.1581619:162
>> exit 1 from 'BUILDDIR="/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build"
>> PSEUDO_UNLOAD=1 wic create "$wks" --vars
>> "/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/sysroots/am62xx-evm/imgdata/"
>> -e "tisdk-default-image" -o "$build_wic/" -w "$tmp_wic"'
> 
> So, is this logo expected by U-boot to reside in the boot partition of SD
> card, or in the /boot directory of the rootfs?
> The first is handled by do_deploy and IMAGE_BOOTFILES, while the second is
> handled by do_install. I wonder if doing both is going to be confusing...
> 
> 

Yes, this logo is expected to reside in boot partition of SD only per 
current implementation in ti-u-boot.

Regards
Devarsh

>> One more reason to do so was to allow user ease of use, to copy the logo too
>> from deploy folder along with other boot files (if not flashing from wic
>> image) since the same is set in am62x.env and if logo is not present in boot
>> partition then it throws some error message although the device still boots.
Ryan Eatmon June 14, 2023, 6:16 p.m. UTC | #5
On 6/14/2023 11:57 AM, Devarsh Thakkar wrote:
> 
> 
> On 14/06/23 21:21, Denys Dmytriyenko wrote:
>> On Wed, Jun 14, 2023 at 08:53:07PM +0530, Devarsh Thakkar wrote:
>>> Hi Denys,
>>>
>>> Thanks for the review,
>>>
>>> On 14/06/23 20:24, Denys Dmytriyenko wrote:
>>>> On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar via 
>>>> lists.yoctoproject.org wrote:
>>>>> Early splash screen support for AM62x has been enabled in u-boot
>>>>> and it requires bitmap tarball to be present in boot partition
>>>>> as per the default environment settings done in u-boot [1].
>>>>>
>>>>> Copy the ti logo bitmap tarball to boot partition of wic image in 
>>>>> order
>>>>> to enable out of box early display on AM62x.
>>>>>
>>>>> [1] 
>>>>> https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>>>>
>>>>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>>>>> ---
>>>>> V2: Rename ti logo tarball as per suggested changes (same is being
>>>>>      done in ti-u-boot too)
>>>>> ---
>>>>>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 
>>>>> +++++++++
>>>>>   1 file changed, 9 insertions(+)
>>>>>
>>>>> diff --git 
>>>>> a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb 
>>>>> b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>>> index e6da84cb..c948e1ed 100644
>>>>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>>>>   SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>>>> +do_install:append:am62xx() {
>>>>> +    install -d ${D}/boot
>>>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz 
>>>>> ${D}/boot
>>>>> +}
>>>>> +
>>>>> +do_deploy:append:am62xx() {
>>>>> +    install -d ${DEPLOYDIR}
>>>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz 
>>>>> ${DEPLOYDIR}
>>>>
>>>> Any specific reason you also need to deploy this loose file?
>>>>
>>>
>>> I think the boot partition script which is ran as part of 
>>> do_image_wic expects
>>> IMAGE_BOOTFILES to be present in deploy directory, I remember getting 
>>> below
>>> error without doing so :
>>>
>>> | ERROR: _exec_cmd: install -m 0644 -D
>>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz
>>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/tmp-wic/hdd/boot/ti.gz
>>> returned '1' instead of 0
>>> | output: install: cannot stat
>>> '/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz':
>>> No such file or directory
>>> | WARNING:
>>> /home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/temp/run.do_image_wic.1581619:162
>>> exit 1 from 
>>> 'BUILDDIR="/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build"
>>> PSEUDO_UNLOAD=1 wic create "$wks" --vars
>>> "/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/sysroots/am62xx-evm/imgdata/"
>>> -e "tisdk-default-image" -o "$build_wic/" -w "$tmp_wic"'
>>
>> So, is this logo expected by U-boot to reside in the boot partition of SD
>> card, or in the /boot directory of the rootfs?
>> The first is handled by do_deploy and IMAGE_BOOTFILES, while the 
>> second is
>> handled by do_install. I wonder if doing both is going to be confusing...
>>
>>
> 
> Yes, this logo is expected to reside in boot partition of SD only per 
> current implementation in ti-u-boot.

So then it only requires do_deploy and IMAGE_BOOTFILES since that puts 
items into the boot partition... Do we need the do_install?


> Regards
> Devarsh
> 
>>> One more reason to do so was to allow user ease of use, to copy the 
>>> logo too
>>> from deploy folder along with other boot files (if not flashing from wic
>>> image) since the same is set in am62x.env and if logo is not present 
>>> in boot
>>> partition then it throws some error message although the device still 
>>> boots.
Denys Dmytriyenko June 14, 2023, 11:17 p.m. UTC | #6
On Wed, Jun 14, 2023 at 01:16:13PM -0500, Ryan Eatmon wrote:
> 
> 
> On 6/14/2023 11:57 AM, Devarsh Thakkar wrote:
> >
> >
> >On 14/06/23 21:21, Denys Dmytriyenko wrote:
> >>On Wed, Jun 14, 2023 at 08:53:07PM +0530, Devarsh Thakkar wrote:
> >>>Hi Denys,
> >>>
> >>>Thanks for the review,
> >>>
> >>>On 14/06/23 20:24, Denys Dmytriyenko wrote:
> >>>>On Wed, Jun 14, 2023 at 08:03:05PM +0530, Devarsh Thakkar
> >>>>via lists.yoctoproject.org wrote:
> >>>>>Early splash screen support for AM62x has been enabled in u-boot
> >>>>>and it requires bitmap tarball to be present in boot partition
> >>>>>as per the default environment settings done in u-boot [1].
> >>>>>
> >>>>>Copy the ti logo bitmap tarball to boot partition of wic
> >>>>>image in order
> >>>>>to enable out of box early display on AM62x.
> >>>>>
> >>>>>[1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
> >>>>>
> >>>>>Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
> >>>>>---
> >>>>>V2: Rename ti logo tarball as per suggested changes (same is being
> >>>>>     done in ti-u-boot too)
> >>>>>---
> >>>>>  .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb     
> >>>>>| 9 +++++++++
> >>>>>  1 file changed, 9 insertions(+)
> >>>>>
> >>>>>diff --git
> >>>>>a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >>>>>b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >>>>>index e6da84cb..c948e1ed 100644
> >>>>>--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >>>>>+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >>>>>@@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
> >>>>>  SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
> >>>>>+do_install:append:am62xx() {
> >>>>>+    install -d ${D}/boot
> >>>>>+    install -m 0644
> >>>>>${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
> >>>>>+}
> >>>>>+
> >>>>>+do_deploy:append:am62xx() {
> >>>>>+    install -d ${DEPLOYDIR}
> >>>>>+    install -m 0644
> >>>>>${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
> >>>>
> >>>>Any specific reason you also need to deploy this loose file?
> >>>>
> >>>
> >>>I think the boot partition script which is ran as part of
> >>>do_image_wic expects
> >>>IMAGE_BOOTFILES to be present in deploy directory, I remember
> >>>getting below
> >>>error without doing so :
> >>>
> >>>| ERROR: _exec_cmd: install -m 0644 -D
> >>>/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz
> >>>/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/tmp-wic/hdd/boot/ti.gz
> >>>returned '1' instead of 0
> >>>| output: install: cannot stat
> >>>'/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/deploy/images/am62xx-evm/ti.gz':
> >>>No such file or directory
> >>>| WARNING:
> >>>/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/work/am62xx_evm-oe-linux/tisdk-default-image/1.0-r0/temp/run.do_image_wic.1581619:162
> >>>exit 1 from
> >>>'BUILDDIR="/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build"
> >>>PSEUDO_UNLOAD=1 wic create "$wks" --vars
> >>>"/home/devarsht/ti/yocto_sdk_am62/oe-layersetup/build/arago-tmp-default-glibc/sysroots/am62xx-evm/imgdata/"
> >>>-e "tisdk-default-image" -o "$build_wic/" -w "$tmp_wic"'
> >>
> >>So, is this logo expected by U-boot to reside in the boot partition of SD
> >>card, or in the /boot directory of the rootfs?
> >>The first is handled by do_deploy and IMAGE_BOOTFILES, while the
> >>second is
> >>handled by do_install. I wonder if doing both is going to be confusing...
> >>
> >>
> >
> >Yes, this logo is expected to reside in boot partition of SD only
> >per current implementation in ti-u-boot.
> 
> So then it only requires do_deploy and IMAGE_BOOTFILES since that
> puts items into the boot partition... Do we need the do_install?

Well, thinking a bit more about this, we do the same for all other binaries 
from U-boot build in u-boot-ti.inc and even upstream u-boot.inc - we install 
and deploy them. The installed files go into /boot directory and end up in 
corresponding IPK package, but we do not install it, hence the files are not 
in the rootfs. So this should be fine as is...


> >>>One more reason to do so was to allow user ease of use, to
> >>>copy the logo too
> >>>from deploy folder along with other boot files (if not flashing from wic
> >>>image) since the same is set in am62x.env and if logo is not
> >>>present in boot
> >>>partition then it throws some error message although the
> >>>device still boots.
Ryan Eatmon June 15, 2023, 1:36 p.m. UTC | #7
On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
> Early splash screen support for AM62x has been enabled in u-boot
> and it requires bitmap tarball to be present in boot partition
> as per the default environment settings done in u-boot [1].
> 
> Copy the ti logo bitmap tarball to boot partition of wic image in order
> to enable out of box early display on AM62x.
> 
> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
> 
> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
> ---
> V2: Rename ti logo tarball as per suggested changes (same is being
>      done in ti-u-boot too)
> ---
>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>   1 file changed, 9 insertions(+)
> 
> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> index e6da84cb..c948e1ed 100644
> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>   
>   SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>   
> +do_install:append:am62xx() {
> +	install -d ${D}/boot
> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
> +}
> +
> +do_deploy:append:am62xx() {
> +	install -d ${DEPLOYDIR}
> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
> +}


Denys,

In the longer term, should this be in the u-boot.inc file and not in the 
recipe itself?  That's were all of the other do_* appends are...
Devarsh Thakkar June 15, 2023, 1:58 p.m. UTC | #8
On 15/06/23 19:06, Ryan Eatmon wrote:
> 
> 
> On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
>> Early splash screen support for AM62x has been enabled in u-boot
>> and it requires bitmap tarball to be present in boot partition
>> as per the default environment settings done in u-boot [1].
>>
>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>> to enable out of box early display on AM62x.
>>
>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>
>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>> ---
>> V2: Rename ti logo tarball as per suggested changes (same is being
>>      done in ti-u-boot too)
>> ---
>>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>   1 file changed, 9 insertions(+)
>>
>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> index e6da84cb..c948e1ed 100644
>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>     SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>   +do_install:append:am62xx() {
>> +    install -d ${D}/boot
>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>> +}
>> +
>> +do_deploy:append:am62xx() {
>> +    install -d ${DEPLOYDIR}
>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
>> +}
> 
> 
> Denys,
> 
> In the longer term, should this be in the u-boot.inc file and not in the
> recipe itself?  That's were all of the other do_* appends are...
> 

This I think is specific to u-boot 2023.04 version only as the logos were
recently added and are not available in previous versions of u-boot and hence
I thought to have the changes in u-boot-ti-staging_2023.04.bb

Regards
Devarsh
> 
>
Ryan Eatmon June 15, 2023, 2:09 p.m. UTC | #9
On 6/15/2023 8:58 AM, Devarsh Thakkar wrote:
> 
> 
> On 15/06/23 19:06, Ryan Eatmon wrote:
>>
>>
>> On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
>>> Early splash screen support for AM62x has been enabled in u-boot
>>> and it requires bitmap tarball to be present in boot partition
>>> as per the default environment settings done in u-boot [1].
>>>
>>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>>> to enable out of box early display on AM62x.
>>>
>>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>>
>>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>>> ---
>>> V2: Rename ti logo tarball as per suggested changes (same is being
>>>       done in ti-u-boot too)
>>> ---
>>>    .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>>    1 file changed, 9 insertions(+)
>>>
>>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> index e6da84cb..c948e1ed 100644
>>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>>      SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>>    +do_install:append:am62xx() {
>>> +    install -d ${D}/boot
>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>>> +}
>>> +
>>> +do_deploy:append:am62xx() {
>>> +    install -d ${DEPLOYDIR}
>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
>>> +}
>>
>>
>> Denys,
>>
>> In the longer term, should this be in the u-boot.inc file and not in the
>> recipe itself?  That's were all of the other do_* appends are...
>>
> 
> This I think is specific to u-boot 2023.04 version only as the logos were
> recently added and are not available in previous versions of u-boot and hence
> I thought to have the changes in u-boot-ti-staging_2023.04.bb

But they will be there going forward and the only other version is 
mainline which is meant to track the latest of u-boot which 
theoretically will contain the logos.

Maybe the best plan would be to create a ti-logos.inc and put these 
statements in there and add an include to that file in the recipe.  Just 
trying to keep the spirit of the recipe.  We can then not include the 
logos in mainline if they are not working.


> Regards
> Devarsh
>>
>>
Denys Dmytriyenko June 15, 2023, 2:10 p.m. UTC | #10
On Thu, Jun 15, 2023 at 08:36:36AM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
> 
> 
> On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
> >Early splash screen support for AM62x has been enabled in u-boot
> >and it requires bitmap tarball to be present in boot partition
> >as per the default environment settings done in u-boot [1].
> >
> >Copy the ti logo bitmap tarball to boot partition of wic image in order
> >to enable out of box early display on AM62x.
> >
> >[1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
> >
> >Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
> >---
> >V2: Rename ti logo tarball as per suggested changes (same is being
> >     done in ti-u-boot too)
> >---
> >  .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
> >  1 file changed, 9 insertions(+)
> >
> >diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >index e6da84cb..c948e1ed 100644
> >--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
> >@@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
> >  SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
> >+do_install:append:am62xx() {
> >+	install -d ${D}/boot
> >+	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
> >+}
> >+
> >+do_deploy:append:am62xx() {
> >+	install -d ${DEPLOYDIR}
> >+	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
> >+}
> 
> 
> Denys,
> 
> In the longer term, should this be in the u-boot.inc file and not in
> the recipe itself?  That's were all of the other do_* appends are...

In the longer term I was going to ask if this logo should be enabled for 
all TI platforms, instead of just am62x?
Ryan Eatmon June 15, 2023, 2:12 p.m. UTC | #11
On 6/15/2023 9:10 AM, Denys Dmytriyenko wrote:
> On Thu, Jun 15, 2023 at 08:36:36AM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
>>
>>
>> On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
>>> Early splash screen support for AM62x has been enabled in u-boot
>>> and it requires bitmap tarball to be present in boot partition
>>> as per the default environment settings done in u-boot [1].
>>>
>>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>>> to enable out of box early display on AM62x.
>>>
>>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>>
>>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>>> ---
>>> V2: Rename ti logo tarball as per suggested changes (same is being
>>>      done in ti-u-boot too)
>>> ---
>>>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>>   1 file changed, 9 insertions(+)
>>>
>>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> index e6da84cb..c948e1ed 100644
>>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>>   SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>> +do_install:append:am62xx() {
>>> +	install -d ${D}/boot
>>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>>> +}
>>> +
>>> +do_deploy:append:am62xx() {
>>> +	install -d ${DEPLOYDIR}
>>> +	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
>>> +}
>>
>>
>> Denys,
>>
>> In the longer term, should this be in the u-boot.inc file and not in
>> the recipe itself?  That's were all of the other do_* appends are...
> 
> In the longer term I was going to ask if this logo should be enabled for
> all TI platforms, instead of just am62x?

Valid question.
Devarsh Thakkar June 15, 2023, 2:17 p.m. UTC | #12
On 15/06/23 19:42, Ryan Eatmon wrote:
> 
> 
> On 6/15/2023 9:10 AM, Denys Dmytriyenko wrote:
>> On Thu, Jun 15, 2023 at 08:36:36AM -0500, Ryan Eatmon via
>> lists.yoctoproject.org wrote:
>>>
>>>
>>> On 6/14/2023 9:33 AM, Devarsh Thakkar wrote:
>>>> Early splash screen support for AM62x has been enabled in u-boot
>>>> and it requires bitmap tarball to be present in boot partition
>>>> as per the default environment settings done in u-boot [1].
>>>>
>>>> Copy the ti logo bitmap tarball to boot partition of wic image in order
>>>> to enable out of box early display on AM62x.
>>>>
>>>> [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env
>>>>
>>>> Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
>>>> ---
>>>> V2: Rename ti logo tarball as per suggested changes (same is being
>>>>      done in ti-u-boot too)
>>>> ---
>>>>   .../recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb      | 9 +++++++++
>>>>   1 file changed, 9 insertions(+)
>>>>
>>>> diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> index e6da84cb..c948e1ed 100644
>>>> --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
>>>> @@ -8,3 +8,12 @@ BRANCH = "ti-u-boot-2023.04"
>>>>   SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
>>>> +do_install:append:am62xx() {
>>>> +    install -d ${D}/boot
>>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
>>>> +}
>>>> +
>>>> +do_deploy:append:am62xx() {
>>>> +    install -d ${DEPLOYDIR}
>>>> +    install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz
>>>> ${DEPLOYDIR}
>>>> +}
>>>
>>>
>>> Denys,
>>>
>>> In the longer term, should this be in the u-boot.inc file and not in
>>> the recipe itself?  That's were all of the other do_* appends are...
>>
>> In the longer term I was going to ask if this logo should be enabled for
>> all TI platforms, instead of just am62x?
> 
> Valid question.
> 

I am not sure about all but I see it as possibility for many TI K3 platforms
having display support displaying logo during bootup in future, although they
may use different files for logo depending upon resolution, memory e.t.c.

Regards
Devarsh
>
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
index e6da84cb..c948e1ed 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
@@ -8,3 +8,12 @@  BRANCH = "ti-u-boot-2023.04"
 
 SRCREV = "1f510931dcc90e6f28f7fed757ad5000d4382e22"
 
+do_install:append:am62xx() {
+	install -d ${D}/boot
+	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
+}
+
+do_deploy:append:am62xx() {
+	install -d ${DEPLOYDIR}
+	install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
+}