diff mbox series

[42/55] python3-pyasn1: upgrade 0.4.8 -> 0.5.0

Message ID 20230614092918.4065570-42-alex@linutronix.de
State Accepted, archived
Commit d36e4228bd94ae9a9ca0feeaa9541ed5afafdd44
Headers show
Series [01/55] insane.bbclass: add a SUMMARY/HOMEPAGE check (oe-core recipes only) | expand

Commit Message

Alexander Kanavin June 14, 2023, 9:29 a.m. UTC
License-Update: copyright years

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../recipes-devtools/python/python-pyasn1.inc | 10 +++----
 ...arning-__int__-returned-non-int-on-P.patch | 28 -------------------
 ...yasn1_0.4.8.bb => python3-pyasn1_0.5.0.bb} |  1 +
 3 files changed, 5 insertions(+), 34 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
 rename meta/recipes-devtools/python/{python3-pyasn1_0.4.8.bb => python3-pyasn1_0.5.0.bb} (98%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-pyasn1.inc b/meta/recipes-devtools/python/python-pyasn1.inc
index 126d0388efa..9eb87354cf3 100644
--- a/meta/recipes-devtools/python/python-pyasn1.inc
+++ b/meta/recipes-devtools/python/python-pyasn1.inc
@@ -1,10 +1,9 @@ 
 SUMMARY = "Python library implementing ASN.1 types."
 HOMEPAGE = "http://pyasn1.sourceforge.net/"
 LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=a14482d15c2249de3b6f0e8a47e021fd"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=190f79253908c986e6cacf380c3a5f6d"
 
-SRC_URI[md5sum] = "dffae4ff9f997a83324b3f33fe62be54"
-SRC_URI[sha256sum] = "aef77c9fb94a3ac588e87841208bdec464471d9871bd5050a287cc9a475cd0ba"
+SRC_URI[sha256sum] = "97b7290ca68e62a832558ec3976f15cbf911bf5d7c7039d8b861c2a0ece69fde"
 
 RDEPENDS:${PN}:class-target += " \
     ${PYTHON_PN}-codecs \
@@ -18,9 +17,8 @@  BBCLASSEXTEND = "native nativesdk"
 inherit ptest
 
 SRC_URI += " \
-	file://run-ptest \
-	file://0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch \
-"
+       file://run-ptest \
+           "
 
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
diff --git a/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch b/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
deleted file mode 100644
index 30ac9a66843..00000000000
--- a/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-From db8f1a7930c6b5826357646746337dafc983f953 Mon Sep 17 00:00:00 2001
-From: Ilya Etingof <etingof@gmail.com>
-Date: Sat, 21 Mar 2020 19:05:03 +0100
-Subject: [PATCH] Fix `DeprecationWarning: __int__ returned non-int` on Py3
-
-In `BitString.__int__()`
-Upstream-Status: Backport
-Signed-off-by: Yulong Liu <yulong.liu@windriver.com>
----
- pyasn1/type/univ.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pyasn1/type/univ.py b/pyasn1/type/univ.py
-index 10924c3..488241f 100644
---- a/pyasn1/type/univ.py
-+++ b/pyasn1/type/univ.py
-@@ -551,7 +551,7 @@ class BitString(base.SimpleAsn1Type):
-         return self.clone(SizedInteger(self._value >> count).setBitLength(max(0, len(self._value) - count)))
- 
-     def __int__(self):
--        return self._value
-+        return int(self._value)
- 
-     def __float__(self):
-         return float(self._value)
--- 
-2.25.1
-
diff --git a/meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb b/meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
similarity index 98%
rename from meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb
rename to meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
index a5e2a713626..0519ba5edb0 100644
--- a/meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb
+++ b/meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
@@ -1,2 +1,3 @@ 
 inherit pypi setuptools3
 require python-pyasn1.inc
+