[meta-oe] nlohmann-json: upgrade 3.10.4 -> 3.10.5

Message ID 1642379337-12144-2-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe] nlohmann-json: upgrade 3.10.4 -> 3.10.5 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 17, 2022, 12:28 a.m. UTC
License-Update: year updated to 2022.

Changelog:
=========
Bug fixes
---------
Make sure C++17 filesystem conversions are only used if the compiler supports
it. Furthermore, add defines JSON_HAS_FILESYSTEM and
JSON_HAS_EXPERIMENTAL_FILESYSTEM which can be set to 0 to avoid using
filesystem support altogether.std::filesystem. #3090 #3097 #3101 #3156 #3203
Fix a compilation error with Nvidia CUDA Compiler (NVCC). #3013 #3234

Warnings
---------
Fix a warning for shadowed variables. #3188 #3193
Fix a warning on a pointless comparison. #3227 #2712 #2676 #1390 #755

Improvements
------------
Add a parameter to the update function to recursively merge objects with common
keys. #3006 #3069
Extend std::hash and std::swap to work on any nlohmann::basic_json
specializations rather than just nlohmann::json. #3121

Further Changes
--------------
Tests and CI
Update CI to use Clang 14, GCC 6, and Clang-Tidy 14. #3088
Update cpplint. #3225
Add build step for the Nvidia CUDA Compiler (NVCC). #3227
Remove Travis CI. #3087 #3233
Compile and execute the test suite with C++17. #3101

Documentation
--------------
The mkdocs-based documentation in doc/mkdocs has been totally overworked. It now
has a unified structure, more examples, and contains all information from the
previous Doxygen-based documentation. The single source of truth is now the
documentation on https://json.nlohmann.me and in particular the API
Documentation. #3071
Removed Wandbox online examples. #3071
Fix typos, links, and parameter names in the documentation.
Add more examples. #3071 #3100

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{nlohmann-json_3.10.4.bb => nlohmann-json_3.10.5.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-oe/recipes-devtools/nlohmann-json/{nlohmann-json_3.10.4.bb => nlohmann-json_3.10.5.bb} (82%)

Patch

diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.4.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
similarity index 82%
rename from meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.4.bb
rename to meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
index 223b141d1..a69c5c7e5 100644
--- a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.4.bb
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.10.5.bb
@@ -2,12 +2,12 @@  SUMMARY = "JSON for modern C++"
 HOMEPAGE = "https://nlohmann.github.io/json/"
 SECTION = "libs"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=441793d25a658d58d79a1f87516a6ad1"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588"
 
 SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \
            "
 
-SRCREV = "fec56a1a16c6e1c1b1f4e116a20e79398282626c"
+SRCREV = "4f8fba14066156b73f1189a2b8bd568bde5284c5"
 
 S = "${WORKDIR}/git"