diff mbox series

[kirkstone,v3] Add linux-ti-extras, u-boot-ti-extras recipe and make jailhouse recipe depend on MACHINE_FEATURES.

Message ID 20230606144626.181511-1-p-bhagat@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [kirkstone,v3] Add linux-ti-extras, u-boot-ti-extras recipe and make jailhouse recipe depend on MACHINE_FEATURES. | expand

Commit Message

Paresh Bhagat June 6, 2023, 2:46 p.m. UTC
Add new recipe for u-boot-ti-extras and linux-ti-extras which will fetch
processor-sdk/uboot and processor-sdk/linux respectively. This recipes,
presently will only be used for jailhouse by changing BRANCH and
SRCREV to jailhouse branch via MACHINE_FEATURES.

In future, if a new feature is hosted in a separate branch, only BRANCH and
SRCREV needs to be changed to respective feature branch in this recipe itself.

Also going forward make jailhouse recipe depend on machine_feature variable.
jailhouse recipe will only be build if MACHINE_FEATURES include jailhouse.

Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
---
 meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-extras.bb   |  9 +++++++++
 meta-ti-bsp/recipes-kernel/linux/linux-ti-extras.bb  | 10 ++++++++++
 meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb |  2 ++
 3 files changed, 21 insertions(+)
 create mode 100644 meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-extras.bb
 create mode 100644 meta-ti-bsp/recipes-kernel/linux/linux-ti-extras.bb
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-extras.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-extras.bb
new file mode 100644
index 00000000..dcd5aea2
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-extras.bb
@@ -0,0 +1,9 @@ 
+require u-boot-ti-staging_2023.04.bb
+
+# This will have priority over generic uboot path
+
+BRANCH = "${@bb.utils.contains('MACHINE_FEATURES','jailhouse','ti-u-boot-2023.04-jailhouse','ti-u-boot-2023.04',d)}"
+
+SRCREV = "${@bb.utils.contains('MACHINE_FEATURES','jailhouse','79615e1c99b9aa73948f811f5f866cff2e34dc37','010afc1fe7a1412f92363c8af69c848d76a53e42',d)}"
+
+UBOOT_GIT_URI = "git://git.ti.com/git/processor-sdk/u-boot.git"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-extras.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-extras.bb
new file mode 100644
index 00000000..fe0a431d
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-extras.bb
@@ -0,0 +1,10 @@ 
+require linux-ti-staging_6.1.bb
+
+# Use different commit, repo and branch for jailhouse build
+# This will have priority over generic rt path
+
+BRANCH = "${@bb.utils.contains('MACHINE_FEATURES','jailhouse','ti-linux-6.1.y-jailhouse','ti-linux-6.1.y',d)}"
+
+SRCREV = "${@bb.utils.contains('MACHINE_FEATURES','jailhouse','0ed0dec2462b805b0188fe080895adc437871549','30bcc25e7cb1b25667db88d61828728f0f0b5f4b',d)}"
+
+KERNEL_GIT_URI = "git://git.ti.com/git/processor-sdk/linux.git"
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
index 05cc21b3..4336c487 100644
--- a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
+++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
@@ -10,6 +10,8 @@  LIC_FILES_CHKSUM = " \
     file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
 "
 
+REQUIRED_MACHINE_FEATURES = "jailhouse"
+
 TARGET_CC_ARCH += "${LDFLAGS}"
 
 PV = "0.12+git${SRCPV}"