diff mbox series

[meta-python] python3-cachecontrol: upgrade 0.12.12 -> 0.13.0

Message ID 1685951589-29920-11-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-cachecontrol: upgrade 0.12.12 -> 0.13.0 | expand

Commit Message

Mingyu Wang (Fujitsu) June 5, 2023, 7:53 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
    Fix #292: disuse HTTPResponse.strict
    fix: double reading error on urllib3 2.0
    Packaging the tests, or not
    Add type annotations
    Use Python's unittest mock
    feat: remove compat module
    tests: Support python 3.11
    fix: use pytest native method name
    Remove use of utcnow
    Release 0.13.0

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...cachecontrol_0.12.12.bb => python3-cachecontrol_0.13.0.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-cachecontrol_0.12.12.bb => python3-cachecontrol_0.13.0.bb} (84%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.12.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.0.bb
similarity index 84%
rename from meta-python/recipes-devtools/python/python3-cachecontrol_0.12.12.bb
rename to meta-python/recipes-devtools/python/python3-cachecontrol_0.13.0.bb
index 8f7185b8f5..e4e3c49988 100644
--- a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.12.bb
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.0.bb
@@ -1,13 +1,13 @@ 
 SUMMARY = "httplib2 caching for requests"
 HOMEPAGE = "https://pypi.org/project/CacheControl/"
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=942a721dac34d073453642ffe5fcf546"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=e2fd6ddcf506e08972d5ba4b93c0022e"
 
 # On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
 # override PYPI_PACKAGE so fetch succeeds.
 PYPI_PACKAGE = "CacheControl"
 
-SRC_URI[sha256sum] = "9c2e5208ea76ebd9921176569743ddf6d7f3bb4188dbf61806f0f8fc48ecad38"
+SRC_URI[sha256sum] = "fd3fd2cb0ca66b9a6c1d56cc9709e7e49c63dbd19b1b1bcbd8d3f94cedfe8ce5"
 
 inherit pypi setuptools3