diff mbox series

[meta-python,007/149] python3-mock: cleanup RDEPENDS

Message ID 20230531082437.10646-8-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski May 31, 2023, 8:22 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Drop PYTHON_PN, improve coding-style and order the dependencies
alphabetically.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../recipes-devtools/python/python3-mock_5.0.2.bb  | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-mock_5.0.2.bb b/meta-python/recipes-devtools/python/python3-mock_5.0.2.bb
index 633b6f277..6753d2cbf 100644
--- a/meta-python/recipes-devtools/python/python3-mock_5.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-mock_5.0.2.bb
@@ -6,11 +6,13 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
 
 inherit pypi setuptools3
 
-RDEPENDS:${PN} += "${PYTHON_PN}-prettytable \
-            ${PYTHON_PN}-cmd2 \
-            ${PYTHON_PN}-pyparsing \
-            ${PYTHON_PN}-mccabe \
-            ${PYTHON_PN}-pep8 \
-            ${PYTHON_PN}-pyflakes"
+RDEPENDS:${PN} += " \
+    python3-cmd2 \
+    python3-mccabe \
+    python3-pep8 \
+    python3-prettytable \
+    python3-pyflakes \
+    python3-pyparsing \
+"
 
 SRC_URI[sha256sum] = "06f18d7d65b44428202b145a9a36e99c2ee00d1eb992df0caf881d4664377891"